Jump to content
LaunchBox Community Forums
Tackett1980

Cant get AV receiver to be seen in windows as an input device for HDMI audio

Recommended Posts

i realize this is probably a windows 10 specific question and not a launchbox problem, but maybe some smart person will know the answer to this. 

I want to mirror my display to my home theater so that I can play PC games like homeworld on my projector from my couch as well as some other games like final fantasy and other games that arent necessarily conducive to standing for hours.

I also am working on dynamic marquees which is taking up the second slot of the video output of my graphics card which is a gt1030.

So to accomplish this I ran the HDMI out to a splitter, then ran one output of the splitter to the cabinet monitor and plugged that into the monitor via a hdmi to dvi adapter.

the second output of the splitter  I ran to a flush mount HDMI jack on the back of the cabinet then, from there, I ran a 50' redmere cable to my home theater receiver.

My audio setup is using the standard 3.5mm audio jack from the on board sound to some pc speakers and a subwoofer in the cabinet to get audio to the cabinet. 

The issue here is that with this setup, when I run the home theater I get no HDMI audio.  I get  video as I sit here and type this on my projector but there is zero audio.  

If I go  into my audio settings in windows 10 it is not detecting my receiver, it simply says there are no devices available and all I have to choose from is the on board audio device. 

Does anyone know how I can get windows to detect the receiver with this setup, or some way to trick it into just spitting the dang audio out of hdmi?  This is driving me nuts.  Freaking cant stand windows. 

 

 

 

Share this post


Link to post
Share on other sites

My guess it's the splitter. But use Process of Elimination...

A)   Swap the outputs of the splitter.  Test.

B)   Take out the splitter completely and run just to the DVR.  Test.

C)   Same as 'B', but bypass the pass-through in the back of the cab.  Test.

D)   Either 'B' or 'C' AND unplug from the DVI 

Is the HDMI port 'tagged' as Monitor 1 and the DVI as 'Monitor' 2 in Windows?  If not, the DVI could be "hijacking" the audio such that Windows only uses the Motherboard's audio out jack.

Share this post


Link to post
Share on other sites
10 hours ago, Tackett1980 said:

If I go  into my audio settings in windows 10 it is not detecting my receiver, it simply says there are no devices available and all I have to choose from is the on board audio device. 

My guess here is the splitter as well. The fact you have a image means that the HDMI is working, so you should also have the audio option, the fact that you dont could be the splitter stripping the audio out, maybe for HDCP reasons? Or is it passing a format the splitter cant handle for some reason?

As @JoeViking245 says, id try without the splitter first as that is my suspect. Also in the audio options make sure you have the "show disconnected" and "show Disabled" device options checked, and see if it shows as a device.

Share this post


Link to post
Share on other sites
7 hours ago, neil9000 said:

My guess here is the splitter as well. The fact you have a image means that the HDMI is working, so you should also have the audio option, the fact that you dont could be the splitter stripping the audio out, maybe for HDCP reasons? Or is it passing a format the splitter cant handle for some reason?

As @JoeViking245 says, id try without the splitter first as that is my suspect. Also in the audio options make sure you have the "show disconnected" and "show Disabled" device options checked, and see if it shows as a device.

It was in fact the splitter.  I bought a usb to hdmi adapter and hooked that to the marquee, one output on the graphics card to the cabinet monitor and one to my AVR.

 

Of course, it just can’t work the way I want it to without some kind of frickin issue to work through.

So, my computer now sees monitor 1, 2 and 3.  My cabinet monitor is 2, my marquee screen is 1 and my AVR/projector is 3.  My default monitor is 2.

What I’m trying to accomplish is whenever I want to play a game on the couch like Homeworld, half-life, final fantasy, etc I want to sit on my couch and play it rather than standing in front of my cabinet.  
 

The issue is a couple of things:

If I have this set up with all 3 screens as “extend” and the projector turned off, the stupid thing still shows up as connected so it’s throwing things default to the projector totally off screen where I can’t get to them without turning it on.

if I set it up to mirror, I can’t independently change the resolution of the projector which is 16:9 from the mirrored display which is 4:3.  That’s not a big deal when playing a 4:3 game but when I want to play a 16:9 game I have to jack around with the settings to get it to work, then do it again when I quit to get the cabinet to work.

so, I guess it boils down to:

Is there a way in windows to have display 3 default disconnected and only turned on when I launch a certain game, then disconnect again when that game is closed.  For instance, I will never ever play certain games on my cabinet.  Never.  

An example of what I’m taking about would be.

I stand in front of big box and say, “I feel like playing Homeworld right now.” I go click Homeworld and launch it.  My AVR and projector then turns on and the game is displayed over there.  I play what I want, exit the game, and it goes back to displaying on monitor 2.

is this even possible?

Share this post


Link to post
Share on other sites

Anything is possible.  :) 

You could use something like Display Fusion or Monitor Profile Switcher.  I can't personally attest to Display fusion (mainly because I'm cheap frugal) but have heard many great things!  For my cab, I use Monitor Profile Switcher, but for when starting BB.  Not on a game-by-game basis. 

forums.launchbox-app.com/topic/47734-easy-multiple-monitor-configuration-switching-solved

So you could setup your 'monitor profiles', then then set up the games you want 'switched' to switch Automatically Run Before Main Application and the switch back Automatically Run Main Application by adding Additional Applications to each.

As for turning on the AVR and projector.... that gets you into the realm of CEC or home automation and the sort.  But if you can get that working, may as well connect the coffeepot to the macro too and dim the lights. 😊

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...