Jump to content
LaunchBox Community Forums

10.14-beta-1 Released


Recommended Posts

  • Replies 113
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hey all, the first 10.14 beta out now with the following: Improvement: Handling of multiple instances of LaunchBox and Big Box has been improved with a proper message instead of just endin

The official version 10.14 is out now guys, and 10.12 and 10.13 can no longer upload high scores. All previous scores have also been reset.

FYI all, all is looking good with the release, and clearly the vast majority vote is to reset the high scores. I will be putting out the 10.14 release here shortly this morning, then disabling submitt

Posted Images

3 minutes ago, ItchyRobot said:

seems to be running good on my end. I couldn't get a high score to save my life, but it didn't mess any of my controls up or mess with my bezel layout... which i was hesitant since so much data is inside those files.

In the end I decided not to change those files; we only read them. We simply refuse to upload the high score if we find any dip switches changed.

  • Like 2
Link to post
Share on other sites
1 hour ago, Jason Carr said:

In the end I decided not to change those files; we only read them. We simply refuse to upload the high score if we find any dip switches changed.

will that show in the debug log?  If settings were changed prior, can we reset the switches and have scores uploaded? Not sure if you can/will answer how it works, but is it reading the cfg file for mentions of dip switches?  it looks like more than just the dip switch settings are saved in the cfg files.

Link to post
Share on other sites
2 minutes ago, ed20910 said:

will that show in the debug log?  If settings were changed prior, can we reset the switches and have scores uploaded? Not sure if you can/will answer how it works, but is it reading the cfg file for mentions of dip switches?  it looks like more than just the dip switch settings are saved in the cfg files.

Yes, it's reading the cfg files for dip switch settings. You can remove those from the cfg files if you need, or just delete the cfg files. And yes, it shows in the logs. If you can test though, I'd appreciate it.

  • Thanks 1
Link to post
Share on other sites
5 hours ago, Jason Carr said:

No nag versions are definitely usable, yes. That's what I use.

Just following this up, the no nag should never interfere with normal mame operations, as the changes are ui orientated. If anything changes in the future i will make sure its noted in the downloads.

  • Like 1
Link to post
Share on other sites
8 hours ago, Jason Carr said:

I believe that's the first I've heard that request. Not possible currently, unfortunately. Can you add a Bitbucket ticket for it?

Okay, done.

I know you're busy with the MAME high scores thing right now, understandably. Hope this request doesn't find it's way to the wayside like when you minimize LB and and re-open it from from the taskbar, the sound is still going from post back a couple versions ago.

Just out of curiosity, is anyone getting this error when they update to new beta version. been happening to me most about every time since v10. It seems to install fine, get the error, close app, then re-open and all is good.?

 

Untitled.jpg

Edited by Wanderer189
Link to post
Share on other sites
1 minute ago, Wanderer189 said:

Okay, done.

I know you're busy with the MAME high scores thing right now, understandably. Hope this request doesn't find it's way to the wayside like when you minimize LB and and re-open it from from the taskbar, the sound is still going from post back a couple versions ago.

Just out of curiosity, is anyone getting this error when they update to new beta version. been happening to most about every time since v10. It seems to install fine, get the error, close app, then re-open and all is good.?

 

Untitled.jpg

I believe that error happens when administrative rights are refused for the DirectX install (or it times out asking).

Link to post
Share on other sites
1 minute ago, Wanderer189 said:

So nothing has changed on my system, other than normal windows updates, how is it fixed?

You should be able to safely ignore it, assuming DirectX was already installed. It should be prompting you to log in as an administrator though, or approve administrator rights. If it's not, there's probably some kind of non-standard Windows policy setting in place.

Link to post
Share on other sites

I don't have LB installed on "C" drive, so it generally wouldn't ask for admin rights, and with current win10, if you grant admin rights, it really messes with with NAS issues if the roms are stored on a NAS

 

I do ignore it, just wanted to report it as a problem

Edited by Wanderer189
Link to post
Share on other sites
12 hours ago, Wanderer189 said:

@Jason Carr: Is it possible to get a Blank game Video added to LB like the Blank game image? So if there is not a video, we can have it fall back to a default video? Currently I am making a copy and renaming it, but that is a pain a big waste of HDD space.

A quick hack for this is to use a symbolic link from the source video, and just rename the symbolic link as needed, i use this for multiple files/folder in LB that use matching media and even my  data folder and image cache folders use these as i have them active on another drive.

HardLink Shell Extension. This is probably the best an easiest app to use to create links, install right click folder/file and select 'Pick Link Source' then right click in the location you want it and you will either be ablew to choose 'Drop As' or Drop as Symbolic Link. Hope that helps you for the time being.

Link to post
Share on other sites
4 minutes ago, MadK9 said:

A quick hack for this is to use a symbolic link from the source video, and just rename the symbolic link as needed, i use this for multiple files/folder in LB that use matching media and even my  data folder and image cache folders use these as i have them active on another drive.

HardLink Shell Extension. This is probably the best an easiest app to use to create links, install right click folder/file and select 'Pick Link Source' then right click in the location you want it and you will either be ablew to choose 'Drop As' or Drop as Symbolic Link. Hope that helps you for the time being.

I will most definitely have to look into this, thank you for the reply

Link to post
Share on other sites
10 minutes ago, Wanderer189 said:

I don't have LB installed on "C" drive, so it generally wouldn't ask for admin rights, and with current win10, if you grant admin rights, it really messes with with NAS issues if the roms are stored on a NAS

 

I do ignore it, just wanted to report it as a problem

It's the DirectX install part that needs admin rights. It doesn't matter where you install it. And it has nothing to do with any NAS issues or anything of that sort.

Link to post
Share on other sites
6 minutes ago, Jason Carr said:

It's the DirectX install part that needs admin rights. It doesn't matter where you install it. And it has nothing to do with any NAS issues or anything of that sort.

Thanks Jason, but if it was working in the past, and I haven't changed DirectX rights (never fool with that kinda stuff, unless something like this is brought to my attention), what should I check? Where do I need to go to check? 

I mean all was good, then not.

Link to post
Share on other sites
12 minutes ago, Wanderer189 said:

Thanks Jason, but if it was working in the past, and I haven't changed DirectX rights (never fool with that kinda stuff, unless something like this is brought to my attention), what should I check? Where do I need to go to check? 

I mean all was good, then not.

I would say first re-run the setup process to see if you're prompted for admin rights. Sometimes that error happens just because it times out (pops up a request for admin rights and doesn't get a click fast enough).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...