Jump to content
LaunchBox Community Forums
Jason Carr

10.15-beta-1 Released

Recommended Posts

Posted (edited)
42 minutes ago, neil9000 said:

image.thumb.png.025752caea5755acf86150d813576a6d.png

When idle in the background, yes, but when I click and browse it can get from 2 to 2,5 GB. Also, just after launching the app. I closed it, but it still remained in the task manager for a long time. I had to manually close it. Generally, it's worst after launching. Then, it's better. But it definatley has high peaks to 2,5 GB.

1.thumb.png.fbc7d8a1fa3ee18d44bbf6129ca3b5dd.pngIt can drop to 1,9 GB when I do nothing.

And record (over 3 GB RAM):

3.thumb.png.79a4d94b353ff80004e9815ad7e5638c.png

Edited by Pixel

Share this post


Link to post
Share on other sites

Any chance we can see a tiny QOL feature added: You can select/deselect multiple files from the Clean Up Media tool. It's either all or nothing and when you have thousands of results and only want to select half.... (just the Duplicates or just the File not in use), you can't do that without individually selecting each of the thousands of results... which makes the tool impractical. \

Just a tiny request that shouldn't be hard to do.. if time permits of course.

Thanks.

Share this post


Link to post
Share on other sites
37 minutes ago, Pixel said:

When idle in the background, yes, but when I click and browse it can get from 2 to 2,5 GB. Also, just after launching the app. I closed it, but it still remained in the task manager for a long time. I had to manually close it. Generally, it's worst after launching. Then, it's better. But it definatley has high peaks to 2,5 GB.

1.thumb.png.fbc7d8a1fa3ee18d44bbf6129ca3b5dd.pngIt can drop to 1,9GB when I do nothing.

And record:

2.thumb.png.004d1c48ad37f10d678600f505a5331d.png

That's about normal for what I have seen for a while now. Mine ranges anywhere from 1.5-2.5 depending on what I am doing in LB.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, Retro808 said:

That's about normal for what I have seen for a while now. Mine ranges anywhere from 1.5-2.5 depending on what I am doing in LB.

Yeah, at the moment I am doing nothing and it just stays at 2,5 GB RAM. It won't drop at all. However, sometimes it drops to 1 GB. So I have no idea why is that...

Edited by Pixel

Share this post


Link to post
Share on other sites
20 hours ago, TheNewClassics said:

Thanks LB team, Origin games are importing well now for me. On a side note, is there a way to have it so that the Origin Client doesn't stay open when you exit the game? I notice that when I quit an Origin game, my Origin page is open and I need to close it in order to get back to BB. I've left the option unchecked to Launch game with Origin Client in options

Thanks, we're looking into that. Stupid Origin. ;)

19 hours ago, code88 said:

I've found a small visual glitch in the name of the games of the new theme. This has been here since the theme was released but I was waiting until having time to test it in a clean install.

I attached the images that show how some labels are correctly rendered (Cruis'n USA) but others look blurred (Top Gear). I also added a zoomed image with both texts side by side so you can easily see the differences. This difference in rendering seems to depend on the row.
 

Screenshot_8.jpg

Screenshot_11.jpg

Screenshot_8 - copia.jpg

This is mostly out of our control I think. I checked on my system and it doesn't appear to be doing that, but it's entirely controlled by Windows and WPF/XAML. It could be due to any number of things, from your video card or monitor drivers to your ClearType configuration, or even your resolution if you have a small resolution maybe.

8 hours ago, jetbootjack said:

The slight oddity was I went in removed all the background image types and all good, then on reboot they were all selected again - so had to deselect twice.

Updated my second system and had the same issue, needed to do it twice to stick...

Thankfully now all good, and I am once again serenely enjoying Launchbox!

I too use Game Pass and just create windows shortcuts to the games and import those - works like a champ, admittedly it is manual though - I guess you are using the same process?

         sTeVE

Previous versions had added in the new image types from the various integrations (Origin, Uplay, etc.), so that's my guess as to what's going on. We've cleaned all that up now though so that there's less stuff added and the defaults are much more paired down.

Share this post


Link to post
Share on other sites
5 hours ago, rockohoward said:

Is it possible to allow installing/updating from the root of a drive in the future? 

I remember that issue from years ago, but hasn't come up in ages iirc. Where are you seeing a problem with that?

2 hours ago, Pixel said:

Why does LB uses 2,5 GB RAM? I think this is not supposed to be like that.

That's pretty normal for apps these days, especially apps that use so much media. We can always reduce RAM usage, but performance is likely to suffer as a result.

Share this post


Link to post
Share on other sites
20 hours ago, TheNewClassics said:

Thanks LB team, Origin games are importing well now for me. On a side note, is there a way to have it so that the Origin Client doesn't stay open when you exit the game? I notice that when I quit an Origin game, my Origin page is open and I need to close it in order to get back to BB. I've left the option unchecked to Launch game with Origin Client in options

There is a option to not show Origin after gameplay in its options.

image.thumb.png.5346423632b229b416d0540e16f60460.png

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, neil9000 said:

There is a option to not show Origin after gameplay in its options.

image.thumb.png.5346423632b229b416d0540e16f60460.png

Bingo, thanks Neil. Sucks that it's enabled by default, but it's probably better to use that than to hack in a way to hide it.

Share this post


Link to post
Share on other sites

I have an issue with some imported Origin games.

I can't start the Origin version anymore when a game from Origin gets merged with another version of the same game (in my case the Steam or GOG versions). Origin opens up but nothing happens.

When I edit the merged game (doesn't matter if I change a field as long as I close it with the OK button) the game also loses its Origin badge. Once the Origin version has lost its Origin badge it stays broken even when you expand the games into their individual entries. In this case the only fix right now is to delete the broken Origin entry and re-import it.

If the Origin version gets imported as its own entry (or gets expanded before you change something in the Edit window) it launches perfectly fine and editing the game details doesn't seem to do any harm as well. But it breaks again when you merge it.

I've tested this with multiple games and they all had the same issues.

Share this post


Link to post
Share on other sites
24 minutes ago, CriticalCid said:

I have an issue with imported games from Origin.

I can't start the Origin version anymore when a game from Origin gets merged with another version of the same game (in my case the Steam or GOG versions). Origin opens up but nothing happens.

When I edit the merged game (doesn't matter what field I change) the game also loses its Origin badge. Once the Origin version has lost its Origin badge it stays broken even when you expand the games into their individual entries. In this case the only fix right now is to delete the broken Origin entry and re-import it.

If the Origin version gets imported as its own entry (or gets expanded before you change something in the Edit window) it launches perfectly fine and editing the game details doesn't seem to do any harm as well. But it breaks again when you merge it.

I've tested this with multiple games and they all had the same issues.

Thanks @CriticalCid. I'll have @C-Beats review. He may ask for your data for testing.

Share this post


Link to post
Share on other sites

Beta 4 is out now with the following:

  • Improvement: When editing an emulator and setting it as the default for a platform, LaunchBox will now prompt you to update all additional apps to use that emulator as well (in addition to the main games that it was prompting for previously)

  • Improvement: Additional logging has been added to the debug logs to assist GreatStone with debugging hi2txt issues

The former issue should help solve problems that some people were having with updating their emulators on the main games but not the additional apps. Just set the platform as default for that emulator and you should be prompted to update the additional apps if any are found that don't match already.

  • Like 3

Share this post


Link to post
Share on other sites

Just updated to the last 3 betas and each time after it finishes the install this shows up. Do note before this message BigBox always hanged around opened even after being closed.

image.thumb.png.45d803a19f0e6307584c9b1921c1006d.png

Share this post


Link to post
Share on other sites

Hi Jason. In a future release (I'm assuming not this one) do you plan to also add import compatibility with the Rockstar Games launcher? I know there are not many games on it, and most people use other launchers for its games, but it would be good to also consider adding this at some point for completeness.

Share this post


Link to post
Share on other sites
9 hours ago, wallmachine said:

Just updated to the last 3 betas and each time after it finishes the install this shows up. Do note before this message BigBox always hanged around opened even after being closed.

image.thumb.png.45d803a19f0e6307584c9b1921c1006d.png

From what i remember its pretty normal for LB to hang around in task manager after closing as it writes the xml's on exit, once its done that task it closes fully,  so if you have it on a slower drive it will be more noticable.

I had that message the other day, after trying to run LB too quick again after closing it.

 

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, Jason Carr said:

I remember that issue from years ago, but hasn't come up in ages iirc. Where are you seeing a problem with that?

That's pretty normal for apps these days, especially apps that use so much media. We can always reduce RAM usage, but performance is likely to suffer as a result.

Anytime I attempt it states:

You must enter a full path with drive letter; for example

C:\App

or a UNC path in the form:

\\server\share

 

I was manually able to move it there and run the application from the root of the drive but anytime I get updates I get this error. Now I have to install it else where and manually copy the files to the root that its currently installed on. I was wondering if there is a way for the Wizard to allow you to either install it to the root or provide rar/zip files for updates to manually install.

Share this post


Link to post
Share on other sites
18 hours ago, wallmachine said:

Just updated to the last 3 betas and each time after it finishes the install this shows up. Do note before this message BigBox always hanged around opened even after being closed.

image.thumb.png.45d803a19f0e6307584c9b1921c1006d.png

You're saying the install runs and completes while Big Box is running? That should make the install fail if Big Box is running in the background, because it won't be able to copy the files. Confused here.

As far as I'm aware, the latest beta should fix any issues with Big Box not closing. If you're still seeing that issue, can you send me a debug log?

8 hours ago, Mike Stewart said:

Hi Jason. In a future release (I'm assuming not this one) do you plan to also add import compatibility with the Rockstar Games launcher? I know there are not many games on it, and most people use other launchers for its games, but it would be good to also consider adding this at some point for completeness.

There are actually many more third party stores, not just Rockstar unfortunately. There's Blizzard, Humble Bundle, and a bunch of other stores that I'm forgetting about for right now. We may add them eventually, yes, but there's so many of them that "for completeness" feels impossible unfortunately.

8 hours ago, MadK9 said:

From what i remember its pretty normal for LB to hang around in task manager after closing as it writes the xml's on exit, once its done that task it closes fully,  so if you have it on a slower drive it will be more noticable.

I had that message the other day, after trying to run LB too quick again after closing it.

 

Yes, LaunchBox saves XMLs for a bit after closing the window, so do make it sure you give it time to do that before killing the process, or you may end up with corrupted data. We're hoping that any closing issues have been solved with these betas though. If not, please send me a debug log.

3 hours ago, rockohoward said:

Anytime I attempt it states:

You must enter a full path with drive letter; for example

C:\App

or a UNC path in the form:

\\server\share

 

I was manually able to move it there and run the application from the root of the drive but anytime I get updates I get this error. Now I have to install it else where and manually copy the files to the root that its currently installed on. I was wondering if there is a way for the Wizard to allow you to either install it to the root or provide rar/zip files for updates to manually install.

I see. I'm not sure if our installer has a solution for that or not. I'll put it on the list.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Jason Carr said:

You're saying the install runs and completes while Big Box is running? That should make the install fail if Big Box is running in the background, because it won't be able to copy the files. Confused here.

As far as I'm aware, the latest beta should fix any issues with Big Box not closing. If you're still seeing that issue, can you send me a debug log?

What I meant to say was.

Each time I ran LB for the last three betas I was prompted to update so I did, after it finished installing it loaded up LB and this prompt showed up each time.

Regarding BigBox, when you close it and open again after some time lets say about a minute nothing happens, check Task Manager, close BigBox and re-open.

Can't send a debug log due to it not being checked, have to wait for next update.

Edited by wallmachine

Share this post


Link to post
Share on other sites
5 hours ago, wallmachine said:

What I meant to say was.

Each time I ran LB for the last three betas I was prompted to update so I did, after it finished installing it loaded up LB and this prompt showed up each time.

Regarding BigBox, when you close it and open again after some time lets say about a minute nothing happens, check Task Manager, close BigBox and re-open.

Can't send a debug log due to it not being checked, have to wait for next update.

I'm just confused as to why that popup would show up after an update, because a successful update should be impossible if LaunchBox or Big Box are running in the background. I guess we'll see what the log file says for the next update. Is anyone else running into any issues on updating?

Share this post


Link to post
Share on other sites

Beta 5 is out now with the following:

  • Improvement: The included version of 7-zip has been updated to version 19.00, which provides some significant performance improvements when extracting files and creating archives, especially on 64-bit machines

  • Improvement: The included version of hi2txt has been updated to version 1.12, which adds support for new games and fixes various issues. Huge thanks to GreatStone for all his work on hi2txt!

  • Like 7

Share this post


Link to post
Share on other sites
4 hours ago, Jason Carr said:

I'm just confused as to why that popup would show up after an update, because a successful update should be impossible if LaunchBox or Big Box are running in the background. I guess we'll see what the log file says for the next update. Is anyone else running into any issues on updating?

Didn't happen beta 5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...