Jump to content
LaunchBox Community Forums
PrecociousPleb

Way too much RAM consumption

Recommended Posts

Posted (edited)

I am currently experiencing an issue where LB starts to use way too much RAM, sometimes as high as 11gb out of 16. It's only as of version 10.14 that this has been happening.

Is there a way to limit the ram usage? I have to end up closing the application to run games smoothly.

 

I have an i7 8700k with 16gb of ddr4 ram 

Edited by PrecociousPleb

Share this post


Link to post
Share on other sites

It sounds like it might just be rebuilding it cache.  Start LB and let it set [run] for a bit (2 minutes? 5? 10+??).  The ram (and processor) consumption should then level out, reduce and be idle.  Provided you don't then add/remove a bunch of games/metadata/media, subsequent starts shouldn't be as demanding.

Share this post


Link to post
Share on other sites

yeah not sure what the issue is I have 16GB of DDR3 in my PC and I've never seen LB go anywhere near 11GB of RAM.

Share this post


Link to post
Share on other sites
5 hours ago, JoeViking245 said:

It sounds like it might just be rebuilding it cache.  Start LB and let it set [run] for a bit (2 minutes? 5? 10+??).  The ram (and processor) consumption should then level out, reduce and be idle.  Provided you don't then add/remove a bunch of games/metadata/media, subsequent starts shouldn't be as demanding.

I see, well I'll give that a go and get back to you. Thanks for the prompt response

Share this post


Link to post
Share on other sites

So I did as you said and left it to run for a few minutes and it definitely does calm down. CPU usage drops to about 2% down from 98% and RAM usage is about 3gb. Startup though seems very demanding on the CPU with usage going up to 99%. I hope this gets better with time and perhaps it's something to be looked at for 10.15.  

Share this post


Link to post
Share on other sites

big box absolutely has a Ram issue.. I had a recent post about this which has gone on deaf ears. the only way to not return after a few hours of my machine crashing out to desk top is by changing attract mode to not change systems, and start after 5 minutes, plus change after 40 seconds.. Doing that it stays on (like hyperspin did fine)

Share this post


Link to post
Share on other sites
On 5/4/2020 at 2:54 PM, PrecociousPleb said:

So I did as you said and left it to run for a few minutes and it definitely does calm down. CPU usage drops to about 2% down from 98% and RAM usage is about 3gb. Startup though seems very demanding on the CPU with usage going up to 99%. I hope this gets better with time and perhaps it's something to be looked at for 10.15.  

If after that cache gets built you still have high usage after subsequent starts there could be something else going on. Do you have a lot of auto-populated playlists?

30 minutes ago, floodie said:

big box absolutely has a Ram issue.. I had a recent post about this which has gone on deaf ears. the only way to not return after a few hours of my machine crashing out to desk top is by changing attract mode to not change systems, and start after 5 minutes, plus change after 40 seconds.. Doing that it stays on (like hyperspin did fine)

It may not have fallen on deaf ears. There are only 2 developers working on this so it is not like we have a big team that can focus on every issue. C-Beatsmay be trying to figure out what is up from your post. Different themes have been found to cause memory leaks so it could be a theme issue. Not saying that is your cause, but have you tested different themes. I recently let a member know some themes were causing attract mode to lock up and BB become unusable so he is taking a look at it to see what needs updating.

Share this post


Link to post
Share on other sites

thanks for a reply and better clarity on your HQ, its appreciated Retro808. 

I have 46 system wheels, all bonefide systems not these playlist system (capcom classics etc). Total of 13,000 games. 3TB drive, ryzen 5 2400G, 8GB 3000mhz ram, win 10.

Share this post


Link to post
Share on other sites
33 minutes ago, floodie said:

thanks for a reply and better clarity on your HQ, its appreciated Retro808. 

I have 46 system wheels, all bonefide systems not these playlist system (capcom classics etc). Total of 13,000 games. 3TB drive, ryzen 5 2400G, 8GB 3000mhz ram, win 10.

LB/BB have experienced memory leaks issues and Jason has fixed them in the past and always looks to fix them. For your issue in BB crashing after being left in attract mode what theme or themes are you using? I have a similar issue with 2 of my cabinets the other 2 do not have it. So it is a pretty odd issue for me.

Share this post


Link to post
Share on other sites

Are you using WMP as your video playback engine that is know to cause memory leaks?

Share this post


Link to post
Share on other sites

@RETRO - using unified. to be honest, my solution to only have Arcade cycling through at the intervals ive changed it to is fine.... when i return to it it is sluggish in the morning i must admit so ideally a reboot is needed to release it all... it is nice to have a machine constantly on, however i dont think many people actually do this so a reboot daily isnt really THAT bad (Anymore)

@DOS - I tried WMP and didnt have long enough to test its performance when it was clear many of the videos played poorly compared to VLC. I notice that there is a slightly updated version of VLC compared to the one in your third party folder, but doubt that difference was it. And in fact, im sure i used the most uptodate VLC and didnt notice any change.

I have applied the very good stickied thread you guys have done on the steps to improve, thats helped too.  

Share this post


Link to post
Share on other sites
On 5/6/2020 at 12:05 PM, Retro808 said:

If after that cache gets built you still have high usage after subsequent starts there could be something else going on. Do you have a lot of auto-populated playlists?

It may not have fallen on deaf ears. There are only 2 developers working on this so it is not like we have a big team that can focus on every issue. C-Beatsmay be trying to figure out what is up from your post. Different themes have been found to cause memory leaks so it could be a theme issue. Not saying that is your cause, but have you tested different themes. I recently let a member know some themes were causing attract mode to lock up and BB become unusable so he is taking a look at it to see what needs updating.

I don't have any auto-populated playlists no. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...