Jump to content
LaunchBox Community Forums

Pause Screen Takes PJ64 Out Of Fullscreen


Recommended Posts

The pause screen option works well for my other emulators, but when I use the pause screen in Project64 2.3 it acts kind of funny.

I'm using Big Box. When I'm in a fullscreen N64 game and I bring up the Big Box pause screen then two weird things happen after I select resume:
1. PJ64 is now in windowed mode
2. The game stays paused

If I bring up the Big Box pause screen again and select resume then the game resumes properly, but still in windowed mode. At this point, I can use the Big Box pause screen as much as I want and it works perfectly to pause and resume, but it won't switch back to fullscreen. 

I was playing around with PJ64 in Windows 10 as well, and I found that when playing a game in fullscreen and I Alt+Tab to another program, the emulator automatically leaves fullscreen mode. I think this might be causing my issue, but I couldn't find anything in the settings of PJ64 that would prevent it from leaving fullscreen.

Is there a script that I can use in my LaunchBox PJ64 emulator settings that would prevent it from leaving fullscreen when I resume after using the Big Box pause screen?

I'm sorry if this issue has already been dealt with in the past, I looked through the forums but I couldn't find my same problem. Thank you in advance for any insight you might have.

Link to post
Share on other sites

PJ64 returns to full screen from pause for me so I wonder why it does not for you. Do you have PJ64 option set to Enter Full Screen Mode when loading rom ticked? I assume yes since it runs full screen, but just wanting to confirm. 

In the Pause Screen tab when you go to Tools>Manage Emulators and edit PJ64 there is a tab for "On Resume". In that tab you could likely set an AHK to send a command to set the emulator back to fullscreen. You can probably try one of these two (they do the same thing). I am not an AHK expert. We have a couple forum members that know a ton about AHK. Maybe they can chime in with a better way to write the AHK.

Send !{Enter}

or

Send {Alt Down}{Enter}{Alt Up}

 

Link to post
Share on other sites

@Retro808 Thank you for your suggestions, an AHK script in the "On Resume" tab was exactly what I was hoping for. I did have checked in PJ64 to enter fullscreen mode when loading a ROM. I did a lot of playing around and finally I got the Send {Alt Down}{Enter}{Alt Up} script to work.

At first neither scripts worked for me and they did some really funny stuff (read below if you're interested at all) Then I reinstalled PJ64, tried both scripts again, and tried a similar script I found that someone used with a different emulator. Nothing was working. I even experimented with a second computer and found PJ64 reacts the same way when in fullscreen and focus changes (I tested this outside of BigBox/LaunchBox)

Finally, I did these three things (maybe I did something else, but I can't remember)
1. removed my -fullscreen command-line parameter
2. unchecked in LaunchBox "Suspend Emulator Process While Paused"
3. In BigBox options I cycled my primary screen from screen 1 to screen 2 and back to screen 1

Then I added the script Send {Alt Down}{Enter}{Alt Up} back into the "On Resume" tab. Not sure what caused it to work properly, but finally 2 hours later I had success!

Essentially I think the BigBox fairy came by and fixed it for me with magic. But regardless of why it's now working, I'm not changing any of those three things back.

Thanks again for the support!

 

Not necessary to read below:

When I used this script: Send !{Enter}
Game resumes perfectly, but Big Box gets switched to my 2nd monitor and stays there. With other emulators Big Box stays on my 1st display, but as soon as I open an N64 game Big Box switches to my 2nd monitor. To add to the confusion, the Big Box pause screen shows up on my main display, but everything else in Big Box is on my 2nd monitor.

The first time I used this script: Send {Alt Down}{Enter}{Alt Up}
There was a 3 pattern cycle that occurred each time I brought up the Big Box pause screen and then resumed the emulation.
1st time - Game stayed paused in windowed mode
2nd time - Game resumes in windowed mode
3rd time - Game resumes in fullscreen

  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...