Jump to content
LaunchBox Community Forums

Flycast and Naomi

Recommended Posts

Hello All,

I've been at this for about a month now and have had great success getting many things set up.  Most of this is due to the excellent work the community has put into helping newcomers and sharing information.  I am truly thankful for how easy this is after all of these years.


So far I have - 

Sammy Atomiswave (Retroarch - Flycast)

3DO (Retroarch - Opera)

Atari 2600 (Retroarch - Stella)

Atari 5200 (Retroarch - Atari800)

Atari 7800 (Retroarch - Prosystem)

Atari Jaguar (Retroarch - Virtualjaguar)

Atari Lynx (Mednafen)

ColecoVision (ColEm)

Fairchild Channel F (Retroarch - Freechaf)

Mattel Intellivision (Retroarch - Freeintv)

Sega 32X (Kegafusion)

Sega Genesis (Retroarch - Genesis Plus GX)

Sega Master System (Retroarch - Genesis Plus GX)

Nintendo Gameboy (Retroarch - Sameboy)

Nintendo Game Boy Advance (Retroarch - mgba)

Nintendo Game Boy Color (Retroarch - Sameboy)

sega Game Gear (Retroarch - Genesis Plus GX)


All installed and running correctly with nearly 5,000 games.  ETA Prime has been especially helpful in making sure that I don't  miss the random configuration file or BIOS.


With that said, I have gotten stuck in a few places.

I'm sure I'll be back here in future forum posts bothering you all about other Systems but today I've run into a problem getting Naomi games to work with the Flycast core in Retroarch - 


Most of the posts I've found have to do with people being unable to run ANY games through that core but my issue appears to be isolated to Naomi (Atomiswave games run fine).

I have a few hunches as to what could be wrong - I currently have a .zip file called naomi.zip in my System folder for Retroarch that contains several "BIOS FILES".  I've found the same pack at  several sites and so assumed it was fine but upon further inspection, I see that I need to rename an epr-21576h.bin  to naomi_boot.bin.

The .zip I have does have a file called epr-21576h.ic27 but no epr-21576.bin.  Is the .ic27 the same thing?  It is in there with many other epr-21576/7/8(x).ic27 files and I am not sure if I need all of these as they are not mentioned in any of the troubleshooting topics I can find.  Also, is it fine in the .ic27 format?  Must it be renamed to be recognized?  Is the file (if renamed) alright inside of a .zip archive or does Retroarch require it to be decompressed and placed in the System directory?  Some help on understanding the various .ic27 files, their purpose, their relationship to the .bin file (to be renamed naomi_boot.bin), etc... would be helpeful.

What I've tried on this front - 

I have copied the epr-21576h.ic27 to the System directory from the archive.  I have copied it alone and with the other .ic27 files

I have renamed it to epr-21576h.bin

I have renamed it to naomi_boot.bin

None of these things have worked.

Going back to the games files - 

I have been examining my Naomi games compared to what other people online say I will need (including ETA Prime's excellent video on the subject) and have also compared them to what I have in my Atomiswave games.

My Naomi games are zipped and have got .bin and .ic files in them (ic1 - ic20+ in some cases) OR just .bin files in them OR just .dat files in them . 

They do NOT have a .lst file.  I see that these were the files to add through the Launchbox ROM import according to ETA Prime's video.  In researching further, it appears that the .lst files act as some sort of hash to confirm the size of the game?  Not sure if they are truly necessary to open the archive or if telling Launchbox to simply use the .zip files for the Emulator will be enough for the Emulator to know what to do.

I thought that this must surely be the issue until I saw that my Atomiswave games are very similar to my Naomi games.  They, too, come zipped and do not have .lst files and they run fine (again, full of just .bin and .ic and .mrom files).

I am open to the possibility that my Naomi pack of games are outdated or are not compatible with the Emulator/Core I am trying to use but the similarity to the Atomiswave games (retrieved from the same source and roughly of the same age) leads me to believe that my .zip Naomi games are fine and it is, in fact, a BIOS issue. 


Next steps - 

For now, I will try to find an exact epr-21576h.bin (not .ic27) file and rename it to naomi_boot.bin and will try to remove any and all other references to Naomi from my Retroarch/System folder in case the Core is trying to load some other random file it is finding there.  I'll also search for another ROM pack.


I apologize for how verbose this is.  I work in IT and know that I always work better off of more information, not less.  Also, I am hoping to help others troubleshoot here in the future once I get my system fully configured and running so I am hoping that by asking detailed questions I will get detailed answers that will not only help me get the system working, but will also teach me some of the nitty gritty details that will make me of more use to someone else in the future.

Thanks for all you guys do to help us new guys out!



Not sure why it highlighted some of my text in white... Will try to fix that.

One other thing - 

Does retroarch have easily readable log files?  I did  a quick Google search and found that it logs to a file called retroarch.log, but I am unable to locate that file.  I think that perhaps I need to enable a higher level of logging from the command line or something prior to launching.

Also, a detail I left out - When launching the Naomi games in Retroarch (be it through Launchbox or standalone), it doesn't throw any error messages or default back to a Launchscreen for Retroarch.  It just crashes (closes) without warning.

So, the steps to get that result - 

Load core

Load content

Retroarch closes.

If I follow the exact same process with my Atomiswave games, they launch without problem.

Edited by demosthenes2010
Link to comment
Share on other sites

For anyone else who runs into this problem here is what I've learned - 

The naomi.zip file that I have appears to be a MAME BIOS file from at least version .154 or later and the .ic file that I was referencing in my previous post IS the correct one to be renamed to noami_boot.bin.  With that said, I'd somehow had a copy in a /dc folder (which I see is how some suggest you do it) and another copy one level up from that in my /system folder.  Cleaning these up did not fix the issue.

Also, the .zip files that I had did not come with the .chd's so I downloaded a new pack and this one appears to have them.  I've also read that they need to be in the same directory as the .zip files for Flycast/Reiscast to use them properly (so I did that).  This did not resolve the issue.

I'd read somewhere that someone just had to completely delete flycast from their Retroarch system and reinstall the core. Did this, updated everything in Retroarch.  This did not resolve the issue.

Through all of this, Atomiswave games continue to play without issue.

Another note - 

When I look at the Core Info under the Desktop version of Retroarch I can see the following details - 

(!) Present, Optional: dc/dc_boot.bin (Dreamcast BIOS)
(!) Present, Optional: dc/dc_flash.bin (Date/Time/Language)
(!) Present, Optional: dc/naomi.zip (Naomi Bios from MAME)
(!) Missing, Optional: dc/hod2bios.zip (Naomi The House of the Dead 2 Bios from MAME)
(!) Missing, Optional: dc/f355dlx.zip (Naomi Ferrari F355 Challenge deluxe Bios from MAME)
(!) Missing, Optional: dc/f355bios.zip (Naomi Ferrari F355 Challenge twin/deluxe Bios from MAME)
(!) Missing, Optional: dc/airlbios.zip (Naomi Airline Pilots deluxe Bios from MAME)
(!) Missing, Optional: dc/awbios.zip (Atomiswave BIOS from MAME)
(!) dc_boot.bin (md5): e10c53c2f8b90bab96ead2d368858623
(!) dc_flash.bin (md5): 0a93f7940c455905bea6e392dfde92a4
(!) naomi.zip
(!) hod2bios.zip
(!) f355dlx.zip
(!) f355bios.zip
(!) airlbios.zip
(!) awbios.zip


At this point, I am thinking about installing Demur and trying the games there.  May revisit this in the future...

Link to comment
Share on other sites

That is more likely an issue with a bad rip, there are a lot especially for Dreamcast with the different formats. Some emulators are better than others for different format, but anytime I had that issue, a different rip fixed it.


Here is a list of the files in my system/dc/naomi.zip file:

naomi.thumb.jpg.2d4d01f28b833a4248e114787e6d24da.jpgand its as a CRC-32 checksum of AB628024.

Running all Naomi and Dreamcast fine with these.

Edited by Headrush69
Link to comment
Share on other sites

Thank you, @Headrush69!


That was the issue!  I have several naomi.zip files around on my PC and the one I was using only had the following files.


Once I switched to the one you were using, the Naomi games started working.


Some of the games in the pack give me a "01 THIS GAME IS NOT ACCEPTABLE BY MAIN BOARD" error but according to this thread from Feb of this year, it may be because Flycast doesn't fully support Naomi 2?  I will research further but for now, 3/4 I've tested work - 


Link to comment
Share on other sites

1 minute ago, demosthenes2010 said:

Some of the games in the pack give me a "01 THIS GAME IS NOT ACCEPTABLE BY MAIN BOARD" error but according to this thread from Feb of this year, it may be because Flycast doesn't fully support Naomi 2?  I will research further but for now, 3/4 I've tested work - 


There are a few issues that can cause this:

  1. It's a Sega Naomi 2 game
  2. You are missing the CHD file for that game
  3. SOme games you have to go into the in game test menu and set the cabinet type correctly
  4. Although the Flycast core seems pretty good now at picking the right system, at one point I had some that it didn't, so I've set the system type in the Retroarch options for every game and saved a game options file to be 100% safe.
Link to comment
Share on other sites

Thanks, @Headrush69.

I figured it out.

Back when I'd first started troubleshooting with this new ROM set, I had placed the .zip files for games in the folder where matching .chd's sat. (for example, azumanga.zip was placed in /azumanga because azumanga.chd was there).

Once I removed the .zip files from those directories and placed them where they were when I'd downloaded them (along with the other .zip's that did NOT have .chd folder/files), those games started working.  

At this point I think I'm good to go!

Link to comment
Share on other sites

I had similar issues with RetroArch. Finally dumped it & went with Demul. Also switched out BIOS I found from another source. Working perfectly now. I think the issues I was having was having were a combination of both. My only issue with Demul is Hikaru doesn’t run in full screen and the workaround app stretches instead of keeping the proper aspect ratio. But that’s off-topic. ?

Link to comment
Share on other sites

Good reading. Whish I've seen this previously. My Demul set didn't have the chds where the mame roms needed to be there was my culprit.

Träästruggle to get light-guns going and I got Ninja Assault working with Aimtrak so I have hope for other ligjgun titles in Naomi. But I could never got atomiswave games to work. A extreme hunting 1 & 2, sport shooting usa..all have my cross hair locked in the down right part of the screen(!) anyone want to try as some of you state that all Naomi1 games working for you. ? Thanks for the thread hijack

Link to comment
Share on other sites

Haven't been here in a few days due to work and life responsibilities.  

I'm likely going to start a new thread soon about file types for Dreamcast games.

The pack that I have has .zips.  Those archives have some games that are just very large .gdi's (looks like complete disk images) and others that are .gdi with .bin and .raw.  

The ones that are .gdi/.bin/.raw I am having no problem turning into .chd's so that they are cleaner and compressed.

The ones that are ONLY large .gdi are not running in flycast AND are not able to be compressed into .chd's.

I'm sure someone out there has dealt with this before.  Will hunt down an answer in a new thread so others can see.

Thank you all for the responses.  For now, I think this thread can be closed out as "solved".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...