Jump to content
LaunchBox Community Forums
elJonnyRage

Dolphin Emulator Issues

Recommended Posts

Hello,

 

I recently updated my version of dolphin. Now when I launch dolphin from Launchbox the game window opens just fine but I don't get the secondary window that allows you to change dolphin configurations (such as graphic settings and key bindings). I even tried deleting dolphin all together, doing a fresh install and rebooting my pc. Still nothing. When I launch dolphin outside of Launchbox the window I'm referring to opens just fine and I'm able to tweak controller settings to my hearts content. The thing is, before upgrading dolphin, I do believe me previous version of dolphin 5 launched with the secondary window open. Is there something I am doing wrong here, or does this just have to do with using a dev build of dolphin or something? Any help would be appreciated.

 

 

DolphinWindow.thumb.PNG.c43d67232eea72dcdd0fbbe8dcdfba39.PNG

Thanks

Share this post


Link to post
Share on other sites

Are you not able to edit those by clicking on the Graphics and Controller icons in the image? Been a while since I have messed with my Dolphin settings, but since I set mine up it has always only launched one window.

Share this post


Link to post
Share on other sites

Why do you even want that window when launching games from Launchbox? You should set your settings once and never really need to look at them again.

Share this post


Link to post
Share on other sites
Posted (edited)

The window in the screenshot does not pop up. If it did, I could change the setting by clicking on the Graphics and Controller. The reason I want the window to show up is because I have multiple controller profiles for a few different wii games. It's not a huge deal. It's just that it popped up before (in the background behind the game window) and now it doesn't. I can just set it up so it handles most titles and then if I'm really having trouble with one, I can play it outside of Launchbox just using dolphin. Just wanted to know if anyone had any insight as to why this behavior seemed different than it was in the past. But according to Rerto 808 it's always been this way for him. That just wasn't my experience in the past. neil9000 as far as I can tell there is no way to select a different controller profile without using that window. Dolphin just loads whatever you have set as the default.

 

Edited by elJonnyRage

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/22/2018 at 1:24 AM, timekills said:

Using latest version of Dolphin (as of 22 APR 2018 that is 5.0-7062) I've had success doing the following:

First, add a blank text file to your Dolphin directory called "portable.txt". This will force Dolphin to save all the config files to the Dolphin directory under a folder named "User" rather than in the windows user documents directory.

Once you've done this and run Dolphin once, you can copy your old files from your Documents directory (My Documents\Dolphin Emulator\*.*) to the dolphin\User directory that was created to make it portable.

Next, create and save your per-game controller settings:

  1.  Under "Controllers - Wii Remote 1 (Configure)" set your configuration for the game. 
  2. Save the configuration profile by giving it a name (preferably either generic i.e. "Sideways" or "vertical" or related to the specific game) and press "save"
  3. Right click on the game in the Dolphin menu list of games and select "Properties"
    1. Note that you must have specified the game directories in Dolphin's settings for it to find and list the games!
  4. In the game properties menu there is a button in the lower left labeled "Edit User Config". Select that to edit the config for that game.
    1. Note that you must specify your text editor in Dolphin's settings for it to open the .ini (text based) file for editing.
  5. There may already be some pre-set conditions. Just add the control settings at the end, or overwrite anything in [Controls] if already there.
  6. The text you add will be [Controls] on one line and the next will be the WiimoteProlfileX (where X= the player # of the controller you are setting) = config file you set in step 2.
    1. As @StuDentBR stated, the instructions are located at How-to set game ini settings per game
    2. Do not add the .ini to the end of the config when you type it. Just the name of the config file.
    3. Basically you just paste the following into the ini file you've opened for editing:

[Controls]
WiimoteProfile1 = DKCountry

Replace the name after "WiimoteProfile1" (I used DKCountry in the example) with whatever you saved the controller config as in step 2 above.

Seems like this may be what I need to Try...

 

[Update] Tested and this works great. 

Edited by elJonnyRage

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...