Jump to content
LaunchBox Community Forums
BrainyCabde

Launchbox Causing Dolphin to launch on 1st Screen

Recommended Posts

When I run a game on Dolphin by itself it remembers the position I had it last and has no problems running in fullscreen on my second screen. If I try to run Dolphin through Launchbox, it opens fullscreen on my 1st screen. Anyone know how to fix this issue?

Share this post


Link to post
Share on other sites

Nevermind. Fixed it. It turned out to be the startup config that LB created screwing it up. Deleted all the startup config files except "Default" and "Default Shutdown". Works now.

Share this post


Link to post
Share on other sites

Ok. I closed LB and reopened and it regenerated the startup files. Is there any way to keep that from happening?

Share this post


Link to post
Share on other sites

Weird. Now it doesn't matter if I delete them at all. Opens on my primary monitor. Would be nice if LB added a function similar to Steam big view mode, where it automatically changes second screen to primary and switches back when you go to desktop mode. I guess i'll just launch those emulators outside of LB for now.

Share this post


Link to post
Share on other sites

You're on the right track with Dolphin.  When you started it stand alone, you moved the window to the display you wanted it on, and it 'remembered' it.  I recall that's what I had to do in LaunchBox.  Start your Dolphin game through LB and moves it window as before.  You may need to take it out of full screen (Alt+Enter I think), move it, go back to full screen, then exit the game as normal back to LB.  Though I wanted it to be on the primary screen, so as I think about it, I might be 'speaking out of turn'.😊

Share this post


Link to post
Share on other sites

Yeah that's what I was thinking as well. The weird thing is even when dragging the dolphin window to my secondary monitor when alt-entering to go to full screen, it full screens back to the primary. This doesn't happen when launching Dolphin without LB though. It's like something in LB is preventing dolphin from going full screen on secondary monitor. I'll have another go with it today and see if I can figure it out. It's like this with other standalone emulators too(PCSX2).

Share this post


Link to post
Share on other sites

../Dolphin/User/Config/Dolphin.ini

Scroll down to [Display] and try the opposite setting ("True" or "False") that's listed under "RenderToMain".

[Display]
FullscreenResolution = Auto
Fullscreen = True
RenderToMain = False

Just a[nother Joe] thought.

Share this post


Link to post
Share on other sites

No dice. I'm currently trying to figure out an autohotkey script that uses Windows 10 built in function of pressing the "windows key+p" and selecting which display mode I want. It'll go from "Extend" to "Second Screen Only". I've also made a request feature to the LB team to add a tickbox for an option that launches the game on whatever display you want. Steam Big Picture mode has this and also quite a few pc games. I'm sure it can be done, but in the meantime, i'll keep chomping at the bit. I'll keep you posted if I find something.

  • Like 1

Share this post


Link to post
Share on other sites

You mentioned creating an AHK script.  Not sure if this would work with it starting in full screen, but as a start you may be able to finagle something from it.

Sleep, 3000    ;wait 3 seconds (more time?)
Send #+{Left}  ;Send Win+Shift+Left (or change "Left" to "Right" as necessary)
Return

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...