Jump to content
LaunchBox Community Forums
Jason Carr

11.0-beta-1 Released

Recommended Posts

1 hour ago, Wanderer189 said:

1. When I would add say a windows game manually, I would start with clicking the "ADD" button, then I would go to the browse to enter the path to the game, most of the time if the games executable was the same as the game title, it would auto populate the Title for ya. All you would have to do is click on the search for media button. Now when I do the same procedure, I have to copy and paste the title of the game into the title field before I can search for the media (and now they are in 2 different places)

2. When I finish adding a game manually, use to, when you would click OK, the dialog box would go away and return you to LB, but it would focus on the game you just added. Now it just returns you back to the top.

This is pretty much what I was saying in my post from yesterday about returning from editing anything you have no game selected.

  • Like 1

Share this post


Link to post
Share on other sites

Beta 7 is out now with the following:

  • The game details sidebar in LaunchBox now populates correctly after closing the Add/Edit dialog
  • When cancelling the Add/Edit dialog, some validation errors were still being shown
  • In the add/edit dialog, pressing Enter while focused on the Title text box was not working properly
  • Hopeful fix for legacy video paths not being used in all situations
  • When manually adding a game, the Title text box is now populated automatically when browsing for the ROM or startup EXE file (like the old dialog)
  • New games are now selected after adding them (if they show up in the current platform/filter)
  • Link (.lnk) files are no longer de-referenced when browsing them in add/edit (and a few other places as well)
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks so much @Jason Carr! You Rock! Beta 7 totally fixed the video directory problem, and I even went to see if it did some sort of weird copying over to LaunchBox\Videos\... and turns out all is well. Nothing copies over to play or anything like that at all. Looks like all is well like it was before. Again I thank you a ton for getting this problem fixed to where I don't have to really do anything extra, but leave things as is, and maybe delete what is left over in LaunchBox\Videos\... to save up some space.

  • Like 1

Share this post


Link to post
Share on other sites

The release is live now, if anyone hasn't noticed. :)

Let me know if anyone runs into any serious bugs with the 11.0 release.

  • Like 7
  • Game On 1

Share this post


Link to post
Share on other sites

Congrats on the new release, some awesome features there! 

Just tried recording a video for some games with OBS integration, Resident Evil 2 and Mega Man 11, and both do record and end up in C:\Users\xxx\Videos but they never get copied to my specified folder "Videos\OBS"

And I never get a prompt if I want to use the video as a snap for my game.

Any ideas?

Share this post


Link to post
Share on other sites

Games still cannot share the same video. Each just rename the videos and the previous game that was using it loses the association.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, mcfilmmakers said:

OMG Just installed version 11... it is responsive AF! Amazing!

which one LaunchBox or BigBox? Unfortunately its the same for me.

Edited by wallmachine

Share this post


Link to post
Share on other sites
24 minutes ago, wallmachine said:

which one LaunchBox or BigBox? Unfortunately its the same for me.

 

1 hour ago, mcfilmmakers said:

OMG Just installed version 11... it is responsive AF! Amazing!

There should be no difference in performance anywhere really. Perhaps @mcfilmmakers is referring to the delays that were in the old betas?

5 hours ago, ZeSystem said:

Games still cannot share the same video. Each just rename the videos and the previous game that was using it loses the association.

We'll look into this.

6 hours ago, e2zippo said:

Congrats on the new release, some awesome features there! 

Just tried recording a video for some games with OBS integration, Resident Evil 2 and Mega Man 11, and both do record and end up in C:\Users\xxx\Videos but they never get copied to my specified folder "Videos\OBS"

And I never get a prompt if I want to use the video as a snap for my game.

Any ideas?

It sounds like you've set it up incorrectly, I think. The OBS videos folder setting should be pointed at the folder that OBS puts recordings into, not the destination that videos should end up in. Once associated, videos will end up in the platform's videos folder for the game that was run.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@Jason Carr

When LB associates an OBS file with the corresponding game is there a way for it to move the video instead of just copying it to the game's folder? As it stands, it will duplicate each recording so I have to remember to delete the original files in the OBS video folder. Also, do you know of a way to increase the recorded volume within OBS? I noticed that most of the downloaded game themes are significantly louder than my recordings which means lots of volume adjustments while browsing.

Cheers!

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Jason Carr said:

It sounds like you've set it up incorrectly, I think. The OBS videos folder setting should be pointed at the folder that OBS puts recordings into, not the destination that videos should end up in. Once associated, videos will end up in the platform's videos folder for the game that was run.

You're absolutely right, I misunderstood, it's working now, thanks Jason!

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Jason Carr said:

 

There should be no difference in performance anywhere really. Perhaps @mcfilmmakers is referring to the delays that were in the old betas?

Launchbox 11 as compared to 10.15 is massively more responsive when scrolling through the game lists. Before there was lag when scrolling, now it is smooth as butter.

Share this post


Link to post
Share on other sites

I know the official version has been released, but thought maybe I should post here since it comes from changes in this beta version.

Something that would be really nice is when you are running the Media Cleanup (and it takes so long to run), you are able to minimize LB, currently you can minimize it's cleanup progress window, but it isn't doesn't minimize LB along with it as most apps do.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Thornback said:

@Jason Carr

When LB associates an OBS file with the corresponding game is there a way for it to move the video instead of just copying it to the game's folder? As it stands, it will duplicate each recording so I have to remember to delete the original files in the OBS video folder. Also, do you know of a way to increase the recorded volume within OBS? I noticed that most of the downloaded game themes are significantly louder than my recordings which means lots of volume adjustments while browsing.

Cheers!

Noted the request about moving instead of copying. OBS does have volume controls, but as it's recording your system audio, it could be affected by your system volume.

2 hours ago, mcfilmmakers said:

Launchbox 11 as compared to 10.15 is massively more responsive when scrolling through the game lists. Before there was lag when scrolling, now it is smooth as butter.

I'm not sure why that would be. We haven't seen any difference between 10.15 and 11.0 in our testing.

Share this post


Link to post
Share on other sites

Is there a way to designate what type of video it should be at the confirmation screen? Seems unnecessary to have to go into the edit screen afterwards just to change recording to screenshot.

  • Like 1

Share this post


Link to post
Share on other sites

Pigbacking off what Mr. Laor mentioned, the ability to label what the screenshots are too would be beneficial (gameplay vs title screen vs game over, etc). Great release again LB team!

  • Like 2

Share this post


Link to post
Share on other sites

I noticed that the new edit window only shows one value for each custom fields name.

My Steam games all have multiple custom fields named “Tags” attached to them but in the edit window only one of the "Tags" fields shows up.

To make things worse, all the other "Tages" fields that do not show in the edit dialog will be getting deleted once you save the game entry.

Share this post


Link to post
Share on other sites
9 hours ago, CriticalCid said:

I noticed that the new edit window only shows one value for each custom fields name.

My Steam games all have multiple custom fields named “Tags” attached to them but in the edit window only one of the "Tags" fields shows up.

To make things worse, all the other "Tages" fields that do not show in the edit dialog will be getting deleted once you save the game entry.

Yikes, thanks Cid. Surprised that didn't come up in the betas. We're planning on fixing this and some other more minor things on Monday. Probably look to put 11.1 soon after.

Share this post


Link to post
Share on other sites

Yes, custom fields should support multiple fields, the same as genres or series field, for instance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...