Jump to content
LaunchBox Community Forums

11.0-beta-1 Released


Recommended Posts

3 hours ago, Pixel said:

I think Uplay is also problematic. Generally, switiching between platforms (those launchers) breaks the cycle so that it won't capture images untill you restart LB.  Can we somehow configure this Windows Built-In solution? When I use one launcher it is ok (except Rockstar) but when I switch, it stops capturing the next games that I launch from any platform (also emulatros that worked before) etc.

We're hoping this is all fixed with the beta release.

Link to post
Share on other sites
  • Replies 307
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hey all, the first 11.0 beta is out now with the following: New Feature: The Clean Up Media process has a new option to scan images for rough matches. This new option can make the clean up

Beta 3 is out now with the following: New Feature: You can now take screenshots that will automatically be associated with your games; see Tools > Options > Screen Capture in LaunchB

Beta 2 is out now with the following: New Feature: OBS Studio integration has been added, which allows you to easily record videos and automatically assign them to your games; take a look

Posted Images

1 hour ago, CriticalCid said:

I just tried again to import my Epic launcher games and the missing games that I’ve had reported a while ago are still missing. It’s most likely a bigger issue than just a temporal hiccup.

I'll have @C-Beats review it. Unfortunately, though, it may just be an issue with Epic's API.

Link to post
Share on other sites
7 minutes ago, klepp0906 said:

hmmm.  new beta wont launch retroarch/games.  tried 2 different platforms same result.  roll back to 11.0 and all is fine.

Not seeing any issues that I can replicate. Launched NES, SNES, Genesis, and N64 all without issues. What exactly is happening for you?

Link to post
Share on other sites

weird.  absolutely nothing.  just re-rolled forward and did it again. wont launch a game.  it just goes to the startup screen and POOF, goes back to bigbox.

Thought it was a streaming thing, so immediately hopped back over to my pc and launched outside of steam.   Same result.

Then i thought it was a bigbox thing, so tried with just launchbox.   Same result.

rolled back, works.  rolled forward again, no works.   #boggle

Link to post
Share on other sites

Nice one adding trailers! I've noticed that most trailers show nothing about the game in the first 5 to 10 seconds. Is it possible to make them start at a later time instead of at the beginning? That would be cool. Maybe add a slider so the user can adjust the start time.

Link to post
Share on other sites
1 minute ago, wallmachine said:

Going to Tools -> Options ->OK the current Platform goes greyed out like its thinking and I have to click on another Platform

Im not seeing that here on beta 1, same steps. The edit window hangs for a second or two while it saves, but i have full control to click on games in the current platform when it closes.

Link to post
Share on other sites

got it now.  3rd times the charm apparently.   

re-updated again.   this time i attempted to launch a non RA platform first that worked.   Then moved to an RA platform and it worked this time.

Unsure if the non RA platform had something to do with it, or it was some other wonky business resolved overall with the rolling back/forth but all is right in the world again it seems.

Apologies for the false alarm!

Link to post
Share on other sites
7 hours ago, Suhrvivor said:

Nice one adding trailers! I've noticed that most trailers show nothing about the game in the first 5 to 10 seconds. Is it possible to make them start at a later time instead of at the beginning? That would be cool. Maybe add a slider so the user can adjust the start time.

This might be helpful for you

  • Like 2
Link to post
Share on other sites

I don't know if this was possible before 11.0 but I managed to import a crap ton of games and some of the titles have a space at the end which appears to mess with finding associated assets. I'm using the media manager plugin to find those titles with the space at the end and there are quiet a few... (Acorn Electron) Is this normal behavior? I would expect launchbox to remove spaces at the ends of all fields including title, platform, developper, etc. and I'm fairly certain this used to be the case.

Edited by mcfilmmakers
Link to post
Share on other sites

Video clips are still playing Tug of War with each other by forcing a rename each time you Add Video, but still can't be used to more than one game title. Like if I have "The Speed Rumbler - Arcade.mp4" and then Add it to the game through Edit it then becomes something like "The Speed Rumbler-01.mp4" or "The Speed Rumbler.ac7401a2-5d36-413b-adf3-51751f4562e6-01.mp4", and then if you try and Add it to another game title it then becomes something like "The Speed Rumbler.c7465dc2-840d-49ef-8905-fd3944f7e02f-01.mp4" and the previous game you Edited before with it can no longer be used since the file directory changed

Link to post
Share on other sites
20 hours ago, wallmachine said:

Going to Tools -> Options ->OK the current Platform goes greyed out like its thinking and I have to click on another Platform

The games view will repopulate after closing the Options screen. I'm guessing it just was going to take a bit longer to populate.

20 hours ago, Suhrvivor said:

Nice one adding trailers! I've noticed that most trailers show nothing about the game in the first 5 to 10 seconds. Is it possible to make them start at a later time instead of at the beginning? That would be cool. Maybe add a slider so the user can adjust the start time.

That's an interesting idea, but honestly I don't think it would have mass appeal.

7 hours ago, mcfilmmakers said:

I don't know if this was possible before 11.0 but I managed to import a crap ton of games and some of the titles have a space at the end which appears to mess with finding associated assets. I'm using the media manager plugin to find those titles with the space at the end and there are quiet a few... (Acorn Electron) Is this normal behavior? I would expect launchbox to remove spaces at the ends of all fields including title, platform, developper, etc. and I'm fairly certain this used to be the case.

Thanks, we've fixed this for beta 2.

5 hours ago, RULLUR said:

Video clips are still playing Tug of War with each other by forcing a rename each time you Add Video, but still can't be used to more than one game title. Like if I have "The Speed Rumbler - Arcade.mp4" and then Add it to the game through Edit it then becomes something like "The Speed Rumbler-01.mp4" or "The Speed Rumbler.ac7401a2-5d36-413b-adf3-51751f4562e6-01.mp4", and then if you try and Add it to another game title it then becomes something like "The Speed Rumbler.c7465dc2-840d-49ef-8905-fd3944f7e02f-01.mp4" and the previous game you Edited before with it can no longer be used since the file directory changed

So the previous functionality here was more of a by accident thing than a by design one. We've changed videos to behave exactly like images do now. We need the ability to use different videos for games with the same titles, so that is the reason for the GUID text being appended to the end. Still, if you want to force LaunchBox to use the same video for multiple games, you should be able to just manually rename the file to the game's title, and I think both games should pick it up.

Link to post
Share on other sites

Beta 2 is out now with the following:

  • Game titles are now trimmed properly
  • Browsing for an additional app will now default to the game's directory
  • Fixes for the new auto-complete functionality with the multi-select drop downs in the add/edit window (auto-complete now works for all items in the list instead of just the last item)

The plan is to put an official 11.1 fix release out tomorrow. Let me know if anyone finds any more bugs with the 11.0, beta 1, or beta 2 releases. Thanks y'all. :)

  • Like 3
Link to post
Share on other sites
18 minutes ago, Jason Carr said:

Beta 2 is out now with the following:

  • Game titles are now trimmed properly
  • Browsing for an additional app will now default to the game's directory
  • Fixes for the new auto-complete functionality with the multi-select drop downs in the add/edit window (auto-complete now works for all items in the list instead of just the last item)

The plan is to put an official 11.1 fix release out tomorrow. Let me know if anyone finds any more bugs with the 11.0, beta 1, or beta 2 releases. Thanks y'all. :)

 

Games still cannot share the same video. Each just rename the videos and the previous game that was using it loses the association.

Link to post
Share on other sites
8 minutes ago, ZeSystem said:

 

Games still cannot share the same video. Each just rename the videos and the previous game that was using it loses the association.

Yes, we're aware of that. Please see my response here:

32 minutes ago, Jason Carr said:

So the previous functionality here was more of a by accident thing than a by design one. We've changed videos to behave exactly like images do now. We need the ability to use different videos for games with the same titles, so that is the reason for the GUID text being appended to the end. Still, if you want to force LaunchBox to use the same video for multiple games, you should be able to just manually rename the file to the game's title, and I think both games should pick it up.

 

Link to post
Share on other sites
2 minutes ago, Jason Carr said:

Yes, we're aware of that. Please see my response here:

 

This usually works if the games have the same title, but a lot of games I have issues with this is due to having different names. The workaround you suggested is unfortunately not an option.

The problematic cases include games that are mostly an identical game with just a few contents added and/or tiny little balance changes (fighting games), or games that have different subtitles (modern point and click adventure games) or different episodes (like the 5th Monkey Island game having "Episode 1/2/3/4/5" suffix).

Link to post
Share on other sites
1 minute ago, ZeSystem said:

This usually works if the games have the same title, but a lot of games I have issues with this is due to having different names. The workaround you suggested is unfortunately not an option.

The problematic cases include games that are mostly an identical game with just a few contents added and/or tiny little balance changes (fighting games), or games that have different subtitles (modern point and click adventure games) or different episodes (like the 5th Monkey Island game having "Episode 1/2/3/4/5" suffix).

Oic, so you were manually browsing for the same video for two different games? To be honest, I didn't even know people did that. We'll take a look to see if we can support that. It may be more trouble than it's worth though, to be honest, considering that you can just duplicate the video on the rare occasions that you've got that particular situation.

Link to post
Share on other sites
28 minutes ago, Jason Carr said:

So the previous functionality here was more of a by accident thing than a by design one. We've changed videos to behave exactly like images do now. We need the ability to use different videos for games with the same titles, so that is the reason for the GUID text being appended to the end. Still, if you want to force LaunchBox to use the same video for multiple games, you should be able to just manually rename the file to the game's title, and I think both games should pick it up.

There are times I use a commercial which promotes the game for several Platforms, and this new way kinda messes that up for me, and the way I have things set is just clips in 1 folder and not any subfolders for Platforms or anything like that which would make anything with a similar name and a -01 at the end of it show up on the wrong Platform version. I just notice all the ones I haven't touched since the new way are doing just fine and don't seem to conflict. I really wish there was a way to go back to the way it used to be without all the conflict or tug of war it's doing of the now though. I don't know of anyone else who may worry they have to go back and spend countless time setting things up again with their videos like I may have to do.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...