Jump to content
LaunchBox Community Forums

Odd behaviour in latest version


Solo187
 Share

Recommended Posts

Ever since the introduction of the screenshot grabber. I've been having a strange issue with certain cores in retroarch. Mainly cores for computers with keyboards. Also requests to save Phantom screenshots after exiting. Its as if my joypad movements are sending keyboard commands to retroarch. It renders the spectrum fuse core unusable. Its definitely a launchbox issue as it all works fine in an earlier version (which i have setup separately & not updated). Also works fine when running retroarch alone. I've changed nothing in settings. I don't have my pad set to do anything like this in launchbox settings either. Strange

Link to comment
Share on other sites

51 minutes ago, Solo187 said:

Ever since the introduction of the screenshot grabber. I've been having a strange issue with certain cores in retroarch. Mainly cores for computers with keyboards. Also requests to save Phantom screenshots after exiting. Its as if my joypad movements are sending keyboard commands to retroarch. It renders the spectrum fuse core unusable. Its definitely a launchbox issue as it all works fine in an earlier version (which i have setup separately & not updated). Also works fine when running retroarch alone. I've changed nothing in settings. I don't have my pad set to do anything like this in launchbox settings either. Strange

There is a fairly large disclaimer about screenshotting retroarch to be fair.

image.thumb.png.9808e90b4d7a982d630aa0899335c73f.pngAnd if you are being prompted after closing Retroarch it sounds like you are hitting F8 during gameplay, or whatever you changed the hotkey to in retroarch.

Link to comment
Share on other sites

Thats just it, Im not taking any screenshots. Its just saying i have after i exit. Also i haven't set a screen capture key or changed the default f8 screenshot key in retroarch. Like i said, Ive changed absolutely nothing since  launchbox 11 beta 1. But now im getting these save screenshot requests & any joypad press whilst  using the fuse core will spaz it out. Its like background keyboard automations off the joypad are being sent to retroarch or something

Link to comment
Share on other sites

Just now, Solo187 said:

Thats just it, Im not taking any screenshots. Its just saying i have after i exit. Also i haven't set a screen capture key or changed the default f8 screenshot key in retroarch. Like i said, Ive changed absolutely nothing since  launchbox 11 beta 1. But now im getting these save screenshot requests & any joypad press whilst  using the fuse core will spaz it out. Its like background keyboard automations off the joypad are being sent to retroarch or something

How are you controlling fuse? Cause i just tested it here with the core set to Kempston input using my controller and i had no weird issues at all, game controlled fine, and no prompts to save screenshots when i exited.

Link to comment
Share on other sites

1 hour ago, neil9000 said:

Not sure what to tell ya, working just fine for me. Are you using any third party mapping software, or have steam open and using its desktop configuration?

 

 

Nope. Nothing extra. Steam is always open on my system as i have it load at startup. But thats not it as the older launchbox works fine. I was going to test up to which version it stopped working but unfortunately i deleted my update folder contents just recently!. Somewhere between 11 beta 1 & 11 official is the problem

Link to comment
Share on other sites

On 7/4/2020 at 1:56 AM, Solo187 said:

Ever since the introduction of the screenshot grabber. I've been having a strange issue with certain cores in retroarch. Mainly cores for computers with keyboards. Also requests to save Phantom screenshots after exiting. Its as if my joypad movements are sending keyboard commands to retroarch. It renders the spectrum fuse core unusable. Its definitely a launchbox issue as it all works fine in an earlier version (which i have setup separately & not updated). Also works fine when running retroarch alone. I've changed nothing in settings. I don't have my pad set to do anything like this in launchbox settings either. Strange

I'm confused here; what is the exact issue you're running into with the cores in Retroarch (other than the phantom screenshots)?

Per the phantom screenshots, have you looked to see what the images actually are? Are they proper screenshots of the game?

Link to comment
Share on other sites

On 7/4/2020 at 5:59 AM, Lukeyboy67 said:

Same thing is happening to me and I don't use Retroarch, now after I exit a game it gives me a screenshot save request to random screenshots I haven't taken....

What are the screenshots of? Are they of the game you were playing?

Link to comment
Share on other sites

1 minute ago, Jason Carr said:

I'm confused here; what is the exact issue you're running into with the cores in Retroarch (other than the phantom screenshots)?

Per the phantom screenshots, have you looked to see what the images actually are? Are they proper screenshots of the game?

It's fine now, Sorted. Turns out it was a wayward custom config i was using for the fuse core causing my controller issues. As for the phantom screenshots, i will investigate later as to what the shots actually are.

  • Like 1
Link to comment
Share on other sites

1 minute ago, Lukeyboy67 said:

Yeah, shots of the game. Once I got one of the startup theme 'Now Loading' screen, before the game had even loaded. Hope this helps.... :)

What emulator(s) is it happening with? Have you checked to see what keys or controller buttons are bound to the new screen capture features?

Link to comment
Share on other sites

3 minutes ago, Jason Carr said:

What emulator(s) is it happening with? Have you checked to see what keys or controller buttons are bound to the new screen capture features?

I have lots of emulators and I'm sorry I can't for the life of me remember what I was playing that day? It's only happened a couple of times, it's not everytime I exit, just thought I'd mention it. I set F11 to capture screens.

Link to comment
Share on other sites

2 hours ago, Jason Carr said:

What are the screenshots of? Are they of the game you were playing?

Ok so i checked my retroarch screenshot folder & there were 10 screenshots. These are shots i'd taken previously. None of the game in question. On the occasions where i've been asked to save the shots though, it asked me to save 10 screenshots.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...