Jump to content
LaunchBox Community Forums

Issues importing games from Epic Store


Chrius
 Share

Recommended Posts

I started using LaunchBox today, imported all my Steam and Origin games without issues, but when I tried importing my games from the Epic Store the Import tool only showed about half of the games I have on my account.

The ones that showed up imported without issues. I tried importing them a second time, but the "Ready to Import" screen is empty now.

Do I need to do anything different to import all my games from the Epic Store?

Link to comment
Share on other sites

  • 2 weeks later...

We've had some users report similar issues with games not appearing. I need to devise a good way to debug the API call for some of the users experiencing this but currently I cannot do this without the users credentials (which I don't feel comfortable asking for or having). Before the next beta release I am hoping to get some more logs added into the Epic code to see if we can figure out why users are having this issue and if it is on our end or Epic's.

Link to comment
Share on other sites

I'll addon to this, since it's similar enough I don't feel it needs a new thread, my Epic was the first and only games I  have right now, and LaunchBox is saying "Displaying 20 of 25 total games" even though I have selected "all" in case some Windows games got through, but I'm guessing it's tied to this bug.

Link to comment
Share on other sites

11 hours ago, Azolphion said:

I'll addon to this, since it's similar enough I don't feel it needs a new thread, my Epic was the first and only games I  have right now, and LaunchBox is saying "Displaying 20 of 25 total games" even though I have selected "all" in case some Windows games got through, but I'm guessing it's tied to this bug.

What you are describing would suggest that you have some titles hidden.

Link to comment
Share on other sites

  • 1 month later...
On 7/14/2020 at 9:20 AM, C-Beats said:

We've had some users report similar issues with games not appearing. I need to devise a good way to debug the API call for some of the users experiencing this but currently I cannot do this without the users credentials (which I don't feel comfortable asking for or having). Before the next beta release I am hoping to get some more logs added into the Epic code to see if we can figure out why users are having this issue and if it is on our end or Epic's.

I just tried to add Epic Games into my LaunchBox 11.3 instance and same issue - no games show up.

First time trying to import Epic Games content into LB.

I did notice, under Epic Games --> Account --> Connections --> Apps, Launchbox isn't listed as well even though I provided it credentials? Does LB use this API or another method to scrape the data?

Edited by coolspot
Link to comment
Share on other sites

  • 2 months later...
9 minutes ago, C-Beats said:

Thanks again for the log. I was able to track down a few potential issues with the Epic importer and have made some code changes that should appear in the next beta release. Once that happens I'd love if you could update to the beta and see if it corrects your issues.

Ok, thanks ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...