Jump to content
LaunchBox Community Forums

NOT FUN losing focus while playing!!

Recommended Posts

Posted (edited)

What in tarnation!!!  It loses focus completely! 
We'll (me and the wife) will be in the the middle of a game and the screen will go black!  You can still hear the game but the only way out is to quit the game or go to the keyboard and alt-tab!  From that black screen, if you quit the game; MAME will still be running and never actually quits the game, you are simply back at the game select screen while Mame is happily still on the last game in the background! 
This is incredibly FRUSTRATING.. I QUIT EVERY SINGLE APP... I've gone and quit services that run under my name... still... Smack in the middle of playing at some random time!  
I've also set the window hiding apps as many have suggested.
Does anyone have any idea that could possibly help?  It's hard enough to get the wife to play... when this happens in the middle of her streak and she thinks it's me somehow.. 
I would sincerely appreciate ANY ideas.. I finally got this running to where I'm almost 80% with my desired emulators... image.thumb.png.fefcedd806de24e9529dc5b2d1c365c2.png

Edited by adam1972

Share this post

Link to post
Share on other sites
Posted (edited)

This is probably way out of left field but what are you using for controllers? I had a similar issue a while back and I was pulling my hair out. It turned out that having Steam open was hooking into my xbox controller and the Desktop theme had a button combo on it (I don't remember ever messing with it at all) that was pulling me out of games by pulling the emulator out of fullscreen (lovely coincidence). I'm not saying its Steam but if you're using any keybinding software you could check there.

I'd go through the MAME keybindings as well to make sure everything is in order just to be safe. I don't think MAME allows you to bind combos but it might allow you to bind the same button or key for multiple things which might be a problem.

Then again, that you hear the game but can't Alt Tab back to it (if I'm understanding the emulator is blackscreening?) it might be something with MAME itself? Have you tried to see if the same behavior happens with MAME outside of the LB/BB environment?

I personally would definitely uncheck all of the options in that screenshot. That's all cool stuff but when you're testing its all also EXTRA stuff. Rule it out.

If it isn't the emulator, something about your setup is making the emulator lose focus. I wonder if those annoying Windows 10 notifications could do it? Or some other program trying to notify you of something?

More information would help.

Controller or keyboard setup (one or two controllers, what kind, any mappers), MAME emulator version, have you tested in both LB and BB, windows version, how many monitors etc.

Its not normal behavior and I'm just spitballing but I don't think LB/BB ever tries to take control of your screen except maybe with that Hide All Windows thing you have checked and maybe the pause menu. So I personally can't imagine how launchbox itself would be pulling you out of games.

Edited by fromlostdays

Share this post

Link to post
Share on other sites

Thank you for the assist. :)
It's an X-Arcade Tank Controller.  
I didn't have steam running.  I went through and closed all apps, used task manager and closed everything I could that was running under my profile as well that had to do with steam, gog, printers, cloud services.. anything I didn't need.  The only thing I didn't close was bigbox.  
I am able to come to the keyboard and alt-tab.. that's what I DO NOT want to do, especially since the game doesn't pause when it happens.  It is NOT a solution.  
One keyboard and mouse, two monitors, one turned off (disabled when I turn on LB/BB), MAME 0.220,   I only use BB, so I haven't tested LB.  
Those option I have checked are the ones everyone that has had this problem or similar have suggested in other threads to eliminate other windows from taking focus from the emulator.  They were originally off when I started having the issue and apparently had no effect in this case.. ugh.... 
I am going to try one thing.. You mentioned alerts so I did a quick search on stopping windows alerts and found this article on a Windows feature.. Focus assist, disables those annoying alerts in case it is what is causing this...  I'll give that a try and see if it helps.
Thank you fromlostdays :) 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...