Jump to content
LaunchBox Community Forums

Adding games, no longer has default emulator


Recommended Posts

Since the last big updates to the menu system, I noticed when I add a new game, the default emulator is empty. Every system use to have a default EMU chosen for whatever platform you set.

When I look at the associated platform for say Bizhawk, non of the platforms are defaulted when adding a game. I have to manually click on BizHawk and associate it as the emulator.

Did something change and I have to set the defaults else where?

Link to post
Share on other sites

Have not seen this issue and just tested some games. Default emulator is showing up. Tested on latest LB stable version as well as the latest beta.

How are you importing? Drag and drop or are you scanning for new file? Also is this an English version of LB or one of the translated language versions?

Images from importing a Game Boy game. During the import wizard you can see in the second image it recognize Retroarch as my default for Game Boy. The last image is the edit screen of the game. The Emulation tab is showing RA is attached to it.

 

Screen Shot 2020-09-04 at 1.31.04 PM.png

Screen Shot 2020-09-04 at 1.31.13 PM.png

Screen Shot 2020-09-04 at 1.34.40 PM.png

  • Like 1
Link to post
Share on other sites
1 hour ago, Retro808 said:

How exactly are you manually doing it? Specifics might help.

If you add a game in anyway directly in the LB interface the wizard comes up.

I can also confirm that this feature is for some reason disabled or hasn't moved to the updated GUI:
Untitled-1.thumb.png.ef285b5ebe8b96d8f72b22c006b90a1c.png
And when you search with "Search metadata", you get all the fields filled with the metadata found in the Database:2.thumb.png.97141691ebef00204d825a6013c3f4c0.pngaegae.thumb.png.fedec5836897895b8feb884e3e268b2f.png
But then the emulation field remains empty:
aehaehjae.thumb.png.23a857ce209fefbed9597b90118ea00d.png
And, yes - my default emulator for PC-9801 is "Retroarch".

Before the new GUI update, the Emulator field was also auto-filled when there was an entry on the database.

 

aehaehjae.png

Edited by kurzih
  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...