Jump to content
LaunchBox Community Forums
thejamestownoasis

ISSUES WITH MAME AND XARCADE: CONTROLS

Recommended Posts

Hi all- I have had LB with my XArcade tankstick running just fine for a around a year now- but I still post as a NOOB cuz I'm just plain stupid with this stuff.

 

Anyway- I joke that every time my brother's son comes over he breaks something- or many times- multiple things. This time it was my LB/MAME setup. The controls just won't work.

 

I tried a restart and re-inserted the two usb connections into my cpu. No joy. 

 

I use "tab' on my connected keyboard to enter the controls area and I think this is where I get lost. I mostly use this for Golden Tee Complete, so for instance, I will just go into the controls area for the game, double click on a given command, and then just "tap" the key I want. I thought it was this simple but it doesn't work.

 

When I first set up the arcade stick all worked just fine, so I wish I just knew how to "reset" mame, and the Arcade stick, if necessary, It's really all I need to do, for my purposes.

 

Shameful I cannot figure this out and would desperately appreciate any advice.

 

Thanks so much

James

 

 

Edited by thejamestownoasis

Share this post


Link to post
Share on other sites
On 9/22/2020 at 3:48 PM, thejamestownoasis said:

When I first set up the arcade stick all worked just fine, so I wish I just knew how to "reset" mame, and the Arcade stick, if necessary, It's really all I need to do, for my purposes.

Go to your MAME/cfg folder and delete the default.cfg, that is where your general controls are set, as well as any per cabinet changes you have made and they will be named the same as the rom.

image.thumb.png.319c7a008d6a4b35db0a33384a643b57.png

Share this post


Link to post
Share on other sites

Thanks so much- I have done this with no luck, unfortunately.

I had the tv/display volume turned down and was not noticing that the cpu was booting out the xarcade stick and now after minimizing lb/mame, I can see that it’s saying that the stick is “usb not recognized/faulty”- even though the trackball still works and at least one of the buttons does (I say this as I believe the trackball and buttons/joysticks are work on the separate usb connections).

So it could be a usb/xarcade issue??? I just don’t know what my nephew could have done to cause THIS issue?? I just wish I could “reset” the x arcade stick...SO frustrating. Ugh.

James

 

Share this post


Link to post
Share on other sites

And when I delete this file, btw, what happens? Does the xarcade create a new one autmatically? I read I need/should place the config file off their (xarcade’s) website in the config folder. I have done that too with no luck.

 

thanks again

Share this post


Link to post
Share on other sites

Hi everyone

Not sure if this has been solved or even answers your problem, i will try not to make this long but it was a very good learn.

I finally got my xarcade DIY setup ( so not tankstick, just the guts) for my arcade working after spending 5 solid uninterrupted hours configuring buttons etc.

From my experience these are not just plug and play in some cases and from what i know only player one is configured from shop. retroarch and bigbox keyboard layout clash with the xarcade mode1 buttons. so u have to check this out and configure accordingly.

The easiest way to really understand the xarcade is to download all their recommend programs. test program, update program (if u have updateable trimode board) and pc programmer. The test program is the best as it is configured to what each button corresponds to on a keyboard when u press a button on tankstick.

I know its abit time consuming but the first 3 steps is what i took to make sure everything was working on tankstick/diy. Made everything easier after that.

The xarcade is supposedly configured for direct play for mame only if the switch on back of tankstick is set on mode 1(which is just keyboard settings/buttons) which is closest to the serial number or if u have a diy the yellow cable. just flick the switch.

The xarcade is not programmable in mode1.so chances of your nephew changing anything on tank stick is slim. believe me i changed and played with so many settings, the tankstick is not changeable/programmable unless a keyboard is plugged into it.

Process of elimination.

make sure your computer recognises the tank stick, use the xarcade programs to see if its all working then move into your retroarch/LB or BB controls before playing with emulator settings.

I finally figured out the settings for retroarc/bigbox for button layout and can play all my emulated consoles and mame with my diy/tankstick on my arcade with out flicking over the switch to xinput and dininput mode.i  even use my xbox 1 controller at same time. 

Dont want to bore anyone but if u need setting info ill post if anyone needs.

cheers

 

Share this post


Link to post
Share on other sites
On 9/22/2020 at 10:48 AM, thejamestownoasis said:

Hi all- I have had LB with my XArcade tankstick running just fine for a around a year now- but I still post as a NOOB cuz I'm just plain stupid with this stuff.

 

Anyway- I joke that every time my brother's son comes over he breaks something- or many times- multiple things. This time it was my LB/MAME setup. The controls just won't work.

 

I tried a restart and re-inserted the two usb connections into my cpu. No joy. 

 

I use "tab' on my connected keyboard to enter the controls area and I think this is where I get lost. I mostly use this for Golden Tee Complete, so for instance, I will just go into the controls area for the game, double click on a given command, and then just "tap" the key I want. I thought it was this simple but it doesn't work.

 

When I first set up the arcade stick all worked just fine, so I wish I just knew how to "reset" mame, and the Arcade stick, if necessary, It's really all I need to do, for my purposes.

 

Shameful I cannot figure this out and would desperately appreciate any advice.

 

Thanks so much

James

 

 

https://support.xgaming.com/support/solutions/articles/12000003052-configuring-mame-for-x-arcade-use-the-easy-way

Share this post


Link to post
Share on other sites
On 9/30/2020 at 6:41 PM, Krakatoa said:

Thanks I’ve tried this to no avail. I’m to the point now where I would - literally- pay someone money to fix this. I am mentally exhausted over this and my sanity is fraying.

Anyone in the Milwaukee metro area who wants to make some $. Seriously. I cannot take this anymore. The worst thing about problems like this is not even knowing enough about what you‘re doing to know what the problem IS. 
 

I cannot program the tankstick in MAME for the LIFE of me. And the trackball also refuses to work in the game, although it moves the cursor around the screen, which I can use to click on things outside of MAME (say a browser screen) and move over options within the “tab” screen, within MAME. So when I start Golden Tee, it cannot be used, within the game.

 

I tried uninstalling and reinstalling MAME. Deleting the “config” file. Re-applying the “x-arcade” controller file in the controller folder.

who knows what else.

I would absolutely love watching someone who knows what they’re doing figure this out in minutes.

sigh.

James

 

Share this post


Link to post
Share on other sites

Thanks all- I now- inexplicably- am able to program the buttons just fine in mame (through the “tab” menu). I do it specifically through the GT machine because for the life of me, I don’t know how to program the buttons for general use so it works with all/“most” games.

Anyway, still no joy on the mouse. Trackball works fine moving in browsers and on the “tab” menu, but zero functionality in games.

oh, and I broke LB- says I’m missing something in the root folder. I tried to delete and re-install and get the same message.

so now I just go directly through mame.

oh the joy.

 

thanks

James

Share this post


Link to post
Share on other sites

So- like xarcade states- since the trackball works just fine on my desktop, and even in the mame UI, the problem HAS to lie with the mame setup. Right?

again, I have all the buttons set up for GT, the trackball just does not function. I feel like I’m at least making progress.

any ideas on the trackball situ?

 

thanks again

James

Share this post


Link to post
Share on other sites

BTW: my regular mouse used to work concurrently (for better or worse) - now it does not work either- although it did, earlier today. 
 

anyway, I tried some machine specific settings - like turning the mouse functionality “on” as it was “off” - no joy. I tried mouse because I believe that’s how mame “sees” my trackball.

 

EDIT: VICTORY!!! Looks I needed to “save machine settings” after selecting the mouse!!!

 

thanks so much for everyone’s help- it’s so easy when you know what you’re doing!

 

James

6FE01052-BAEC-453D-B301-C587448F8150.jpeg

1D91E912-C51A-441E-8C60-F1E305CADC27.jpeg

Share this post


Link to post
Share on other sites

thanks- I don’t know why the default config- especially after using the xarcade config- doesn’t have the mouse there. I know I did not have to go through this initially, it just worked.

 

truthfully, it made sense it “had” to be mame, as the trackball and buttons worked everywhere else, just as they should since they are seen as a keyboard.

 

thanks again all.

james

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...