Jump to content
LaunchBox Community Forums

DarkRoom


RedSnake
 Share

Recommended Posts

53 minutes ago, RedSnake said:

Hi,

 

I checked it and yes I have the same problem.

It also happens when you 'alt tab' to another application, and Big Box videos continue playing with my Theme, but not with others.

Probably something to deal with window focus management or foreground state.

 

I will work on it, and try to fix this before next BB version update.

 

Thanx for the feedback.

It's because most themes that play video use our ImageVideoView or VideoControl which Big Box then tells to pause when it loses focus. Looks like you are using a plugin in your theme and so it doesn't get told to pause the video.

Link to comment
Share on other sites

Posted (edited)
20 minutes ago, C-Beats said:

It's because most themes that play video use our ImageVideoView or VideoControl which Big Box then tells to pause when it loses focus. Looks like you are using a plugin in your theme and so it doesn't get told to pause the video.

Thanks for the reply.

But yes I know the plugin is the one I developped :)

Its using WMP (not VLC) cause I was planing to use shaders (it's done now and will be released next week).

However indeed it doesn't pause because of what you said.

Is there an event/callback or something like that (BB state or whatever) in the BB librairies/modules that can tell me (or that I can read from) BB main Window state?

The plugin I developped inherits "UserControl" and "IBigBoxThemeElementPlugin", but I don't think there is anything usefull here

Edited by RedSnake
Link to comment
Share on other sites

24 minutes ago, RedSnake said:

Is there an event/callback or something like that (BB state or whatever) in the BB librairies/modules that can tell me (or that I can read from) BB main Window state?

The plugin I developped inherits "UserControl" and "IBigBoxThemeElementPlugin", but I don't think there is anything usefull here

We have the IGameLaunchingPlugin interface that would tell you when a game closed. Wouldn't work for alt tab situations though. Could try subscribing to the Application.Current.MainWindow.Deactivated event to do it. I've not personally tried it so you will need to test it before releasing anything.

  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

Ok thanx a lot I will try that ^^

Edit: the IGameLaunchingPlugin didn't help: my pluggin only overrides video management, not game launching. As a consequence, when I tried to implement your interface, the callbacks (something like beforeGameStart, AfterGameStart and onGameClosed) where never called.

However, adding custom events to Application.Current.Deactivated and Application.Current.Activated event handlers solved my problem, and I was able to be notified when BB main window wasn't "active"

Edited by RedSnake
Link to comment
Share on other sites

27 minutes ago, Styphelus said:

Will there be an alternate lighter version of this theme? I really like it but it's too dark.

Very unlikely, as I didn't save system backgrounds in their "original" lighting (same thing for tv screens or cabs).

So the left part of the theme will never change. Sorry ^^

Now if you are talking about the black overlays that appears on the right of the theme, they are removable (they are either png overlays or xaml black gradiants), but I won't make a "special" version for that.

It's dark on purpose as I usually don't like shiny or saturated visuals + it's done to highlight fanarts and videos

Link to comment
Share on other sites

On 3/25/2021 at 8:14 PM, RedSnake said:

Ok thanx a lot I will try that ^^

Edit: the IGameLaunchingPlugin didn't help: my pluggin only overrides video management, not game launching. As a consequence, when I tried to implement your interface, the callbacks (something like beforeGameStart, AfterGameStart and onGameClosed) where never called.

However, adding custom events to Application.Current.Deactivated and Application.Current.Activated event handlers solved my problem, and I was able to be notified when BB main window wasn't "active"

Good news. You manage to solve the problem then ?

Link to comment
Share on other sites

4 minutes ago, gaialily said:

Hi RedSnake,

Little thing I notice, the neon clearlogo above the TV in the textgamesview flickers a little. Is it intentional ?

Yes. It is the same animation as the one for the marquees for arcade

Link to comment
Share on other sites

Posted (edited)

**************************************************************************

Update available in the download section ("DarkRoom.zip")

**************************************************************************

Hi all.

Please note that for it to work correctly, you will have to delete the following folders from the theme before updating:

- Themes\DarkRoom\Images\Theme

- Themes\DarkRoom\Views

- In addition to the systems already mentionned previously, added Game Views for Arcade Cave, Interton VC-4000, Philips CDi, NEC TurboGrafx-CD and NEC PC-FX platforms.

Please read the changelog for more information

CDi.thumb.jpg.ae5ae1f5ae1126a5ceb43464b8297f63.jpg    PCFX.thumb.jpg.3a024f2161c95d9d6ea88bcf30b9105e.jpg

TGFX-CD.thumb.jpg.3e19b4a2356556c02fb2a34f7ca5d03c.jpg    Cave.thumb.jpg.ad19c43d555b4ccea646a71a0247bc87.jpg

Edited by RedSnake
  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...

Hello, that's a weird error.

From the picture you sent me in private, it seems Big Box tries to find resources in the wrong folder:

image.png.b758de00feb498ba7f77568961021219.thumb.png.650062e1d6b07f89202409a850973f90.png

It tries to find theme resources in "/Launchbox/Core/Themes/DarkRoom" while it should look for them in "/Launchbox/Themes/DarkRoom".

I' am currently using last official version available of Big Box, so should you :)

Do you have the same problem with other themes?

The error is linked to a "relative" path defined in the xaml files, so it should be a pretty standard thing among themes.

I have no idea of what could be causing this.

Note: Sorry but I don't understand Spanish so I'm using English instead ^^

 

 

Link to comment
Share on other sites

9 minutes ago, RedSnake said:

Hello, that's a weird error.

From the picture you sent me in private, it seems Big Box tries to find resources in the wrong folder:

image.png.b758de00feb498ba7f77568961021219.thumb.png.650062e1d6b07f89202409a850973f90.png

It tries to find theme resources in "/Launchbox/Core/Themes/DarkRoom" while it should look for them in "/Launchbox/Themes/DarkRoom".

I' am currently using last official version available of Big Box, so should you :)

Do you have the same problem with other themes?

The error is linked to a "relative" path defined in the xaml files, so it should be a pretty standard thing among themes.

I have no idea of what could be causing this.

Note: Sorry but I don't understand Spanish so I'm using English instead ^^

 

 

His image of the error above says that Launchbox Version 9.10 is being used. This version is from before the core folder was a part of Launchbox, i believe there are differences now as many themes had some issues when the first release to use core was released (as symlinks are now used). I believe the core change was made in Launchbox 11.3, which was released 26th August 2020, this is before you released this theme on the 10th October 2020. So my guess is your theme is not compatible with versions of Launchbox prior to 11.3.

Version 11.3, August 2020

  • Improvement: LaunchBox and Big Box have been upgraded to .NET Core 3.1, which brings with it many advantages, such as better performance, increased security, and more opportunities for cross-platform support

Version 11.5 September 2020

  • Improvement: Better theme compatibility for installs that don't support symbolic links (such as on network drives or external drives running the exFAT file system). Not all themes are supported in this scenario, but theme support should be much improved. We still do not recommend running LaunchBox or Big Box off of a network drive or an external drive with the exFAT file system."
  • Thanks 1
Link to comment
Share on other sites

3 hours ago, neil9000 said:

Su imagen del error anterior dice que se está utilizando Launchbox Versión 9.10. Esta versión es de antes de que la carpeta principal formara parte de Launchbox, creo que ahora hay diferencias ya que muchos temas tenían algunos problemas cuando se lanzó la primera versión para usar el núcleo (ya que ahora se usan enlaces simbólicos). Creo que el cambio principal se realizó en Launchbox 11.3, que se lanzó el 26 de agosto de 2020, esto es antes de que lanzaras este tema el 10 de octubre de 2020. Así que supongo que tu tema no es compatible con las versiones de Launchbox anteriores a la 11.3.

Versión 11.3, agosto de 2020

  • Mejora: LaunchBox y Big Box se han actualizado a .NET Core 3.1, lo que trae consigo muchas ventajas, como un mejor rendimiento, mayor seguridad y más oportunidades de soporte multiplataforma.

Versión 11.5 Septiembre de 2020

  • Mejora: mejor compatibilidad de temas para instalaciones que no admiten enlaces simbólicos (como en unidades de red o unidades externas que ejecutan el sistema de archivos exFAT). No todos los temas son compatibles en este escenario, pero el soporte de temas debería mejorarse mucho. Todavía no recomendamos ejecutar LaunchBox o Big Box desde una unidad de red o una unidad externa con el sistema de archivos exFAT ".

image.thumb.png.1382d0a0f160d668036ce2f2323b60fd.png

image.png.cf6a65a0afd331ef8cb1d0dee65ebffb.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...