Jump to content
LaunchBox Community Forums
Sign in to follow this  
KAG

How to close Supermodel 3 only using arcade controls?

Recommended Posts

I've found the scripts and a number of other topics. They mainly say I need to set up a button combination in the automation section. I'm confused since I can't find any automation settings for the controller. This is running in an arcade cabinet and I'd love to keep exiting games as simple and uniform as possible. Thanks

Share this post


Link to post
Share on other sites
16 minutes ago, KAG said:

I've found the scripts and a number of other topics. They mainly say I need to set up a button combination in the automation section. I'm confused since I can't find any automation settings for the controller. This is running in an arcade cabinet and I'd love to keep exiting games as simple and uniform as possible. Thanks

In LB and BB there are dedicated controller map options you need to set in both. The controller automation is right in the settings page for both LB and BB.

LaunchBox: \Tools\Options\Game Controller > Mappings

BigBox: \Settings\Options\Controller Mappings (In BigBox set it for the option labeled "Close Active Window" - Do not set it for the one labeled "Exit" that is for exiting BigBox)

 

Screen Shot 2020-10-18 at 12.28.48 PM.png

Screen Shot 2020-10-18 at 12.30.22 PM.png

Share this post


Link to post
Share on other sites
1 hour ago, Retro808 said:

In LB and BB there are dedicated controller map options you need to set in both. The controller automation is right in the settings page for both LB and BB.

LaunchBox: \Tools\Options\Game Controller > Mappings

BigBox: \Settings\Options\Controller Mappings (In BigBox set it for the option labeled "Close Active Window" - Do not set it for the one labeled "Exit" that is for exiting BigBox)

 

Screen Shot 2020-10-18 at 12.28.48 PM.png

Screen Shot 2020-10-18 at 12.30.22 PM.png

Thanks for your reply. I did go into Launchbox and set the "Exit Game" to the button I want. I also went into BB and set the "Close active window" to the same button. For some reason, its still not exiting Supermodel 3. I'm starting to wonder if the script I got is incorrect or if I've got it in the wrong place. I attached the photo of my screen. Hopefully you can read it! I'm about to throw myself and this cabinet out the window haha.

IMG_4538.JPG

Share this post


Link to post
Share on other sites
7 minutes ago, KAG said:

Thanks for your reply. I did go into Launchbox and set the "Exit Game" to the button I want. I also went into BB and set the "Close active window" to the same button. For some reason, its still not exiting Supermodel 3. I'm starting to wonder if the script I got is incorrect or if I've got it in the wrong place. I attached the photo of my screen. Hopefully you can read it! I'm about to throw myself and this cabinet out the window haha.

IMG_4538.JPG

What AHK script are you using? There is not script in that image.

Post a copy of the script so we can confirm it is good. Also if you ever need to use an AHK to close an emulator it gets pasted into the "Running AHK" tab. The "Exit AHK" tab is for having issues when exiting and emulator from the LB/BB Pause Menu.

Share this post


Link to post
Share on other sites
3 hours ago, KAG said:

Thanks for your reply. I did go into Launchbox and set the "Exit Game" to the button I want. I also went into BB and set the "Close active window" to the same button. For some reason, its still not exiting Supermodel 3. I'm starting to wonder if the script I got is incorrect or if I've got it in the wrong place. I attached the photo of my screen. Hopefully you can read it! I'm about to throw myself and this cabinet out the window haha.

IMG_4538.JPG

Ah, I'm sorry I attached the wrong image. I have this script in the "Running Autohotkey Script" 

; This section closes Supermodel when pressing Escape
$Esc::
{
    Process, Close, {{{StartupEXE}}}
} 

Share this post


Link to post
Share on other sites
46 minutes ago, KAG said:

Ah, I'm sorry I attached the wrong image. I have this script in the "Running Autohotkey Script" 


; This section closes Supermodel when pressing Escape
$Esc::
{
    Process, Close, {{{StartupEXE}}}
} 

That script should work, but I would recommend changing it. Process, Close command is a hard close and on some emulators can cause issues.

Try the following:

$Esc::
{
    WinClose, ahk_exe {{{StartupEXE}}}
}

You can be even more specific like:

$Esc::
{
    WinClose, ahk_exe supermodel.exe
}

If that does not work can you post an image of your controller automation setting in LB showing what you have mapped to Exit.

Share this post


Link to post
Share on other sites
1 hour ago, Retro808 said:

That script should work, but I would recommend changing it. Process, Close command is a hard close and on some emulators can cause issues.

Try the following:


$Esc::
{
    WinClose, ahk_exe {{{StartupEXE}}}
}

You can be even more specific like:


$Esc::
{
    WinClose, ahk_exe supermodel.exe
}

If that does not work can you post an image of your controller automation setting in LB showing what you have mapped to Exit.

I tried the more specific one and it didn't work. It also caused Launchbox to lose focus after I exited manually with the keyboard. Here's photos of my button settings. Its very possible I'm missing something here. I'm burnt out on this thing, been at it since yesterday morning and haven't really quit much haha. Hopefully you can read them, this PC isn't connected to the internet and is just sitting in the cabinet so its difficult to access. Thanks again for your time and help!

IMG_4540.JPG

IMG_4539.JPG

Edited by KAG

Share this post


Link to post
Share on other sites

Not sure. I do not have the version of the exe. I do have 777 and 783 and both work fine and both do not even use an AHK. Either will exit a game using only the set command mapped in the controller mappings in LB and BB. I do use a button combo.

Removing by controller mapping and trying with just either of the AHK I posted worked as well.

There is nothing special inside the supermodel ini you need to worry about.

Can you exit other emulators ok?

Are you running supermodel.exe as admin by chance?

Screen Shot 2020-10-18 at 7.54.01 PM.png

Screen Shot 2020-10-18 at 7.54.13 PM.png

Screen Shot 2020-10-18 at 7.55.05 PM.png

Share this post


Link to post
Share on other sites
1 hour ago, Retro808 said:

Not sure. I do not have the version of the exe. I do have 777 and 783 and both work fine and both do not even use an AHK. Either will exit a game using only the set command mapped in the controller mappings in LB and BB. I do use a button combo.

Removing by controller mapping and trying with just either of the AHK I posted worked as well.

There is nothing special inside the supermodel ini you need to worry about.

Can you exit other emulators ok?

Are you running supermodel.exe as admin by chance?

Screen Shot 2020-10-18 at 7.54.01 PM.png

Screen Shot 2020-10-18 at 7.54.13 PM.png

Screen Shot 2020-10-18 at 7.55.05 PM.png

I haven’t specifically set supermodel to run in administrator mode. I’m not married to that version, I just want to be sure I can run Star Wars Trilogy. That’s the only game I’m running with the emulator. I tried a lower version but it was really fast. 

Share this post


Link to post
Share on other sites
On 10/18/2020 at 7:08 PM, Retro808 said:

Not sure. I do not have the version of the exe. I do have 777 and 783 and both work fine and both do not even use an AHK. Either will exit a game using only the set command mapped in the controller mappings in LB and BB. I do use a button combo.

Removing by controller mapping and trying with just either of the AHK I posted worked as well.

There is nothing special inside the supermodel ini you need to worry about.

Can you exit other emulators ok?

Are you running supermodel.exe as admin by chance?

 

 

So, I tried the 783 version and that finally fixed the exiting! But, Launchbox still loses focus after exiting. I don't currently have any AHK scripts running, is there something I should add to fix that?

 

Edit: So, the exit button was working until I went and mapped my controls in Supermodel 3. As soon as I did that, I went back in and couldn't exit. Any ideas? I am using the GUI version but I launch Supermodel 3 with the regular exe in Launchbox. 

Edit 2: I got it! I kept noticing Launchbox saw the exit button as "Button 2" but any time I mapped my other buttons, which vary from 2 different encoder boards (two players on each, as windows sees it), it never specified which controller it was reading from. So I rewired the buttons to where they'd never overlap button numbers and that did it. It now exits fine and stays focused on Launchbox. Thanks for trying to help, I'm just relieved I finally got it! Now, onto other issues unrelated to LB! haha

 

Edited by KAG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...