Jump to content
LaunchBox Community Forums
thimolor

11.8 Additional Apps not working

Recommended Posts

Hi,

I'am using a program named HRC to switch my refresh rate from 60 to 50 hz for certain emulators, in this case FS-UAE. I have used the Additional Apps for this purpose. Running the HRC program before and after the main application. This used to work on older versions of LaunchBox, but now the option "Automatically run after main application" does not seem to work properly. The 50 hz command should run before FS-UAE is started (this works), but the "run after" option seems to run right after 50 hz resulting in FS-UAE running in 60 hz mode (should be 50 hz). So the trigger is not working correctly, or so I assume.

Does anyone else have this problem?additional-application-run-before.thumb.png.f2a9e51e05685fa5caf2ce036f5b7974.pngadditional-application-run-after.thumb.png.5259ebb4cbf4274df0db05a20c61a7d6.png

Share this post


Link to post
Share on other sites

Have you had this working specifically with FS-UAE before?  

I don't have this setup on my cab anymore, but I'm guessing what might be happening is the emu's command line is using Launcher.exe but this then spawns something else like "fs-uae.exe" or "fs-uae-launcher.exe".  

So when you launch a game, HRC-50hz, kicks in and then Launcher.exe starts.  The problem then is (assuming I'm correct) Launcher.exe starts fs-uae-launcher.exe (or something else similar) then exits itself.  Which [Launcher.exe] is considered the Main Application.  So HRC-60hz now kicks in and the game plays.  Unfortunately it's now playing at 60hz.

And if I'm totally off base, never mind. 😊

  • Thanks 1

Share this post


Link to post
Share on other sites
16 minutes ago, JoeViking245 said:

And if I'm totally off base, never mind. 😊

I think you are likely exactly right. 

I had a similar issue with LEDBlinky scripts i was using and fs-uae some time ago. I corrected it by calling fs-uae.exe directly, but this led to some other inconveniences.

Unfortunately I don't have my scripts anymore as I've switched to the P-uae core in Retroarch for my Amiga games. It just works easier for the games I need and has a cleaner look that comes with Retroarch. 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, JoeViking245 said:

Have you had this working specifically with FS-UAE before?  

I don't have this setup on my cab anymore, but I'm guessing what might be happening is the emu's command line is using Launcher.exe but this then spawns something else like "fs-uae.exe" or "fs-uae-launcher.exe".  

So when you launch a game, HRC-50hz, kicks in and then Launcher.exe starts.  The problem then is (assuming I'm correct) Launcher.exe starts fs-uae-launcher.exe (or something else similar) then exits itself.  Which [Launcher.exe] is considered the Main Application.  So HRC-60hz now kicks in and the game plays.  Unfortunately it's now playing at 60hz.

And if I'm totally off base, never mind. 😊

Yes I have, but I don't have my previous settings available anymore. You are right about the issue. Now I just need to find out the correct commmand-line parameters to run FS-UAE with the additional apps.

FOUND IT! fs-uae-launcher.exe was the right one. Thank you so much!


 
Edited by thimolor
  • Game On 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...