Jump to content
LaunchBox Community Forums

Recommended Posts

Hi, i made a big update on one of my plugin but i was too hurry and forget to verify if Launchbox was in .net framework or core.
- First i would to know if Launchbox will stay in .net framework (that will stay in .net framework 4.8 according to MS)

- Second: Currently i have an error because i  installed the system drawning common by nugget package and this is a 5.0 version, and it raise an exception if i join it asking to modify security right... i prefer to ask if somebody ever tried to develop a .net core 3X plugin before.

In the worst case i will remake it in .net framework i don't think there is so much things to change, hardest is done i modified it since forms to wpf...

Best regards.

Link to post
Share on other sites

Yeah .net core works.

To fix system drawing error.

Install system drawing 5.0.

Once installed open project file and replace:

  <ItemGroup>
    <PackageReference Include="System.Drawing.Common" Version="5.0.0" />
  </ItemGroup>

to

  <ItemGroup>
    <PackageReference Include="System.Drawing.Common" Version="4.7.0" />
  </ItemGroup>

works for me.

Edit: I didnt read your post properly. I haven't had any issues with security rights. Not sure if my solution will work for you. 

 

Edited by jayjay
Link to post
Share on other sites
  • 3 months later...

Hi everybody,

Yesterday same problem and i was unable to remind me the exact method i used last time, but i made a lot of try and understood where was my problems. I make a feedback for the future, perhaps even for me if i forgot again.

I describe it again.... you can't see your plugin in tools, and when you read the debug log file you read that some external dll are impossible to find. If you add this dll into your package you will have an error from windows that denied access for compatibility reason (don't modify uac or anything) .

- Launchbox uses 4.7.2version System.Drawing.dll  (used at least for the icon for your application).
- My plugin used 5.0.0 version and in all case i couldn't use another because i use some other custom library i made based on the >= 5.0.0 version of the Microsoft.Compatibility package.

then:
- I changed for the custom library i use for a previous version of the Microsoft.Windows.Compatibility package, with the 3.1.1 i have the 4.7.0 version of System.Drawing.Common.
- I changed in my plugin from V5.0.0 System.Drawing.Common to v4.7.2.

In reality it was not so hard, the real problem was to understand where was exactly the problem.

I don't know if there is a way to force the plugin to use most recent dll (i doubt, i have my self an application i made and if i remember well it's written like that to be sure to have exactly the same thing between Core and Plugins) .

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...