Jump to content
LaunchBox Community Forums
BZZ

Duplication of games

Recommended Posts

So recently I formated my C drive and at the same time changed order of all my other disks. This has broken all links to games in Launchbox, which was not a problem as it gave me opportunity to clean and clear them a little. Unfortunately now I have duplicates in 3DO and Xbox360. What the program does it it adds the old file locations at the same time as the new ones. It is not a case of Cue/Bin/Iso. So it goes like that:

I open the launchbox it has duplicates in 3DO and Xbox360.

I remove duplicates and close the programs.

I open the program again and the duplicates are back.

 

Is that a known issue? Does anyone know how can I remove them permanently? Is it a 'config' problem wheres 1 file somewhere can be removed and list will re-fresh ?

 

Thank you in advance.

Edited by BZZ

Share this post


Link to post
Share on other sites
3 minutes ago, BZZ said:

So recently I formated my C drive and at the same time changed order of all my other disks. This has broken all links to games in Launchbox, which was not a problem as it gave me opportunity to clean and clear them a little. Unfortunately now I have duplicates in 3DO and Xbox360. What the program does it it adds the old file locations at the same time as the new ones. It is not a case of Cue/Bin/Iso. So it goes like that:

I open the launchbox it has duplicates in 3DO and Xbox360.

I remove duplicates and close the programs.

I open the program again and the duplicates are back.

 

Is that a known issue? Does anyone know how can I remove them permanently? Is it a 'config' problem wheres 1 file somewhere can be removed and list will re-fresh ?

 

Thank you in advance.

Well I solved my own problem immediately after posting. Sorry, but might help someone.

Go to (...)\LaunchBox\Data\Platforms and remove the XML files that say 'backup'. For some reason Launchbox was loading both the original file and the backup.

Share this post


Link to post
Share on other sites
4 hours ago, BZZ said:

Well I solved my own problem immediately after posting. Sorry, but might help someone.

Go to (...)\LaunchBox\Data\Platforms and remove the XML files that say 'backup'. For some reason Launchbox was loading both the original file and the backup.

LB is looking for an xml file with your platform name in it. If you create any extra files and place them in that folder and the file has the platform's name it LB will try to load it as well. There should only ever be one file with your platform name in it in that folder.

Share this post


Link to post
Share on other sites
2 hours ago, Retro808 said:

LB is looking for an xml file with your platform name in it. If you create any extra files and place them in that folder and the file has the platform's name it LB will try to load it as well. There should only ever be one file with your platform name in it in that folder.

Well yes... I did not create the files though, so launchbox must have. Or I've done it in involuntary manner by clicking something in launchbox.

Edited by BZZ

Share this post


Link to post
Share on other sites
Just now, BZZ said:

Well yes... I did not create the files though, so launchbox must have. Or I've done it in involuntary manner by clicking something in launchbox.

LB only creates backups in the \Backups folder. Something else you are using is creating that file. Any chance you are using Skraper to scrape games for media?

Share this post


Link to post
Share on other sites
1 minute ago, Retro808 said:

LB only creates backups in the \Backups folder. Something else you are using is creating that file. Any chance you are using Skraper to scrape games for media?

No mate, I am not using any external scrapers with Launchbox.

Share this post


Link to post
Share on other sites
1 minute ago, BZZ said:

Well yes... I did not create the files though, so launchbox must have. Or I've done it in involuntary manner by clicking something in launchbox.

I'm betting you have used scraper, that will create them. Its a awful program that should never be touching other programs data files to do what it does.

Share this post


Link to post
Share on other sites
1 minute ago, neil9000 said:

I'm betting you have used scraper, that will create them. Its a awful program that should never be touching other programs data files to do what it does.

I do not use scrapers with Launchbox. I do use them but not with this front end. There is no external programs other than ones launchbox uses by itself.

Edited by BZZ

Share this post


Link to post
Share on other sites
Just now, BZZ said:

No mate, I am not using any external scrapers with Launchbox.

Launchbox itself will never create those files, and certainly not in that location, so something else has created them. Launchbox simply doesnt have the code to do what you are seeing. If its not coded to create those files there (which it's not) then it simply cant create them. Programs have to be coded to do things, if that code doesnt exist its impossible for it to do it.

Share this post


Link to post
Share on other sites

Is that a build you did from scratch or one of the build from like Colpipes? I have seen those have the backup files in it as the buikder used skraper. Nothing LB does will duplicate a xaml file in a spot it knows it does not like it. All it will do is back the file up with the exact name in the /Backups folder.  

Share this post


Link to post
Share on other sites
Just now, neil9000 said:

Launchbox itself will never create those files, and certainly not in that location, so something else has created them. Launchbox simply doesnt have the code to do what you are seeing. If its not coded to create those files there (which it's not) then it simply cant create them. Programs have to be coded to do things, if that code doesnt exist its impossible for it to do it.

Ok mate. Launchbox clearly has the code to do it if it does it in another location. The problem has been solved anyway. I have not interfered with my launchbox drive in anyway with external scrapers. That by the way are not awful but great and useful. I used them with Batocera, Recalbox and Lanka. I do not know what caused creation of these files in that location but whatever it was had no external interference.

Share this post


Link to post
Share on other sites
2 minutes ago, Retro808 said:

Is that a build you did from scratch or one of the build from like Colpipes? I have seen those have the backup files in it as the buikder used skraper. Nothing LB does will duplicate a xaml file in a spot it knows it does not like it. All it will do is back the file up with the exact name in the /Backups folder.  

The launchbox was installed and that is it. Emulators were added and path to games. Before formating the system drive there were no duplicates. The appeared right after format.

Share this post


Link to post
Share on other sites
16 minutes ago, BZZ said:

The launchbox was installed and that is it. Emulators were added and path to games. Before formatting the system drive there were no duplicates. The appeared right after format.

Still curious as to what is creating that file. We have never seen LB create those files. LB does have the coding to create a backup but all it does is just backup the folder in zipped format in the correct folder. It is not even coded to create a file named "Insert Platform Name Here_backup.xml". For the users that have had them it was due to skraper or from a downloaded build. This is not a comment to argue against what you are saying you have done, just pushing the discussion to see if we can see what else might be happening. You fixed what is going on now which is good. So hopefully those backups do not occur again.

What plugins are in your plugin folder?

Share this post


Link to post
Share on other sites
30 minutes ago, Retro808 said:

Still curious as to what is creating that file. We have never seen LB create those files. LB does have the coding to create a backup but all it does is just backup the folder in zipped format in the correct folder. It is not even coded to create a file named "Insert Platform Name Here_backup.xml". For the users that have had them it was due to skraper or from a downloaded build. This is not a comment to argue against what you are saying you have done, just pushing the discussion to see if we can see what else might be happening. You fixed what is going on now which is good. So hopefully those backups do not occur again.

What plugins are in your plugin folder?

No plugins whatsoever. Only Launchbox with bios and emulator files added.

Share this post


Link to post
Share on other sites
20 minutes ago, BZZ said:

No plugins whatsoever. Only Launchbox with bios and emulator files added.

Thanks and it was only those 2 platforms that had the duplicates right? Was LB originally on the C drive you reformatted or on one of the others?

Share this post


Link to post
Share on other sites
14 minutes ago, Retro808 said:

Thanks and it was only those 2 platforms that had the duplicates right? Was LB originally on the C drive you reformatted or on one of the others?

Launchbox was on another drive. Yes it was only these two platforms. It is very unlikely that the format had anything to do with it, it is simply odd that it happened immediately after format. I mean format, driver install all other things you do before you start gaming....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...