Jump to content
LaunchBox Community Forums

Why do somethings work in launchbox but not Bigbox?


Recommended Posts

I set everything up using launchbox, all the usual emulators etc, and thought big box was merely a more arcade-orientated wrapper and that everything would have the same functionality, but I have found a number of instances so far where everything works fine in launchbox but not big box - for instance, Daphne Dragons lair works great in launchbox, but in BB I just get a dos box on the screen and the game does not load, if I load a ps3 game using rpcs3 then launchbox quits it ok but I cannot quit at all using BB even though other systems work ok. Incredibly Demon Attack on the Atari 2600 works fine in LB but in BB has no sound.

 

I am at the point where BB is so hit and miss in terms of what games work then I have no option but to use Launchbox which is very disappointing considering the cost...

Link to post
Share on other sites

Issues like this almost always related to system-specific issues/conflicts with the startup or pause screens. Can you try disabling the startup and pause screens in Big Box to see if that fixes the issue? Those options are available in the Big Box options list under Game Startup and Game Pause (iirc).

Link to post
Share on other sites

Thanks for the fast reply, I will certainly take a look at this in the next few days but for the time being will leave things as they are and use launchbox - I have spent days getting everything up and running and it was very disappointing for it not to work in bb as I had expected, but the overall launchbox experience is so good anyway that it will serve my needs as it is, certainly the best front end I have used. 

Link to post
Share on other sites

seems like that worked, I just disabled both and now have no problems with Daphne, and somehow Demon Attack has started to work again properly too so who knows what was going on there...

 

Quick question - is there a way of getting Daphne to close when I press the home button on my xbox one controller - this works with most emulators and I have even got it working on RPCS3 following guidance here but cant seem to find anything similar for Daphne...

Link to post
Share on other sites
4 hours ago, chubsta said:

seems like that worked, I just disabled both and now have no problems with Daphne, and somehow Demon Attack has started to work again properly too so who knows what was going on there...

 

Quick question - is there a way of getting Daphne to close when I press the home button on my xbox one controller - this works with most emulators and I have even got it working on RPCS3 following guidance here but cant seem to find anything similar for Daphne...

To be honest, I've never emulated Daphne myself so I probably won't be much help there. You should be able to use the built-in app closing tools for Big Box, but there are always emulators that are exceptions and don't use standard practices. Not sure if Daphne is one of those or not. Most likely though, if you can configure Daphne to exit with the Escape key, the controller exiting should work with it.

Link to post
Share on other sites
6 hours ago, chubsta said:

seems like that worked, I just disabled both and now have no problems with Daphne, and somehow Demon Attack has started to work again properly too so who knows what was going on there...

 

Quick question - is there a way of getting Daphne to close when I press the home button on my xbox one controller - this works with most emulators and I have even got it working on RPCS3 following guidance here but cant seem to find anything similar for Daphne...

Daphne should work fine with the built in controller exit features within BB/LB if set to Guide button on Xbox One controller.  So somewhat odd it isn't working.  As alternative, here was an AHK I used prior to that built in feature implementation in LB/BB.  You would need to place this in the Running AutoHotkey Script tab for Daphne emulator within LB:

; =================================================================================
; Daphne 
; Must use ALT F4 since Process Close command will not work
; exit with press of XBOX Guide Button
; =================================================================================
$vk07::
Send !{f4}
return

Sometimes I have seen issues where things are not working on AHK side within LB/BB if Daphne loses focus. Particularly if the vertical resolution isn't set close to the actual monitor height or a close multiplier of it resulting in the windows moving around when Daphne changes resolution during launch.  Might check your batch file used to call Daphne in that case if above AHK still isn't working. 

Edited by sundogak
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...