Jump to content
LaunchBox Community Forums

MAME 0.78 Romset Import Error on Windows


Recommended Posts

My apologies if this has been asked before. I looked up this issue and couldn't find a solution. 

I'm trying to import and trim a MAME 2003 0.78 reference set and I'm having some trouble. 

If I try to set the MAME version to the 0.78 emulator when importing I get an error that says "MAME.xml child node not named machine" and it won't complete. If I use the newest version of MAME it will let me import the games list, but when I try to export them it says I have no Roms. 

So a few questions:

1. Does it matter if I just use the newest MAME so I can import successfully, or should I try to figure out this child node error some more? 

2. How do I get Launchbox to find my MAME Roms once imported? As I said, I've gotten them over before but nothing plays because it says No Rom. I know there is something I have to edit, but I can't seem to find it. 

My end goal is to have a nicely curated MAME set for my Raspberry Pi. 

Thanks for the help. Sorry I'm such a noob.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Hi guys, I believe this is because the *really old* MAME versions (like 8+ years old) don't have support for the -listxml feature that is required for the importer to work properly. Unfortunately your only options here are to either upgrade your ROM set and MAME version to something at least relatively modern, or use an older version of LaunchBox that just assumes that you have a modern version of MAME. However, even the older versions of LaunchBox would not have worked well with such an old version of MAME, because it would have imported a bunch of games that didn't previously work.

  • Thanks 1
Link to post
Share on other sites
Posted (edited)

Thanks, Jason. 

That's good to know, and will hopefully prevent people from wasting too much time trying to force it to work. 

 

I ended up using Simple Arcade Multifilter to do what I needed to do. Worked like a charm! 

Edited by JimboFett
Link to post
Share on other sites
On 3/10/2021 at 4:00 PM, JimboFett said:

Thanks, Jason. 

That's good to know, and will hopefully prevent people from wasting too much time trying to force it to work. 

 

I ended up using Simple Arcade Multifilter to do what I needed to do. Worked like a charm! 

Hi, I had a look at Simple Arcade Multifilter but couldn't work out how to remove just duplicates - did you work it out?

Link to post
Share on other sites

having same issue with version 0.159 rom set.  I think ot has something to do with a change from game to machine in the xml structure.  But I am unable to use as well.  Does simple arcade multiplier allow you to import into launch box or are you using that as your front end?

 

Also, can I just manually somehow add the roms that I want to use?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...