Jump to content
LaunchBox Community Forums

Anyone using singe v2 daphne ?


WInzen
 Share

Recommended Posts

NEW win 10 intel 5 8 gb ram 500 gb ssd internal gpu

hello :)

so my singe 2.00 / daphne games randly crash as they progress.  Crashes to desktop closing the software entirely.

A good example for anyone to test is - play mad dog 1 and progress to the choose a location menu and choose anyone then play and it will crash every time in those 4 areas.  No idea if this is a time played problem or specific to those areas but it prevents progress.

I am building an arcade for family and this game is the most important so I hope for it to work perfectly within reason.

Ive googled this but its old tech.

  • Does anyone use these lazer disc games and if so any issues?

thanks for any help.

 

error.png

Edited by WInzen
Link to comment
Share on other sites

  • WInzen changed the title to Anyone using singe v2 daphne ?

it may just be with mad dog.  Can you test mad dog and see if it crashes. Or are you aware of why it might crash?

I am using the software direct from the webiste.  CAn i ask how youre running it and are you using LB ?

thanks for reply

Link to comment
Share on other sites

13 minutes ago, WInzen said:

it may just be with mad dog.  Can you test mad dog and see if it crashes. Or are you aware of why it might crash?

I am using the software direct from the webiste.  CAn i ask how youre running it and are you using LB ?

thanks for reply

I tested again before posting, no issues.

No way of knowing for sure but could be where you acquired your Mad Dog files... bad singe file possibly. Knowing for sure whether it's just that game or several would help narrow it down.

Maybe try running without the -f, -z, and -w options and adding the trace option -t, might display an error that may help.

Edited by Headrush69
  • Like 1
Link to comment
Share on other sites

51 minutes ago, Headrush69 said:

I tested again before posting, no issues.

No way of knowing for sure but could be where you acquired your Mad Dog files... bad singe file possibly. Knowing for sure whether it's just that game or several would help narrow it down.

Maybe try running without the -f, -z, and -w options and adding the trace option -t, might display an error that may help.

ive attached an image of my drive setup above...

maybe you can see the issue comapred to yours ?

as said all files from the official site kangaroo punch studios  / singe

What does " -f, -z, and -w options and adding the trace option -t, might display an error that may help. " mean ?

thanks for help.

 

 

Edited by WInzen
Link to comment
Share on other sites

9 minutes ago, WInzen said:

ive attached an image of my drive setup above...

maybe you can see the issue comapred to yours ?

I was referring to corruption within one of the files, not the files you have per say. (That's why I wanted to know if it was just Mad Dog)

I can say that my Singe2 installation does not have any of those xml and sqlite files. By chance did you originally use Singe1 with Daphne?

13 minutes ago, WInzen said:

What does " -f, -z, and -w options and adding the trace option -t, might display an error that may help. " mean ?

Basically, it makes sure you aren't running fullscreen, with the console window open so you can see "debug" information. I did a little more testing and it appears just adding the -t option will also had that debugging info into a file trace.txt inside the script folder of the game you are running. So I would add that option to however you are launching Singe2, run MAd Dog, let it crash and than check that file for possible errors messages.

  • Like 1
Link to comment
Share on other sites

17 minutes ago, Headrush69 said:

I was referring to corruption within one of the files, not the files you have per say. (That's why I wanted to know if it was just Mad Dog)

I can say that my Singe2 installation does not have any of those xml and sqlite files. By chance did you originally use Singe1 with Daphne?

Basically, it makes sure you aren't running fullscreen, with the console window open so you can see "debug" information. I did a little more testing and it appears just adding the -t option will also had that debugging info into a file trace.txt inside the script folder of the game you are running. So I would add that option to however you are launching Singe2, run MAd Dog, let it crash and than check that file for possible errors messages.

Possibly I have set it up wrong. Can i see a photo of your set up?  I found if i dont have those scripts which came with the rom packs , then they wont run via the menu exe.

I am brand new so only know singe 2.00.  I have never seen daphne.

I am not sure how to put in the commands but im guessing you do that in the exe launcher...

 

 

singe.png

Edited by WInzen
Link to comment
Share on other sites

6 minutes ago, WInzen said:

Possibly I have set it up wrong. Can i see a photo of your set up?  I found if i dont have those scripts which came with the rom packs , then they wont run via the menu exe.

Those xml and sqlite files are from your Bittorrent client you used to download the games. They are not needed once downloaded. 

6 minutes ago, WInzen said:

I am not sure how to put in the commands but im guessing you do that in the exe launcher...

How are you launching the game now, directly running Singe2 or with LaunchBox?

I don't use the Emulation tab of LaunchBox to start my Singe2 games. Since there are just a few, I call the Singe2 application directly and use custom command line options for each.

Attached is a screenshot of my settings for Mad Dog McCree.

 

Capture.JPG

Link to comment
Share on other sites

From LB. As you can see im running from the menu bat (see below) , as when i click on the exe it says error unable to locate script (see image)

As i know nothing about scripts i suspect its the lack of script which is a problem ?

Your setup looks correct. Mine looks flawed. 

 

Should I be running the singe in the background while using the menu bat? maybe thats the issue.  I removed all those scripts and it seems to be running much better :)

But would like to get it set up in LB correctly..

Did you make a script ?  CAn i have a copy or a look at your file placement...

 

thanks for help..means a lot.

lb.png

singe.png

Edited by WInzen
Link to comment
Share on other sites

I did not make any scripts, Singe2 includes all the ones you need.

The menu.dat file just starts Singe2 with a script to present a menu of the games first. I am of the opinion that using a frontend (LB) to call another frontend (That menu) isn't a great option, but to each his own.

If you run that menu.dat outside of LaunchBox, does it start properly?

  • Like 1
Link to comment
Share on other sites

ok so after removing all those useless torrent scripts it now runs without a crash so clearly they were the issue! Thanks for telling me to remove them haha

I am launching from launch box and then big box long term.  I notice that menu bat launches singe2 in the background.

I suspect having 2 front ends isnt idea.

 

  • When I exit pressing escape I notice singe 2 is still running in the background.  DO you know how i can Force it to shut down upon escape ?

 

  • ALso as a side note....i notice that in mad dog the first shooter at the sherrifs office wont die and so wont allow progress. Some bottles dont blow up either.  Im using a mouse. I plan to use sinden once its all working.  Do you have this issue at all?

 

bad man.png

Edited by WInzen
Link to comment
Share on other sites

9 minutes ago, WInzen said:

When I exit pressing escape I notice singe 2 is still running in the background.  DO you know how i can Force it to shut down upon escape ?

If you start menu.bat instead of the game directly, when you hit escape, it should return to the menu, which you would have to hit escape a second time.

11 minutes ago, WInzen said:

Also as a side note....i notice that in mad dog the first shooter at the sherrifs office wont die and so wont allow progress. Some bottles dont blow up either.  Im using a mouse. I plan to use sinden once its all working.  Do you have this issue at all?

I've never shot the guy running out from the sheriff's office as well. I had this issue when running Singe1 also. I really left investigating it until my Sinden's arrives as well. I do see from using the -t trace option that the gun is locked for a a bit on that scene and it could be firing too soon could be a problem. If I figure it out for sure, I'll let you know.

  • Like 1
Link to comment
Share on other sites

1 minute ago, Headrush69 said:

If you start menu.bat instead of the game directly, when you hit escape, it should return to the menu, which you would have to hit escape a second time.

I've never shot the guy running out from the sheriff's office as well. I had this issue when running Singe1 also. I really left investigating it until my Sinden's arrives as well. I do see from using the -t trace option that the gun is locked for a a bit on that scene and it could be firing too soon could be a problem. If I figure it out for sure, I'll let you know.

thanks for all the help. its all working correctly now but once i have the pc in the arcade machine and install the light guns (with recoil!) i might ask you how you got on. 

Not sure how many of us are playing these old games but for me its what i played with my dad when i was small and now plan to use it to help us spend more time together haha

Feel free to say hi on anything so i can return the help ;)

Im making custom art work for these games specifcally which ill post for all. Need a good collage pic for LB for all these games!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...