Jump to content
LaunchBox Community Forums

Cannot import MS DOS games


Recommended Posts

I am trying to import MS-DOS games on Launchbox 11.9 (Windows 10).  I followed the video here:

But it doesn't work!  When I press Finish at the end of the Wizard, it just ends, nothing imports.  I got it to work years ago on an earlier version of LB but not any more.

I tried importing my DOS games in folders by dragging-and-dropping them into Launchbox direct - this DOES import them, but the Application Paths are all wrong, they looks for the games in the Launchbox app directory, not in the directory in which they are stored.  I could change them all manually but that's going to take ages.

image.thumb.png.128a2b688d751e0da996216da8e20747.png

I tried a fresh install of Launchbox in a separate directory, same problem.

I tried moving the games to a different directory and importing them from there, same problem.  

I tried DOSBox pure on Retroarch, which MIGHT be a solution for more arcade-type games, but it's a poor option for keyboard-heavy games (I've got a thing for old-school interactive fiction).  

Any ideas?  I'm at my wits end with this one.

Edited by Terminates Here
Added detail
Link to post
Share on other sites
  • 4 weeks later...

Ik can confirm this problem. After using the wizard with a map with lots of submaps with dos games it imports nothing.

Also the drag and drop feature screws up the executable paths.

It now is very cumbersome, because the only workaround I can think of is adding every map manually to import them...

 

Edit: I can see in the release notes for the upcoming version 11.10 that the drag & drop issue is fixed. Hopefully the MS DOS import issue with the submaps is also fixed.

https://www.launchbox-app.com/about/changelog

Edited by ten9
Some additional info
Link to post
Share on other sites
On 3/20/2021 at 12:42 PM, ten9 said:

 

 

Edit: I can see in the release notes for the upcoming version 11.10 that the drag & drop issue is fixed. Hopefully the MS DOS import issue with the submaps is also fixed.

https://www.launchbox-app.com/about/changelog

Unfortunately, I do not think it did. Just upgraded to 11.10 beta 6. Have just tried importing DOSBox folders several times and everything looks great. Hit finish, and nothing. 

Link to post
Share on other sites

I found out what is causing the fact that nothing is imported. If you have a set of games, and one of those games has no .EXE or .COM file in the game folder, the entire set will not be imported.

I filed a bug report.

You can woraround this problem by deleting the games from the import in the last step of the dos importer wizard. (by using the DEL- key on the row you want to delete)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...