Jump to content
LaunchBox Community Forums

LB importer not seeing mame 0.229 roms


Recommended Posts

i am having the same issue, trying to import mspactwin.zip  and sf2mkot.zip and 11.9 importer doesn't show them as games...

maybe MAME database haven't YET been updated to reflect 0.229 changes?

Link to post
Share on other sites
3 hours ago, emperorgr said:

i am having the same issue, trying to import mspactwin.zip  and sf2mkot.zip and 11.9 importer doesn't show them as games...

maybe MAME database haven't YET been updated to reflect 0.229 changes?

The mame.xml does not need updating by the devs. LB will update it when you run the importer matched against the version of Mame you are using. 11.9 introduced a change to how the Mame full set importer works.

Copied from Jason's post on the release from when it was in beta:

  • The MAME.xml file contains the majority of the data required for the import, and is automatically generated from MAME every time the full-set importer is run (so it automatically matches the correct version of MAME).

So, if you have .229 Mame and run the importer LB should generate a matching 229 xml for the import.  

Just tested a new import and it found both those games. For sf2mkot.zip you need to uncheck the box for "skip bootlegs".

 

Screen Shot 2021-03-04 at 7.31.07 PM.png

Screen Shot 2021-03-04 at 7.34.29 PM.png

Link to post
Share on other sites

i dont want to run again a full set mame importer, since it will add games i dont want...

i managed to get the ms packman twin imported as "none of the above" even launchbox doesnt found images, etc...

the sf2mkot.zip doesnt' work this way.

i dont understand why we can simply add NEW games after each mame release and we have to RE-import whole set...

Link to post
Share on other sites
27 minutes ago, emperorgr said:

i dont understand why we can simply add NEW games after each mame release and we have to RE-import whole set...

Because thats how MAME works, if new games are added then you need the new romset and the new version of the emulator. Its not good practice to say use the roms from a 0.228 set when they become working games in 0.229, you want the rom from the 0.229 romset, which of course means re-importing the new and correct rom files and switching your emulator entry in Launchbox to use the new emulator as well.

Link to post
Share on other sites

just a simple example...i tried a game i was missing (starforc.zip) and with drag and drop as ROM , the game did imported just fine and found metadata/pictures etc... so with an older game drag & drop worked, however with the two new mame 0.229 roms i tried didnt.

i do understand what you are saying just many "older" roms do work even with 0.229 sets, i dont find the reason to re-import everytime you want just to add 1 game .. for example i have changed the genre types that mame typical uses with my own, so if i re-import....everything is lost.

for now i imported mspacktwin.zip with drag & drop.

sf2mkot.zip is not recognized at all with the drag & drop method.

Link to post
Share on other sites
2 minutes ago, emperorgr said:

i do understand what you are saying just many "older" roms do work even with 0.229 sets,

No, what i am saying is if you want to use newly working games, you need the whole new romset and the new version of the emulator, so with those two things being a must, of course a re-import is needed, you not only now have a new romset, but you also need to setup a new emulator to actually run those new games.

Link to post
Share on other sites

I did a full import with 229 romset and Starforce was not imported...it imported Megaforce though.

I have posted the problem in a thread.

I guess it misses much more.

Link to post
Share on other sites
2 minutes ago, Wally said:

I did a full import with 229 romset and Starforce was not imported...it imported Megaforce though.

I have posted the problem in a thread.

I guess it misses much more.

dear friend, try to import game with drag & drop this way worked for me...

Link to post
Share on other sites
3 minutes ago, Wally said:

I did a full import with 229 romset and Starforce was not imported...it imported Megaforce though.

I have posted the problem in a thread.

I guess it misses much more.

Starforce and megaforce are the same game (megaforce was the US name), are you specifying a region during import?

  • Like 1
Link to post
Share on other sites
18 hours ago, neil9000 said:

No, what i am saying is if you want to use newly working games, you need the whole new romset and the new version of the emulator, so with those two things being a must, of course a re-import is needed, you not only now have a new romset, but you also need to setup a new emulator to actually run those new games.

dear neil,

each time i want to get new games i do use the latest mame.exe in order to have compatibility....

As for new re-import each time a new romset is released, that is not an option for me since i have changed totally to my likings the genre that mame/launchbox is using by default. if i re-import games..i have to change all genre all over again...

 

Link to post
Share on other sites
7 minutes ago, Wally said:

I did a full import with 229 romset and Starforce was not imported...it imported Megaforce though.

I have posted the problem in a thread.

I guess it misses much more.

Did you check additional apps for Mega Force. Starforce is showing up in my import as additional apps to Mega Force.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...