Jump to content
LaunchBox Community Forums

In Retroarch, up and down are reversed and can't be fixed. Video included.


Recommended Posts

Hey guys, any help would be appreciated.

I'm not sure what's happening, but in retroarch while using my arcade cabinet, down is up and up Is down on the joystick. I've changed it numerous times and it still reverts to going the wrong way. I've entered retroarch through the game, through launch box, I've done everything I know to do.

However, I can't get this fixed. I've attached a video going through what exactly I'm talking about even showing the settings.

Here's the video of what I'm talking about.

https://youtu.be/h3zs81ORJT4

I honestly don't know where to go from here. MAME works perfectly.

Link to post
Share on other sites
Posted (edited)

I am going off on a limb, but it sounds like the joystick was installed backwards which is why the axes are reversed. So up is down and right is left and so on. So I believe MAME lets you assign input for each direction, but RetroArch only detects input for the axe and doesn't let you reverse the direction it detects. So you have a number of options, assuming it is what I think it is: (1) reverse the joysticks by physically uninstalling them, turning them 180 degrees from their current orientation and reinstalling them; (2) switch around the leads between up and down and left and right (EDIT: I see you are using zero delay boards, so this method is preferred over method 2); or (3) passing through the inputs to virtually instantiated controllers in x360ce and fixing it all virtually. And as to method 3, see my response elsewhere to you in a different thread about x360ce as you would also need to set up WhiteKnight to hide the physical controllers to eliminate duplicate or ghost inputs from the source physical controllers. On the other hand, if it is not due to a backwards installed joystick, you might also try updating RetroArch since I see you are on a relatively old release, 1.7.7, and it may be an actual bug to blame.

Edited by Hifihedgehog
Link to post
Share on other sites

Thanks for the reply!

I'll try to update retroarch first and then try some of the other solutions.  The weird thing is left and right work perfectly, but it's just up and down that are off.   It's strange!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...