Jump to content
LaunchBox Community Forums

Dolphin and RPCS3 bugs with LB and BB


Recommended Posts

Hello,

 

I noticed a bad bug with Dolphin and RPCS3 using LB and BB.

They don't respond well to what I mapped on my gamepad for exit from a game, they go in windowed and LB and BB don't close the game.

They close well using ESCAPE button on keyboard but not with what I mapped on my gamepad ( I have  a Premium license so I have the option to map Exit on my controller ).

Any tips or fix?

 

Thanks

Link to post
Share on other sites

Not a bug. Likely need to add an AHK to the Running AutoHotKet tab in your emulator setup. Add the AHK below to the RunningAHK tab. 


$Esc::
{
WinClose, ahk_exe {{{StartupEXE}}}
}
 

Link to post
Share on other sites

You have something else going on then. I think I only use that script for maybe 2 or 3 emulators. 
 

Can you post a pic of your set-up? Edit Dolphin and post a pic of the Details tab and the tab where you pasted the script. 

Link to post
Share on other sites

a-sorat.thumb.jpg.f3cee2f6b3392c2e18ce7fb40fe99c6d.jpga-sorat_1.thumb.jpg.770282f9f9c8dc9e0b24d038510a3ba1.jpg

 

I think my configuration is right and I'm sure LB and BB have issues.

Emulators affected by this issue are Dolphin, RPCS3, Yuzu and Citra ( what I tested ).

When I close these emus using ESCAPE on keyboard they close well and when I use my gamepad ( an xbox360 plugged via wireless adaptor ) they don't close but they show their own exit dialogue. 

I feel a bit frustrated by this, hope it will be fixed or at least of getting a solution.

 

Thanks

Link to post
Share on other sites
1 minute ago, nohero said:

they don't close but they show their own exit dialogue. 

You need to turn off "confirm on exit" in the emulators. This is not a Launchbox issue, these emulators close fine for everybody else.

Link to post
Share on other sites
Posted (edited)

It's a LB and BB issue because they close fine using ESCAPE but not with my gamepad ( I purchased a Premium for this feature too ).

It's not a matter of turning off the option "confirm on exit" in the emulators because ( I repeat ) they close using ESCAPE with that option enabled.

Using the button I mapped on my gamepad these emus show their own exit dialogue so it's a LB/BB issue.

 

 

 

Edited by nohero
Link to post
Share on other sites
Just now, nohero said:

It's a LB and BB issue because they close fine using ESCAPE but not with my gamepad ( I purchased a Premium for this feature too ).

As i said these emulators DO close from LB/BB, i have Dolphin myself and it closes just fine with a controller, and has done for the last five years i have used Launchbox. In fact Dolphin doesnt even need the script you are using, any emulator that exits with Escape doesnt need a script.

Link to post
Share on other sites
Posted (edited)

Here it doesn't and I tested on a clean/formatted OS too installing all VC and DX only ( emus and LB/BB are on another drive ).

I'm using v11.11, what version are you using?

 

Tomorrow I will do a video so you can see ( now here it's too late and I'm going to go bed ).

Edited by nohero
Link to post
Share on other sites

@neil9000 is not doubting you have the issue you say that we need to actually see a video of it. He is just stating your issue is not a LB issue as in it is not a bug.

All of my cabinets close all of the emulators fine using my button or key combos. If this was a LB bug/issue more users would be posting about it. Its a setting issue pure and simple. Any chance you run any of those as Admin? 

LB controller automation sends the button combo as an AHK to the emulator telling it to send Escape, if that does not work it then tries some other commands like Alt+F4 before stopping. If you have the emulator set to Admin it will not work.

Link to post
Share on other sites

I run these emus and LB/BB with no Admin rights.

Unticking the option in these emus for confirm on exit works for my gamepad but the question is : why the ESC button works without unticking that option and my gamepad doesn't? If the combo mapped on my gamepad uses an ahk for telling to send ESC why these emus reading that as their on hotkey?

That's why I say it's a LB/BB issue. In my opinion the frontend doesn't communicate well with these emus.

I add  last thing...with ESC they close soon and with gamepad they go first in windowed and then close.

Link to post
Share on other sites

Likely because with the combo there is now a 3rd layer (LB > AHK > Emulator) and AHK is having trouble executing the command with the prompt active. Using just the Escape key you are in the active window pressing a key immediately recognized by the emulator and LB is not actually doing anything. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...