Jump to content
LaunchBox Community Forums

Issues with getting my Marquee monitor to display in big box.


Recommended Posts

Brought a cheep Marque monitor off eBay that fits perfectly on top of my monitor but I cannot getting to display in big box 

I have it set at its highest rez of 1680 x 342 main window displays fine but nothing shows on the top monitor i can see by using alt tab that there are 2 windows running for big box 

but its not showing in the marquee monitor. any help would be great.

  1680 x 3421 

2021-05-24 21.27.27.jpg

Link to comment
Share on other sites

Posted (edited)
On 6/2/2021 at 9:25 AM, Mr. RetroLust said:

Have you setup the marquee monitor in big box settings? If so, also be sure to set the same percentage for both displays in windows font dpi scaling.

I have set up the marquee in big box options will check the dpi main screen running at 1680 x 1080 when  running if i hit alt tab can see there looks like 2 instances of bigbox running so i take one is the marquee screen both on main monitor. will go down the work shop now check dpi they match. How ever getting graphics card error going to look at updating the drivers when the sun goes down as the work shop is like a oven.

Edited by Maniac-Uk
grammatical error
Link to comment
Share on other sites

  • 1 month later...

Did you ever solve this? I have the exact same problem (ALT-Tab shows the marquee screen window running but not showing on my second marquee monitor).

In BigBox I have my primary screen set to Screen 2 (my 1920x1080 main screen) and my marquee screen to Screen 1 (my 1920x360). In the YouTube tutorial I watched the screens were set the other way around- could this be an issue?

Edited by Benjc
Clarity
Link to comment
Share on other sites

It shouldn't be but would be interested if flipping them solves your issue. I've not seen too many users with a cut marquee like that so would be curious your findings so we can make that process as smooth as possible.

Link to comment
Share on other sites

I have used these cut monitors on numerous builds and currently have them in 2 cabinets now. I have not seen where primary is listed as 2 and marquee as 1. They have all been 1 as primary. Only time I had an issue was when DPI scaling was different for each monitor. The marquee was not showing up on one of those builds. I would also double check the Hz on the marquee. Some times the monitors I would get are set to 55Hz and would not show the marquee.

Link to comment
Share on other sites

Well, switching the main screen to 1 and marquee to 2 made no difference whatsoever :( I’ve also checked and both screens are running at 59hz, 100% scaling and have the same horizontal resolution.

This is driving me nuts now. Sorry to say, but even setting up HyperMarquee on Hyperspin was more straightforward than this!

Link to comment
Share on other sites

Actually, it’s gotten even worse… BigBox runs on screen 1 (my primary screen) as expected, then I start a game and that runs on screen 2 (my marquee monitor) in a tiny window. Oh, and the marquee image still cannot be seen anywhere. This is with Primary Screen: Screen 1 and Marquee Screen: Screen 2.

BigBox is pretty much unusable now- help!

Edited by Benjc
Clarity
Link to comment
Share on other sites

Games start where ever the emulator is designed to start from, we don't tell it to launch on a specific window. If the emulator doesn't have a setting that says "Launch on monitor X" it usually set to launch via the primary monitor (as marked in Windows display settings). Also just so I'm clear, is Windows recognizing your marquee as 1920x360 or does it see it as a different resolution?

Link to comment
Share on other sites

15 hours ago, Benjc said:

Well, switching the main screen to 1 and marquee to 2 made no difference whatsoever :( I’ve also checked and both screens are running at 59hz, 100% scaling and have the same horizontal resolution.

This is driving me nuts now. Sorry to say, but even setting up HyperMarquee on Hyperspin was more straightforward than this!

Im not sure if it works but have you tried setting both screens to 60hz?

Link to comment
Share on other sites

1 hour ago, C-Beats said:

Games start where ever the emulator is designed to start from, we don't tell it to launch on a specific window. If the emulator doesn't have a setting that says "Launch on monitor X" it usually set to launch via the primary monitor (as marked in Windows display settings). Also just so I'm clear, is Windows recognizing your marquee as 1920x360 or does it see it as a different resolution?

Thanks- I set this in my mame.ini file and that seems to have sorted the game being on the wrong screen.

Yep, Windows sees the monitors as being 1920x1080 and 1920x360 respectively.

Link to comment
Share on other sites

11 minutes ago, C-Beats said:

Are you using default marquee view @Benjc or a different one? I won't be able to test exactly with that resolution as I have nothing even CLOSE to it, but want to make sure I'm looking at the same file you're trying to use.

I’m not sure where to change default marquee view (or even what it does) so presume I’m using default? Where is that set?

Link to comment
Share on other sites

I have the same-type setup. To get mine to work, on top of the "options" settings to enable the marquee and which monitor it applies to...I also need to use an XML file to tell BigBox how I want my marquees to be viewed. I'll attach the XML code that I currently use in each theme I use. The XML file is called "GameMarqueeView.xaml" and is located in the "Views" folder in each theme.

<UserControl xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
             xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
             xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
             xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
             mc:Ignorable="d"
             d:DesignHeight="562"
             d:DesignWidth="1000"
             HorizontalAlignment="Stretch"
             VerticalAlignment="Stretch"
             FocusVisualStyle="{x:Null}"
             BorderThickness="0"
             Margin="0"
             Padding="0"
             Background="#000">
	<Grid VerticalAlignment="Stretch" HorizontalAlignment="Stretch">
        <Image Source="{Binding Path=ActivatedGame.MarqueeImagePath}" Stretch="Uniform" HorizontalAlignment="Center" VerticalAlignment="Top" RenderOptions.BitmapScalingMode="HighQuality" />
    </Grid>
</UserControl>

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...