Jump to content
LaunchBox Community Forums

Launchbox won't launch after update/reinstall


Recommended Posts

I've had a look through this forum and have found similar things to what I'm experiencing, but not exactly, hence the new topic.

I started Launchbox earlier on today and it asked me if I wanted to update to a new version, so as I usually do, I let it do its stuff and downloaded 11.14. So far so good. However when I went to re-launch the program, nothing happened. Icon still in the start menu but nothing happening. Desktop shortcuts not working. Program not appearing in Task Manager. Just totally dead. Have tried uninstalling and reinstalling, but still nothing.

Just wondering if anyone can shed any light on this? :)

  • Like 1
Link to comment
Share on other sites

I just ran into the same issues today as well. 11.14 was working the past few days for me. Big Box will launch but not the Desktop app. I am not sure Windows pushed a new security update that is breaking it. 

Link to comment
Share on other sites

i find a solution for my problem:

- Microsoft antivirus find that Win32/Zpevdo.B was a threat and quaratined it.

- in the folder Launchbox\Core\LaunchBox.dll was affected

I reverse the action of the antivirus and it's working.

 

Hope it can help

Edited by sanichi
Link to comment
Share on other sites

Yup it was the Windows Defender blocking it. Go to protection history, it will say there is a severe threat. It will show it coming from your Launch Box folder. Actions --> Restore. Now it should be unquarantined. 

  • Like 1
Link to comment
Share on other sites

Too many software projects have had malware inserted into them lately without the author's knowledge.

I'm not whitelisting this until LaunchBox makes an official statement - and I hope that statement includes a review of any recent commits or changes in build tools.

Link to comment
Share on other sites

6 minutes ago, zetec said:

Too many software projects have had malware inserted into them lately without the author's knowledge.

I'm not whitelisting this until LaunchBox makes an official statement - and I hope that statement includes a review of any recent commits or changes in build tools.

Yeah. I got Launchbox working but only after I allowed the "trojan". I've gone back in and removed all instances of it via the protection history and Launchbox is back to not responding now so hoping it's gone. Just running a full scan to make sure but I don't think I'll be firing up the app until there's confirmation it's not a threat.

Link to comment
Share on other sites

I just tried to ask about this in the Launchbox Discord and was met with rude dismissal of my concerns.

"Don't worry about it" is absolutely not okay as a response to being flagged by four vendors, and if this is how the Launchbox team approaches security, not only will I no longer use it, but I have to recommend that nobody else does as well.

Link to comment
Share on other sites

Same. BB runs but not LB. I just checked the windows antivirus and saw it had flagged and removed some LB .dll files.

So... what to do? Why were these all of a sudden flagged? 

EDIT: I ended up rolling back to 11.13 for now. Then LB works. I did a scan again of the LB folder afterwards, and the 11.14 installer was flagged. Everything else was fine.

Edited by OdinsPlayground
Link to comment
Share on other sites

I have notified @Jason Carr and @faeran on our discord to have a look into this.

1 hour ago, zetec said:

I just tried to ask about this in the Launchbox Discord and was met with rude dismissal of my concerns.

"Don't worry about it" is absolutely not okay as a response to being flagged by four vendors, and if this is how the Launchbox team approaches security, not only will I no longer use it, but I have to recommend that nobody else does as well.

I Just had a look on the discord and I don't see a single thing from you or anything related to this issue.

Link to comment
Share on other sites

I posted in the troubleshooting channel. A user named "Mad" something-or-other was extremely dismissive, so I left - so I don't have any screenshots of that exchange. After I left the server, another user named Maria messaged me to say that user wasn't affiliated with the LB team.

 

I don't appreciate the insinuation that I've made a false report - but this is sadly consistent with my LB experience today. This whole experience has turned me off from LB all together.

Link to comment
Share on other sites

Hi all, sorry for the trouble. I've responded in another thread, but I will respond the same thing here as well:

We can confirm that the reports are indeed false positives, but that's all we can say. Every single release we put out, we end up fighting with a million and one broken anti-virus programs to do our best to eliminate any false positives. But every release that task becomes more daunting and more difficult.

It's very rare that Windows Defender reports a false positive like this, but Microsoft apparently updated the definitions today and it is now being reported as a false positive. Obviously we couldn't catch that because when we released 11.14 it wasn't being reported as a false positive. I'm going to look to attempt to put out a new release that does not throw a false positive, but it may or may not be possible, depending.

The unfortunate truth is that most anti-virus programs are absolute garbage and report more false positives than true viruses, so they're much like the boy who cried wolf. They become useless because they cannot be trusted when a virus is reported. Windows Defender has a much better track record than most third-party anti-virus programs, but it's not perfect. When you're searching new developments for a series of bits and bytes from well over 30 years of viruses, it's nearly an impossible task to do without getting it wrong.

Regardless, you're getting a very false sense of "security" if you're trusting an anti-virus program (especially a third-party anti-virus program) to tell you whether or not you have any bad or malicious software on your machine. That's the sad truth these days.

We'll do our best to fix the issue. If you can, please report this to your anti-virus providers as a false positive.

  • Thanks 1
Link to comment
Share on other sites

Alright, 11.15 is out now. Apparently all we needed to do was recompile and it seems that it no longer trips Microsoft Defender. Just bad luck with that false positive I guess (but what else is new).

If you're unable to auto-update to 11.15, you can manually download it here:

https://www.dropbox.com/s/wsflw0p0iu8g3o4/LaunchBox-11.15-Setup.exe?dl=0

Once downloaded, you can just manually install it over top of your existing LaunchBox folder, and it will keep all your games and settings. Just be sure to install it to the LaunchBox folder, like this:

image.thumb.png.4620cc9b925c296c57af1fa6de311801.png

And not a LaunchBox folder inside of the LaunchBox folder like this:

image.thumb.png.8d7732092ac5fe4b6c3ef4e8628825d1.png

Thanks all; my apologies for the trouble. Sometimes we're blindsided with false positives like this and unfortunately there's really nothing we can do to improve it. It's just the nature of software development on Windows these days.

Oh, one last note: as with many of the previous releases, we are still tripping a false positive with Symantec/Norton. This has been unavoidable for us unfortunately. Symantec/Norton seems to be the worst of the anti-virus industry, spitting out more false positives than most other providers.

  • Thanks 2
Link to comment
Share on other sites

Also, one last thing: we are committed to making sure that new official versions of the software do not trip Microsoft Defender (Windows' built-in anti-virus), because we feel like it's the best solution out there, as it generally doesn't act like the boy who cried wolf, reporting millions of false positives, and for the most part it just works. However, sadly, it would be impossible for us to commit to eliminating false positives with every third-party anti-virus product out there.

This is just our 2 cents: if you are using a third-party anti-virus product, we recommend uninstalling it and using Microsoft Defender instead. Here's why: Microsoft has a vested interest in doing the anti-virus job properly, without interfering with performance or producing false positives, because they want users on Windows to have the best experience possible. Anything less than the best experience makes Windows look bad, so it's obvious why Microsoft cares in this regard.

Unfortunately the vast majority of third-party anti-virus companies do not maintain the same level of care. Some important notes:

  • Many of the anti-virus companies take the stance that the more "viruses" they report, the "safer" users will think that their product is; they don't care if they report false positives or not, because they think users are stupid and it doesn't matter. They're not held accountable for false positives in any way, shape, or form, so they don't invest very much in getting rid of them.
  • Many third-party anti-virus companies have a relatively scandalous history, including famous ones like Symantec/Norton, and McAfee; in the worst cases they have introduced viruses themselves that only their own software can fix, just so that they can look better than the competition.
  • Third party anti-virus companies do not have much incentive to increase performance, because as they're often installed before a user even gets their computer, users will usually just blame the hardware or Windows itself.
Link to comment
Share on other sites

5 hours ago, sanichi said:

I have exactly the same problem since 1 hour before, but when i launched Launchbox, Microsoft antivirus find a problem.

Was it the Mircosoft Defener telling you to turn on the Device Control? That happened to me and I am stuck in the same condition

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...