Jump to content
LaunchBox Community Forums

Launchbox won't launch after update/reinstall


Recommended Posts

43 minutes ago, Jason Carr said:

Also, one last thing: we are committed to making sure that new official versions of the software do not trip Microsoft Defender (Windows' built-in anti-virus), because we feel like it's the best solution out there, as it generally doesn't act like the boy who cried wolf, reporting millions of false positives, and for the most part it just works. However, sadly, it would be impossible for us to commit to eliminating false positives with every third-party anti-virus product out there.

Totally agree you can't make sure you don't trip a single third-party software, as there are so many chance of false positives that could happen there. As long as Microsoft Defender doesn't throw a fit, should be all good. 

  • Like 1
Link to comment
Share on other sites

4 minutes ago, srmercenary said:

Was it the Mircosoft Defener telling you to turn on the Device Control? That happened to me and I am stuck in the same condition

Please see the post above to install 11.15 (manually, if needed). That should solve the issue for you.

Link to comment
Share on other sites

3 hours ago, zetec said:

I don't appreciate the insinuation that I've made a false report - but this is sadly consistent with my LB experience today. This whole experience has turned me off from LB all together.

Because you did make a false report. That wasn't LaunchBox as you insinuated it was. You immediately became outraged without even confirming who you were talking to. I get it, I too was upset at virus notification but that doesn't excuse spreading disinformation or bad mouthing a company/software for something that turned out to be outside it's control.

5 hours after this thread was started they have fixed the issue by releasing a new build. That is unheard of in software. Jason's updates in this thread were well spoken and transparent as to how the issue happened in the first place. If you don't consider direct forum support, transparent updates, and a direct patch in a matter of hours a "good experience" then good luck on your journey to find something better.

  • Like 2
Link to comment
Share on other sites

12 minutes ago, Jason Carr said:

Thank you for the positive feedback guys. It does really help after having a stressful Saturday like this. :)

I'm very glad we got it resolved.

11.15 installed, everything is working perfectly fine! Thank you for the quick release.

  • Like 2
Link to comment
Share on other sites

franchement bravo pour la réactivité au moment ou je chercher des avis sur le forum j'ai vu juste après le correctif (la mise a jour) en plus d'être un outil génial l'équipe derrière est passionné en tout cas moi je le sens comme ça, vous êtes toujours très réactif sur le forum en sachant que vous travaillez aussi sur le logiciel (pour une petite équipe c'est pas très courant ) bref ça fait plaisir de partager une passion a travers ce programme fantastique 

frankly bravo for the responsiveness when I look for opinions on the forum I saw just after the patch (the update) in addition to being a great tool the team behind is passionate in any case I feel it like that, you are always very responsive on the forum knowing that you also work on the software (for a small team it's not very common) in short it's nice to share a passion through this fantastic program

  • Like 2
Link to comment
Share on other sites

20 hours ago, Jason Carr said:

Alright, 11.15 is out now. Apparently all we needed to do was recompile and it seems that it no longer trips Microsoft Defender. Just bad luck with that false positive I guess (but what else is new).

If you're unable to auto-update to 11.15, you can manually download it here:

https://www.dropbox.com/s/wsflw0p0iu8g3o4/LaunchBox-11.15-Setup.exe?dl=0

Once downloaded, you can just manually install it over top of your existing LaunchBox folder, and it will keep all your games and settings. Just be sure to install it to the LaunchBox folder, like this:

image.thumb.png.4620cc9b925c296c57af1fa6de311801.png

And not a LaunchBox folder inside of the LaunchBox folder like this:

image.thumb.png.8d7732092ac5fe4b6c3ef4e8628825d1.png

Thanks all; my apologies for the trouble. Sometimes we're blindsided with false positives like this and unfortunately there's really nothing we can do to improve it. It's just the nature of software development on Windows these days.

Oh, one last note: as with many of the previous releases, we are still tripping a false positive with Symantec/Norton. This has been unavoidable for us unfortunately. Symantec/Norton seems to be the worst of the anti-virus industry, spitting out more false positives than most other providers.

Appreciate this. All working now it appears :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...