Jump to content
LaunchBox Community Forums

LaunchBox for Android New Version - Beta Testing


Jason Carr

Recommended Posts

On 9/3/2021 at 11:10 AM, Mark Pollack said:

Hi,

I'm running 0.40 on a fire stick lite and so far so good.  Thanks so much for adding the search in 0.40!

The one minor issue I have, since 0.3x, is that the image on the main tile to launch the application is empty - some default black box.  I guess firetv is a bit particular in how that stuff gets packaged up.

Thanks!

Mark

Thanks for the note about the icon. Not sure what could be causing that, but it's on the list now.

On 9/3/2021 at 8:50 PM, xman said:

Just a suggestion.  Do you think it would be possible to program the left trigger for previous letter and right trigger for next letter in the platform games list since it doesn't seem to be used while in the platform, using an Xbox360 controller?

Yes, that should be possible. However, the right stick can already be used to move much more quickly through the collection.

Link to comment
Share on other sites

@Vader I'll look into that issue. To be honest, the Shield is a relatively low-powered device, so we might not be able to get the scrolling to be completely smooth. It might be also that it would help to download any missing media so that it doesn't have to happen in the background. Have you tried running that process to see if it helps with scrolling performance?

Link to comment
Share on other sites

2 hours ago, Jason Carr said:

@Vader I'll look into that issue. To be honest, the Shield is a relatively low-powered device, so we might not be able to get the scrolling to be completely smooth. It might be also that it would help to download any missing media so that it doesn't have to happen in the background. Have you tried running that process to see if it helps with scrolling performance?

@Jason Carr thanks for your help. 

To clarify, i am not using an nvidia shield, i am using a galaxy tab s7 plus tablet. Also I think I have download all media that is available. 

 

Link to comment
Share on other sites

21 hours ago, Vader said:

@Jason Carr thanks for your help. 

To clarify, i am not using an nvidia shield, i am using a galaxy tab s7 plus tablet. Also I think I have download all media that is available.

Okay, that is certainly interesting. I'm not seeing those issues on devices with similar or lesser performance, so something looks like it's awry. Will look into it.

Link to comment
Share on other sites

@Jason Carr again thanks

An experiment that I want to try but havent had a chance yet is to try and run launchbox from my tablets built in storage instead of my sd card.  Right now launchbox is running from my SD card, and this is where i have my roms and image files. My sd card is cheap, and I think it can't handle the read / write processes that launchbox requires, thus causing the scrolling problem. My opinion, of course.

  • Like 1
Link to comment
Share on other sites

On 9/3/2021 at 11:10 AM, Mark Pollack said:

The one minor issue I have, since 0.3x, is that the image on the main tile to launch the application is empty - some default black box.  I guess firetv is a bit particular in how that stuff gets packaged up.

Just looked into this. Apparently it's a bug with Fire TV. I found this article here:

https://www.aftvnews.com/how-to-fix-missing-or-broken-icons-for-sideloaded-apps-on-amazon-fire-tv/

I was tempted to move the icons around, but that doesn't appear to be the recommended way to do it, so rather than try that and risk messing up other devices, I think we'll just leave it until Amazon can fix that bug. I also don't currently have a Fire TV device to test with, so that would probably not be the greatest idea.

Link to comment
Share on other sites

7 minutes ago, Vader said:

@Jason Carr again thanks

An experiment that I want to try but havent had a chance yet is to try and run launchbox from my tablets built in storage instead of my sd card.  Right now launchbox is running from my SD card, and this is where i have my roms and image files. My sd card is cheap, and I think it can't handle the read / write processes that launchbox requires, thus causing the scrolling problem. My opinion, of course.

Gotcha, that would make good sense.

Link to comment
Share on other sites

Hey all, version 0.41 is out now with the following:

  • Fixed an issue where the Android platform was not saving changes to the view

  • Fixed an issue where the emulator settings pages were not always loading up the correct value for the Extract ROM Archives setting

  • Like 1
Link to comment
Share on other sites

Is there a way to see if Launchbox is still processing files?   My screen locked and I have mame importing.. a lot of files.  Needless to say I don't trust android OS all that much so it leaves me wondering if the spinning circle is actually processing or the process died/killed by the OS or whatnot and it's not importing anymore..  Will it stop if the focus goes to another app?

Link to comment
Share on other sites

1 minute ago, adam1972 said:

Is there a way to see if Launchbox is still processing files?   My screen locked and I have mame importing.. a lot of files.  Needless to say I don't trust android OS all that much so it leaves me wondering if the spinning circle is actually processing or the process died/killed by the OS or whatnot and it's not importing anymore..  Will it stop if the focus goes to another app?

The MAME import process shouldn't really take much longer than a few minutes, so it's probably worth restarting. What device are you using?

Link to comment
Share on other sites

8 minutes ago, Jason Carr said:

The MAME import process shouldn't really take much longer than a few minutes, so it's probably worth restarting. What device are you using?

I sir, am using a OnePlus 7 Pro and the files are on an external 256GB samsung thumbrdrive.  Importing 1689 files.  It's been over an hour.

image.thumb.png.65f12dce0becd29052a4db44690101e5.png

Edited by adam1972
Link to comment
Share on other sites

Allrighty.. I backed out using the left arrow on the launchbox  GUI.  It took me back out to the mame import options.  I clicked the arrow to proceed.. MUCH different result.  THIS TIME within 5 seconds it showed me the list of zip files and after I approved the import it proceeded to FLY through them.  All in all it took about 15 seconds! :) 

  • Like 1
Link to comment
Share on other sites

Hey @Jason Carr

I was able to move my launchbox files from my sd card to internal storage and found that the scrolling issues are gone. It is defenitly an issue with read/write on the SD card. For now i'll leave it as is, but eventually, I'll see if i can get a better SD card to see if that clears up the issue. 

Thanks

  • Like 1
Link to comment
Share on other sites

On 9/6/2021 at 7:31 PM, Jason Carr said:

@Vader I'll look into that issue. To be honest, the Shield is a relatively low-powered device, so we might not be able to get the scrolling to be completely smooth. It might be also that it would help to download any missing media so that it doesn't have to happen in the background. Have you tried running that process to see if it helps with scrolling performance?

@Jason Carr Just to say, have used Hyperspin in the past on my Nvidia Shield, scrolling etc was smooth and fast, Hopefully Launchbox can be the same if not better. 

Link to comment
Share on other sites

1 hour ago, davemk said:

@Jason Carr Just to say, have used Hyperspin in the past on my Nvidia Shield, scrolling etc was smooth and fast, Hopefully Launchbox can be the same if not better. 

Are you seeing issues with scrolling performance? I ask because I don't see any post from you about it, unless I missed it. I'm also not experiencing any issues myself on the Nvidia Shield TV. From what I can tell, the issues are pretty much exclusively coming from slow storage devices.

Link to comment
Share on other sites

12 hours ago, do0r said:

Is there anyway to hide the notification and navigation while we're in the app? Kinda kills it for me.

I have this option on my list to add. Android doesn't make it as easy as it should be though, so it will probably be a while.

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

22 hours ago, Jason Carr said:

Are you seeing issues with scrolling performance? I ask because I don't see any post from you about it, unless I missed it. I'm also not experiencing any issues myself on the Nvidia Shield TV. From what I can tell, the issues are pretty much exclusively coming from slow storage devices.

No sorry, perhaps I did not make my post clear, I was just replying to the quote from above when it was mentioned about the "Shield being a relatively low powered device" and just as a comparison Hyperspin from previous use was smooth as such whilst scrolling through games etc.

Sorry for any confusion.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...