Jump to content
LaunchBox Community Forums

11.16 Beta Testing


faeran
 Share

Recommended Posts

11.16 Beta 1 is now out with the following changes:

  • Improvement: Updated how LaunchBox and Big Box load XML files on startup, should result in faster load times
  • Fixed: Some Platform image path bindings were failing in StartupThemes
  • Fixed: Added logic to help with EmuMovies session refresh with large image queues

 

We recommend backing up your Data folder before updating to this beta.

 

Please report any oddities you see in this thread that you feel may be related to the above changes.

Thank you for your help beta testing.

  • Like 6
Link to comment
Share on other sites

@faeran @Jason Carr Unfortunately, I tried to install this update a few different times and different ways, and I'm getting a major error that I can't get past after the installation finishes. When I revert back to 11.15, there's no issues

11.16beta_error.thumb.jpg.b04bd86d91eba6d993d0b5c3e7a1b4dd.jpg

Update: I figure that this must have something to do with my data or the plugins I'm using, because when I do a fresh install (with no data, games, images, etc.) there's no issues. Sticking with 11.15 until the next beta is released

Edited by bundangdon
Link to comment
Share on other sites

Updated and the first run was fast and no issues, but i also encountered an error after closing and reloading LB

image.thumb.png.80216ec2191883553238b935ae3c2159.png
 

After i closed the error down, and reloaded it worked without an issue.

Think i narrowed the error down for me, it seems to fail when doing the still running check, if you close and reopen to quickly, normally you get the requester pop up, but never gets that far. Also on the second time i had the Error window come up but it didn't populate with any information.

Also loving the speedier loading into LB, much improved for me at least, sometimes could take 30 secs, now its  like 5-10 seconds at most.

 

Heres the full error code

image.thumb.png.b8ecd9208a38ec39432e2aa2ffebf36e.png

Edited by MadK9
Link to comment
Share on other sites

13 hours ago, faeran said:

Fixed: Some Platform image path bindings were failing in StartupThemes

Also thanks for this change, means i can get rid of some ugly code in my Startup Theme.

  • Haha 1
Link to comment
Share on other sites

Hi, I'm getting the below and big box will not stay open. Appreciate any help. Is it possible to downgrade?

 

Object reference not set to an instance of an object.

App:     Big Box
Version: 11.16-beta-1
Type:    System.NullReferenceException
Site:    Boolean ManageAnnotation(System.Object, System.Object, System.StringComparison)
Source:  BigBox

   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.<>c__DisplayClass31_0.ManageAnnotation(Object , Object , StringComparison )
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.<>c__DisplayClass31_0.ValidateError(EmulatorPlatform emulatorPlatform)
   at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Func`2 predicate, Boolean& found)
   at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.<>c__DisplayClass31_0.CallError(Emulatjor emulator)
   at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Func`2 predicate, Boolean& found)
   at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.EnableResolver(Object task, IEnumerable`1 connection)
   at ConfigurationRole.CalculateTests(IPlatform task, IEnumerable`1 connection, ConfigurationRole )
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel..ctor(Platform platform, IEnumerable`1 games)
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.PlatformFiltersViewModelBase.LoadDetails(Guid instance)
   at VisitorRole.CalculateTests(Object , Guid value, VisitorRole )
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FiltersViewModelBase.<>c__DisplayClass208_0.ForgotError()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
--- End of stack trace from previous location where exception was thrown ---
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

Recent Log:

   08:37:29 Exception

 

Thanks

Link to comment
Share on other sites

Not 100% sure yet if my issue with loading up of Clear Logos has been resolved in this release, but I do notice this happened with the newest Beta that wasn't like this in the previous release:

image.thumb.png.a9890611f83c143cc237caee862383f6.png

Link to comment
Share on other sites

I deleted a platform and wanted to reimport the games. When I click next on the final dialog (beofre it scans the dir) I get an exception:

Object reference not set to an instance of an object.

App:     LaunchBox
Version: 11.16-beta-1
Type:    System.NullReferenceException
Site:    Boolean ResetGenericCreator(System.Object, System.Object, System.StringComparison)
Source:  Unbroken.LaunchBox.Windows

   at Unbroken.LaunchBox.Windows.Data.DataManager.ResetGenericCreator(Object , Object , StringComparison )
   at Unbroken.LaunchBox.Windows.Data.DataManager.ContainsGameApplicationPath(String gameApplicationPath)
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.RomImportGameListViewModel.FillDrivenMerchant(Object , Object )
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.RomImportGameListViewModel.OnActivated()
   at RoleInterpreter.CreateInvalidRules(Object , RoleInterpreter )
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.WizardViewModel.ListScopeContainer()
   at ManagerInterpreter.CreateInvalidRules(Object , ManagerInterpreter )
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.WizardViewModel.NextPage()
   at RoleInterpreter.CreateInvalidRules(Object , RoleInterpreter )
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.RomImportMameOptionsViewModel.OnActivated()
   at RoleInterpreter.CreateInvalidRules(Object , RoleInterpreter )
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.WizardViewModel.ListScopeContainer()
   at ManagerInterpreter.CreateInvalidRules(Object , ManagerInterpreter )
   at Unbroken.LaunchBox.Windows.Desktop.ViewModels.WizardViewModel.NextPage()

 

Link to comment
Share on other sites

2 hours ago, 4monty said:

Hi, I'm getting the below and big box will not stay open. Appreciate any help. Is it possible to downgrade?

 

Object reference not set to an instance of an object.

App:     Big Box
Version: 11.16-beta-1
Type:    System.NullReferenceException
Site:    Boolean ManageAnnotation(System.Object, System.Object, System.StringComparison)
Source:  BigBox

   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.<>c__DisplayClass31_0.ManageAnnotation(Object , Object , StringComparison )
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.<>c__DisplayClass31_0.ValidateError(EmulatorPlatform emulatorPlatform)
   at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Func`2 predicate, Boolean& found)
   at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.<>c__DisplayClass31_0.CallError(Emulatjor emulator)
   at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Func`2 predicate, Boolean& found)
   at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel.EnableResolver(Object task, IEnumerable`1 connection)
   at ConfigurationRole.CalculateTests(IPlatform task, IEnumerable`1 connection, ConfigurationRole )
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FilterDetailsViewModel..ctor(Platform platform, IEnumerable`1 games)
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.PlatformFiltersViewModelBase.LoadDetails(Guid instance)
   at VisitorRole.CalculateTests(Object , Guid value, VisitorRole )
   at Unbroken.LaunchBox.Windows.BigBox.ViewModels.FiltersViewModelBase.<>c__DisplayClass208_0.ForgotError()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
--- End of stack trace from previous location where exception was thrown ---
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

Recent Log:

   08:37:29 Exception

 

Thanks

What you can do is look in your "Updates" folder (within LaunchBox) and should be able to find the previous installation files there, that is if you want to go back to an earlier version

Edited by bundangdon
Link to comment
Share on other sites

2 hours ago, bundangdon said:

What you can do is look in your "Updates" folder (within LaunchBox) and should be able to find the previous installation files there, that is if you want to go back to an earlier version

Thanks for your reply. Unfortunately I'm stuck in a loop doing that. It downgrades and opens 11.15 OK, I chose not to update to beta. When I open Big Box it re-installs the beta by itself. I've tried deselcting the beta option but same thing. Appreciate any further help.

Cheers, love the system!

Link to comment
Share on other sites

2 minutes ago, 4monty said:

Thanks for your reply. Unfortunately I'm stuck in a loop doing that. It downgrades and opens 11.15 OK, I chose not to update to beta. When I open Big Box it re-installs the beta by itself. I've tried deselcting the beta option but same thing. Appreciate any further help.

Cheers, love the system!

Delete the 11.16 beta from the updates folder. Its updating currently because you already have it downloaded and its a newer version, just remove it and it cant install.

Link to comment
Share on other sites

same error here only on certain platforms oddly …
"Object reference not set to an instance of an object"

The issue is even worse when I use symbolic links to the rom-path. I get very nervous when file handling access gets changed. I worry it will permanently prevent symbolic link access to a remote path and wont be fixed - making my remote game path broken. went back to 11.15 and all is working again correctly.

  •  
  • Members
  •  0
  • 2 posts
  •  
 
Link to comment
Share on other sites

1 hour ago, 4monty said:

Thanks for your reply. Unfortunately I'm stuck in a loop doing that. It downgrades and opens 11.15 OK, I chose not to update to beta. When I open Big Box it re-installs the beta by itself. I've tried deselcting the beta option but same thing. Appreciate any further help.

Cheers, love the system!

Then you need to delete that 11.16 beta 1 from your "updates" folder and then turn off "Automatically Download Updates" in the background in LaunchBox options.

Link to comment
Share on other sites

2 hours ago, Inquisitor said:

Delete the 11.16 beta from the updates folder. Its updating currently because you already have it downloaded and its a newer version, just remove it and it cant install.

 

45 minutes ago, bundangdon said:

Then you need to delete that 11.16 beta 1 from your "updates" folder and then turn off "Automatically Download Updates" in the background in LaunchBox options.

@4monty The beta does not need to be deleted. Just need to make sure to uncheck the box for "Automatically Download Updates in Background". No matter how many installers you have in your updates folder you can revert to any version and use it without LB trying to update to a more current one in your folder if you have that unchecked.

Link to comment
Share on other sites

2 minutes ago, Retro808 said:

The beta does not need to be deleted

It does if you dont want to be on it, it's newer than the stable 11.15, so Launchbox will try to update to it after rolling back to 11.15. It can't update to it if it's not there.

Link to comment
Share on other sites

8 minutes ago, Inquisitor said:

It does if you dont want to be on it, it's newer than the stable 11.15, so Launchbox will try to update to it after rolling back to 11.15. It can't update to it if it's not there.

That's incorrect. I test constantly for LB going back and forth between betas and prior versions. I never delete any installer even if newer than the one I am running and LB never tries to reinstall it until I make it do so. Been that way for years I have been using LB and testing betas.

If you have Check for Updates on it will ask you if you want to install, but it does not automatically do it. The Background option will. Which is why that has to be off.

Link to comment
Share on other sites

32 minutes ago, OhBoy said:

I'm also getting this error with certain platforms only (PS3, Jaguar CD):

"Object reference not set to an instance of an object"

Try resetting the emulator .exe path. I got that error with Citra and to be honest I do not remember exactly what I did, but I remember reselecting the path was one of the last things I did and the error went away. Again, not saying that was the fix, but worth a try.

Edited:

Just got the error with PS3. Changed the exe path to a completely different emulator and saved it and exited the Manage Emulators screen. Then went back in a edited it back to the correct exe path and no error. If that did not work try closing LB after you make the first change. Then reopen LB and edit it back to the correct .exe path.

  • Unusual Gem 1
Link to comment
Share on other sites

49 minutes ago, Retro808 said:

Try resetting the emulator .exe path. I got that error with Citra and to be honest I do not remember exactly what I did, but I remember reselecting the path was one of the last things I did and the error went away. Again, not saying that was the fix, but worth a try.

Edited:

Just got the error with PS3. Changed the exe path to a completely different emulator and saved it and exited the Manage Emulators screen. Then went back in a edited it back to the correct exe path and no error. If that did not work try closing LB after you make the first change. Then reopen LB and edit it back to the correct .exe path.

That worked! You are so awesome, thank you. ?

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...