Jump to content
LaunchBox Community Forums

STELLA RETROARCH GAMES ARE SLOW


SLUGIE79
 Share

Recommended Posts

36 minutes ago, SLUGIE79 said:

Hi there 

I have added stella core not stella 2014 core it looks and works great but its really slow  when i play any game how do i solve this please 

Also does anyone know which folder to add custom box art, cart and snaps from hyperspin 

thank you

Check that your windows isnt set to run at 30hz, Atari 2600 is easy to run so you shouldnt have any issues at all with it, so it's likely it's not a actual emulator issue. As for images the paths are very simple, Launchbox/Images/Name of system/name of image type. Images must be named the same as they are in the Launchbox UI, or the same as the actual rom file.

Link to comment
Share on other sites

Hi There 

I have hyperspin on nivia sheild and i have used emulators quite a few time before and have never had any problems with atari 2600 I can also emulate games up to GameCube as you say it should be easy 

whereabouts on windows till I find out what hz its runng at?

also it windows 10 thankyou 

Link to comment
Share on other sites

Right click your desktop and choose Display Settings and check there. You can also open Nvidia control panel. 

This is most likely a Retroarch setting issue. Launch a game and go into Retroarch settings and check what your video settings are for that core. 

Link to comment
Share on other sites

Hi there I change the resolution in retro arch and it’s worked!

I have either 16 x 9 or full screen but I’m nes and atari 2600

there is a black frame around my games while I play is there any way of getting rid of this please I know that a lot of people don’t like the games stretched or anything but I want my whole screen filled

it’s just how I like the look of it

thanks in advance

everyone is really helpful on here and I’m so glad I paid the extra to emumovies and lunchbox lifetime member on both

Link to comment
Share on other sites

hi inquisitor

thank you for that i’ve done all that and it works fine but now there’s tearing on my games super marion nes when i run the pipes are tearing badly

I have a 4K TV Sony i’ve got g sync on and it doesn’t make much difference to be honest

The resolution is 3840x2160 at 30 hz

I have tried 1920 x 1080 at 60 hz But the image looks horrible it gets rid of the tearing though

only thing I haven’t tried is changing my PC resolution to match the TV for 1920 x 1080

I would like it in 3840 x 2160 at 30hz though so it looks sharp on the pixels

is there anything else I can do to stop tearing please

Images attached of settings

thank you in advance 

045E70E0-BA17-47B4-8A0F-354DE8BA0067.jpeg

72F9B305-323E-4659-A571-399D16916B01.jpeg

B0151708-EBF3-4FE9-894D-B265FE259A7B.jpeg

9C64F00B-909C-4E26-81D7-C03A99DECB66.jpeg

FA34DE30-BFAA-4BEA-99F1-E225952145F2.jpeg

Link to comment
Share on other sites

7 minutes ago, SLUGIE79 said:

The resolution is 3840x2160 at 30 hz

Yeah, dont do that, those systems all the games run at 60hz, that is why they tear at 30hz. If your TV is not capable of 4K60hz, then you will have to use 1080p60hz, unless the TV can handle 1440p60hz. Long story short never have it set to 30hz.

Link to comment
Share on other sites

9 hours ago, Inquisitor said:

The 30hz thing is why your games were slow to start with, it should never be used for these old consoles as they all ran at 60hz, dropping to 30hz will make them basically unplayable.

Hi Inquisitor 

my TV can handle it at 60 hz 

there is no option on retroarch just 30hz and 28 and 23

is there something I need to download to make it go to 60hz?

Thanks for your help it’s really helpful

Link to comment
Share on other sites

1 hour ago, SLUGIE79 said:

so if my cable doesn’t handle 4k does this mean that the option for 60 Hz won’t be available on retro arch?

You could buy a new cable that can handle the 4K 60hz bandwidth if your current one doesn't support it.

As for your screen tearing issues i'm not sure what to tell you, if you have your games running at the correct speed and your display supports G-Sync then it should just work if setup correctly.

Link to comment
Share on other sites

Yeah your 7 year old cable is likely the issue. Retroarch will be set to whatever hz you have set in Windows by default, so if it's only 30hz in Retroarch its also only 30hz in Windows most likely (unless you have something weirder going on). Sounds to me like your HDMI cable is a old 1.4 version or previous, you need a 2.0 certified HDMI port and cable or higher to get 4K and 60hz simultaneously. 

Link to comment
Share on other sites

4 hours ago, SLUGIE79 said:

could be i guess the cable is a belkin one and i have had it for roughly 7 years 

so if my cable doesn’t handle 4k does this mean that the option for 60 Hz won’t be available on retro arch?

what do you need to download the option in an update

No, you need a new cable, cheap as chips on Amazon.

Link to comment
Share on other sites

A few things here.

Point #1: In my experience, HDMI 2.0 works fine on lesser rated cables unless you are connecting over very long runs and it may be a problem, but even then, it shouldn't. Why? Most all HDMI 1.4 cables are already mechanically and compositionally the same as their HDMI 2.0 counterparts other than the certification testing they formally paid for. Does a cable suddenly change just because its manufacturer up and decided to pay $1000 for formalized certification? Of course, not! That means your cable should "just work" just the same an "official" HDMI 2.0 one would. Not convinced? Read the CNET article "4K HDMI cables (are nonsense)" by Geoffrey Morrison, an expert in the AV field. Don't fall for the snake oil lies that cable manufacturers spread, which is all a bunch of bunk to try to make you spend more money than you need to. That brings me to my next point.

 

Point #2: Given point #1, we should still see a 60Hz option because the monitor and video card cannot actually detect if the cable is HDMI 2.0, 1.4, etc. The reason then the OP may not be seeing 4K at 60Hz as an available option may come down to something else in the signal chain. And if not the TV, the input device, which the OP claims supports 4K at 60Hz, then, by process of elimination, the computer, the output device. That brings me to my last point.

 

Point #3: Before us going any further, have we confirmed that the OP's output device/graphics card actually supports 4K at 60Hz, namely that his or her computer's HDMI port is 2.0? They stated their TV supports 4K at 60Hz, meaning the TV has an HDMI 2.0 input. But the computer may not have an HDMI 2.0 output. Both the input (TV/monitor/projector) and output (computer/game console/smartphone/tablet) devices must support HDMI 2.0 for 4K at 60Hz to work.

 

So... Out of curiosity, what graphics card are you using here? For example, your graphics card may support 4K at 60Hz but only on its DisplayPort (DP) output, not on its HDMI port.

Edited by Hifihedgehog
Link to comment
Share on other sites

Thanks. Can you run Device Manager by right clicking on the Windows' Start Menu icon? Then expand Display Adapters by hitting the plus sign. I would like to see what is in the red section there (see example). I am guessing you probably just have Intel integrated graphics (e.g. Intel UHD Graphics). The Core i7-8700 natively (that is, by default or what it comes with built into the processor) has just HDMI 1.4. That means unless your motherboard has a conversion chip, you are limited to just HDMI 1.4.
image.thumb.png.4182855f9b31f701bb2917659e368009.png
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...