Jump to content
LaunchBox Community Forums

Launchbox keeps crashing (after wanting to import a Plugin)


TathanLIVE
 Share

Recommended Posts

Hey folks! I've been using Launchbox for a while now and wanted to make "cleaner" folders for my games.


After downloading the Demulimporter plugin (even if I use Flycast), and copying in my Plugins folder, everything crashed.

I then deleted the added files, recreated,...

My Launchbox flashes for a second then disappears, and even after copying old backups (that worked), it doesn't solve the issue. So... I presume it doesn't come from my Data folder.

image.thumb.png.065e12be5f1eedce5c9e1621ea53d3bf.pngimage.thumb.png.3688912454eca190ff4d9cfbbb213fea.png

I also tried reinstalling over my launchbox folder (11.17 and even rolling back to 11.12), but it didn't helped.

 

Any advice? Thanks in advance!

 

PS1: I've tried to create a "clean install" on my second drive, and it doesn't work neither. Really weird issue, doesn't seem to be firewall related...)

PS2: I'm gonna try to rollback to and older version, trying to repair Direct X, C++,... Wait&see.

PS3: Removed all my "elevations", started with a brand new Core folder, repaired DX, C++... but didn't worked.

PS4: sfc /scannow didn't helped neither... dotnet-sdk-3.1.413 64 and dotnet-sdk-3.1.19 neither...

 

PS5: Well, let's go to bed for today... I hope to find a solution very soon because I will not be able to use my 8TB arcade anymore if I don't solve it... :(

Edited by TathanLIVE
Link to comment
Share on other sites

Just tried with safe boot, debogging, deleting some drivers (mostly GPU related)... Still no luck.

My issue seems to be related to this one, but I don't use any of those two programs (there isn't almost anything else than games on my cab). I thought that maybe Process Explorer might help me know to find something but it doesn't look like. Eventho, it looks like there could be something causing the issue and making Werfault to show up...

image.thumb.png.3563291229593d4558a4560ae38de614.png

Edited by TathanLIVE
Link to comment
Share on other sites

1 hour ago, Retro808 said:

If you remove the DemulImporter plugin folder from your build does LB open? I think you mentioned removing, but just confirming.

I have never used that plugin so just downloaded it and placed it in the plugins folder and LB works fine

Hey, thanks for your answer. The issue came for the first time after adding it to plugin folder. But even after removing it and a total wipe (of my cores/plugins/...) nothing changed.

What is reaaally weird, is that even downloading Launchbox on a second HDD didn't solved the issue. Which may mean that it's a bigger problem (DirectX corruption, .net errors,... the thing is that I've been deleting and reinstalling everything since yesterday, and there seems to be no way for me to make launchbox work again.

Did you saw my second answer, where I talk about a Reddit post? It really does look like my issue, but I don't use any of the two mentionned programs. I thought that it might come from my Nvidia Control Panel but they don't seem to disturb my Launchbox.exe...

 

I just wiped all my drivers, all the things "connected" to DirectX, Visual C++,... then reinstalled everything again. (Half of my games will probably not work like this ^^) but... it didn't changed a thing. :(

Edited by TathanLIVE
Link to comment
Share on other sites

PROBLEM SOLVED!!!

For all the people who will have the same issue, what made the difference has been to totally wipe my nvidia settings via 472.12-desktop-win10-win11-64bit-international-dch-whql.exe (latest version at the moment).

image.thumb.png.b92f9d85766376bc77c3c70f0dbec8c7.png

I presume that I wasn't wrong when I thought that the problem came from DirectX, but Launchbox wasn't able to reinstall it properly by itself and even DDU didn't totally wiped those.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...