Jump to content
LaunchBox Community Forums

12.2 Beta Testing


faeran
 Share

Recommended Posts

Hi everyone,

12.2 Beta 1 is now out with the following changes:

  • New Feature: RetroArch can now be automatically downloaded and installed via the ROM import processes (if it's not installed already); this makes it super easy to get up and playing just by running the ROM import wizard and doing literally nothing else
  • New Feature: RetroArch management options are now available under Tools > Manage > RetroArch; there are options to automatically update, update cores, and install or reinstall
  • Improvement: The Arrange By menu can now be used in ascending or descending order
  • Improvement: The menus in LaunchBox have been organized for easier navigation
  • Fixed: Correcting a rare error when saving an emulator without a command line (introduced in 12.0)
  • Fixed: In Big Box, the Launch With option in Game Details no longer shows for games that don't use an emulator
  • Fixed: Incorrect download count when processing multiple EmuMovie queues
  • Fixed: FlowVideo control was not always updating the HasVideo binding correctly
  • Fixed: Add/Edit Emulator will now once again let you add two different cores for the same platform when editing RetroArch

 

Thanks for helping beta test LaunchBox.

  • Like 15
  • Thanks 2
  • Game On 1
Link to comment
Share on other sites

14 hours ago, faeran said:

Hi everyone,

12.2 Beta 1 is now out with the following changes:

  • New Feature: RetroArch can now be automatically downloaded and installed via the ROM import processes (if it's not installed already); this makes it super easy to get up and playing just by running the ROM import wizard and doing literally nothing else
  • New Feature: RetroArch management options are now available under Tools > Manage > RetroArch; there are options to automatically update, update cores, and install or reinstall
  • Improvement: The Arrange By menu can now be used in ascending or descending order
  • Improvement: The menus in LaunchBox have been organized for easier navigation
  • Fixed: Correcting a rare error when saving an emulator without a command line (introduced in 12.0)
  • Fixed: In Big Box, the Launch With option in Game Details no longer shows for games that don't use an emulator
  • Fixed: Incorrect download count when processing multiple EmuMovie queues
  • Fixed: FlowVideo control was not always updating the HasVideo binding correctly
  • Fixed: Add/Edit Emulator will now once again let you add two different cores for the same platform when editing RetroArch

 

Thanks for helping beta test LaunchBox.

Wow, the tools menu looks much better! It was pretty cluttered before and now it's much more streamlined and well organized. Probably will take me a while to get used to but definitely worth it. 

  • Like 1
Link to comment
Share on other sites

1 hour ago, ToniBC said:

Hi, Retroarch upgrade options work well and are interesting, but only upgrade to Stable and it would be better to put an option to upgrade to Nightly or Stable.

Agreed. The update options look awesome and seem to work well, so many thanks for that. But if would be nice to choose from stable and nightly :)

 

Link to comment
Share on other sites

5 hours ago, ALIE said:

WOW i didn't think the RetroArch part could be done.. wasn't the team over there against it ?

Closer to the first part of the year there was a discussion and this sort of integration was deemed possible. So we added it to the summer Community Poll and it ended up being popular with you guys.

1 hour ago, ToniBC said:

Hi, Retroarch upgrade options work well and are interesting, but only upgrade to Stable and it would be better to put an option to upgrade to Nightly or Stable.

14 minutes ago, e2zippo said:

Agreed. The update options look awesome and seem to work well, so many thanks for that. But if would be nice to choose from stable and nightly :)

 

For this first phase of the integration, we chose to focus on stability of the feature, and the stable version is as good as it gets. But it's good to know that you would be interested in a nightly option and we will keep that in mind for future phases.

 

3 hours ago, RULLUR said:

I'm having moments where mid-scroll things kinda lag in transition. I try and change the transition from time to time on whatever lags, but still happens on rare occasion.

This feel unrelated to this current beta. However, we will keep this in mind during the next time we work on a performance update.

Link to comment
Share on other sites

Just now, faeran said:

Closer to the first part of the year there was a discussion and this sort of integration was deemed possible. So we added it to the summer Community Poll and it ended up being popular with you guys.

For this first phase of the integration, we chose to focus on stability of the feature, and the stable version is as good as it gets. But it's good to know that you would be interested in a nightly option and we will keep that in mind for future phases.

Awesome, this is really the best way to update RA to and it's cores do date, appreciate the work!

Link to comment
Share on other sites

1 hour ago, faeran said:

Closer to the first part of the year there was a discussion and this sort of integration was deemed possible. So we added it to the summer Community Poll and it ended up being popular with you guys.

Oh yah i even voted for it.. guess i forgot 😄but exciting stuff

Edited by ALIE
  • Haha 1
Link to comment
Share on other sites

I was able to update RetroArch and associated cores last night. I tested a few systems and everything seemed to be in good working order. Good update so far. I like the new menu organization, but it might take a bit to get used to it.

Link to comment
Share on other sites

Hi everyone,

Beta 2 is now out with a few fixes:

  • Fixed: You can now clear the Scrape As value of a platform in Edit Platform
  • Fixed: Select audio was playing twice on occasion when navigating Platform Categories in Big Box
  • Fixed: Corrected several issues related to the Bulk Edit Wizard (introduced 12.2 beta 1)
  • Fixed: Refresh All Images has been added to View menu (introduced 12.2 beta 1)
  • Fixed: Reduced the time it took to switch pages in the various wizards (introduced 12.2 beta 1)

Thanks for your continued help with beta testing.

  • Like 6
Link to comment
Share on other sites

I hope this is the correct place to post this. This just started with the new beta 2 release 

When creating a new category i get the following error and CTD. It was working fine yesterday. It also happens when i right click on a system to add it to a category. It will crash, I restart, and then i can right click on the system again and then assign it. It seems to be happening with each new system I add. 

I have even tried a fresh install of LB, and it is doing it without having anything installed into LB. 

It does seem to add the category when I restart LB. 

spacer.png

 

Edit: it's not happening every time. I just created another catagory, and it didnt give the error this time. 

Edited by maabus
Link to comment
Share on other sites

it actually seems to happen when i try add a system to a category. All newly systems would give that error when i right click on them. i could add a bunch of systems to LB but if i right clicked any of them it would give the error. after it crashed i could then .right click any new system and it would be fine

Link to comment
Share on other sites

Just got this error when trying to import a mame romset while some media was still downloading for another platform.

Object reference not set to an instance of an object.

App:     LaunchBox
Version: 12.2-beta-2
Type:    System.NullReferenceException
Site:    System.Object CreateBatchFactory(System.Object)
Source:  Unbroken.LaunchBox

   at Unbroken.LaunchBox.Search.LocalDb.CreateBatchFactory(Object )
   at Unbroken.LaunchBox.Search.LocalDb.GetMameFileResult(String filePath, Boolean useFolderNames, GameBase game)
   at Unbroken.LaunchBox.Windows.Processes.ImageDownloader.CalculateInvalidParameter(Func`1 item, Action`2 cust, Action`4 dir, Action`2 v2)
   at PageComparator.DestroyBatchAuthentication(Func`1 item, Action`2 cust, Action`4 dir, Action`2 v2, PageComparator )
   at Unbroken.LaunchBox.Windows.Processes.ImageDownloader.ProcessQueue(Func`1 isCancelled, String activeImageGroup, Action`2 onIndeterminateUpdate, Action`4 onUpdateAction, Action`2 onGameImageDownloaded)
   at Unbroken.LaunchBox.Windows.Desktop.ImageDownloaderHelp.<>c.ExcludeAwareConnection()
   at Unbroken.LaunchBox.Windows.Threading.<>c__DisplayClass0_0.CustomizeSessionContainer(Object )
   at Unbroken.LaunchBox.Windows.Threading.<>c__DisplayClass0_0.ExcludeInvalidCallback()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
--- End of stack trace from previous location where exception was thrown ---
   at System.Threading.ThreadHelper.ThreadStart()

Recent Log:

   11:42:49 Exception

 

Link to comment
Share on other sites

Hey all. When I try to download and install retroarch, reinstall retroarch, update retroarch and/or update cores I get this error msgs:

This is from the manage option:

image.png.0d21d5fb98a56cdd81babdcd22605116.png

This is from the Import option:

image.thumb.png.e769031cdfa8c4dc4770b97011ac9aa7.png

Any Ideas?

Edited by Azgorath
Link to comment
Share on other sites

7 minutes ago, Azgorath said:

Hey all. When I try to download and install retroarch, reinstall retroarch, update retroarch and/or update cores I get this error msgs:

This is from the manage option:

image.png.0d21d5fb98a56cdd81babdcd22605116.png

This is from the Import option:

image.thumb.png.e769031cdfa8c4dc4770b97011ac9aa7.png

Any Ideas?

Interesting, there was a moderator who reported this in our mod server, but when i tested it all worked just fine. So thank's for the report, and hopefully once in the devs are back in there home offices on Monday it can be investigated a little further.

Thank's for the report though, and this is why we beta test new features. :) 

Link to comment
Share on other sites

@Azgorath I had this issue as well. It happened on a couple builds I have. I tried several times and then waited a few hours to try again I did not have the issue. So I am thinking maybe just an ISP hiccup or something connecting the the RA servers. I have since tested this feature several more items and have not had it replicate. Since your post about the error have you had any success with the feature?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...