Jump to content
LaunchBox Community Forums

Can't install/launch LaunchBox 11.7


Recommended Posts

When I install 11.7, it gets to the part where it says it needs to update/install DirectX and then seemingly crashes. I uninstalled 11.7 and installed 10.13 and that worked fine, however when it goes to update to 11.7, I run into the same issue. I have verified that both vc_redist.x64 and vc_redist.x86 are both installed and that Direct X seems to look fine using dxdiag. I am on Windows 10 Pro 64-bit and also updated to the latest video drivers per another thread and I still can't finish the install or launch the program as it immediately closes. I don't have any 3rd party anti-virus installed (just the Windows one and real time protection is off). Also, I am not seeing any logs generating in the logs folder. I have heard a lot of good things about LaunchBox and I am ready to pay for it if I can get it running. Attached is my Event Viewer logs. Any help is greatly appreciated!

EDIT: Did a fresh install of Windows and it's now running.


Edited by konotori
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...