Jump to content
LaunchBox Community Forums

My controls work in Launchbox/BigBox interface, and also with SNES emulator through LB/BB. BUT do not work in MAME


Recommended Posts

My problem is similar to the one posted in this thread:

My controls are SJ@JX boards wired to arcade joysticks and buttons. (Bought them from amazon, see here: https://www.amazon.ca/gp/product/B083RTT51K/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

I tried the solution listed in the linked thread above(and in other threads) but no dice.  I have the lifetime registration to LB/BB, I'm using a pretty old version of MAME (0.122u1).  It's on a PC running Windows 10, and playing games is it's entire job. It is installed inside an arcade cabinet. Running MAME by itself my controls work fine. Through LB/BB they let me navigate the menus fine.  I can start a SNES game through LB/BB and play it just fine.  When I try to run a MAME game through LB/BB, the game runs but my controls are ignored.  I can use tab on the keyboard to bring up the joystick configuration, and all of my previously set mappings for my joystick are there, but they just don't work.  I've tried setting my mamepgui.exe to run as administrator.  I've done the same to my LB/BB executables.  I've enabled joysticks under the global options in MAME (before that they did not work outside of LB/BB which they do now). The command line argument "-keyboardprovider dinput" is not an option, because my version of MAME does not support it.  

I'm at the point where my machine is working just the way I want with this one exception.  The thought of having to try and get a new version of MAME to run really sucks @$$.  What about LB/BB could be blocking MAME from taking commands from my joysticks?  The keyboard works with it both ways, so I already went down the joytokey rabbithole only to find out that it will not work under MAME. *ugh*  If I can't figure this out I may have to swap my joystick boards for  a keyboard one, but i believe that there must be a better solution than that.  I have read many posts so far with similar problems but not too many with any kind of solution. 



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...