Jump to content
LaunchBox Community Forums

DInput no longer working with MAME?


Recommended Posts

Four years ago I spent quite a bit of time setting up a MAME rig.  I have a Mayflash Arcade Stick F300 Elite in 4-way mode for 4-way games, two XBOX controllers for the 8-way games, a Thrustmaster flight stick and trackball device with a spinner ring on it for stuff like Zaxxon and Tron.  I have everything set up in devicemap.cfg.  I have the Arcade Stick in DInput mode since MAME takes XInputs on a first come first serve basis.  That way it never gets confused with the XBOX controllers.  Once I had everything set up and confirmed all games were working correctly, I set default.cfg, mame.ini, and ui.ini to read-only so that those files wouldn't get changed if MAME started without a controller plugged in.  Then I copied my entire finalized MAME setup to another location as a backup and haven't touched it.  This setup worked flawlessly for years.  However, life got busy and I haven't played with it in awhile.  Last week I bought a new computer and copied the backed up MAME setup onto it

The problem I'm running into is that MAME is no longer recognizing the Arcade Stick in DInput mode.  Opening the USB Controllers app in Windows, the Stick is recognized in both DInput and XInput and shows OK.  It's just in MAME that it's not recognized.  I thought maybe it's Windows 11, so I went back into my old PC (Win 10) to confirm.  However, the stick is no longer recognized in DInput mode on that PC either.  I verified date stamps on all the files, they're still read only and still dated 2019, so nothing in the MAME folder has changed.  The only thing I can think of is that Windows 10, and now Windows 11, has been updated in a way that's not playing well with MAME.  I did notice that in Device Manager it had a yellow triangle when in DInput mode that would go away when I switched to XInput.  I went to the Mayflash website and downloaded the most recent firmware (Dec 2022) for the Stick.  This fixed the issue in Device Manger.  It also changed the name of the device in DInput mode and I've adjusted the devicemap.cfg accordingly, but still no luck.

If I switch the Stick to XInput it works fine in MAME, but then it gets confused with the XBOX controllers, so I have to reboot as I go between them.  I wanted to see if anyone else has had this come up and if there's anything that can be done about it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...