Jump to content
LaunchBox Community Forums

Help! Retroarch and Dolphin will not load Gamecube roms (PC)


Recommended Posts

Hello all,


This is my first post and apologize if this is in the wrong area.  I'm a noob to Launchbox and Retorarch and emulators in general and I use the free version.  I'm considering upgrading.  I'm an old gamer from way back, I dropped a lot of Bicentennial quarters into a few Pong machines if you know what I mean.  I use the programs on a cheap Dell PC running Windows 10.


When I first began using Launchbox about a month ago, Gamecube roms worked great through Retroarch.  I also have great success with Retroarch handling all my other roms for a wide variety of other games in Launchbox.   I then installed Dolphin because I heard it was the top emulator for the Nintendo Gamecube.   Now neither will load games.  I've tried uninstalling Dolphin and the same thing happens.  Retroarch gets stuck at this screen and will never load a rom,  I've tried a lot of things that I have seen online and on YouTube, but nothing seems to work.  


If anyone could provide me with any help, it would be greatly appreciated.  


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...