Jump to content
LaunchBox Community Forums

[SOLVED] PCSX2 failed to initialize CDVD


SolarisSpell

Recommended Posts

Hi

 

I'm having a problem I'm unable to solve. I've been looking for answers online, but without any luck.

PCSX2 fails to initialize when launching an Additional Version of a game (which happens always when a game has multiple discs)

 

For example, I have Xenosaga I, only 1 disc, so when I launch it through Launchbox, it opens PCSX2 and the games load without any problem. Great

 

But then I have Xenosaga II, 2 discs.

If I only configure the first disc in Launchbox, I can play it normally.

If I configure the first disc and disc 2 as an additional version, I can play Disc 1 fine, but Disc 2 open PCSX2 and a "Failed to initialize CDVD" error appears.

If I configure the first disc, and disc 1 and 2 as additional versions (so that the multidisc label appears), it fails even if I just 'normal launch' the game, without selecting the first disc through additional version.

 

Is someone experimenting problems with additional versions and PCSX2? Have you been able to solve the problem?

 

EDIT: I failed to mention that, even if the problem appears and the game doesn't launch, PCSX2 remains open. Here, through PCSX2, I can launch both disc 1 or 2 of Xenosaga II without any problem. So the error seems to be in how Launchbox calls PCSX2, but only regarding additional versions of the game. I don't know why...

 

Thanks

Edited by SolarisSpell
Link to comment
Share on other sites

Well, it works now. How? No idea.


In case anyone has a similar problem, I was trying not to launch the game by selecting an emulator and creating a command line to do it, and I accidentally deleted the emulator not from the game, but from all Launchbox.

After adding it back, all my ps2 games had lost the emulator field, so I assigned that too... and now it works.

 

It's magic...

Link to comment
Share on other sites

  • SolarisSpell changed the title to [SOLVED] PCSX2 failed to initialize CDVD
  • 5 months later...

I just had this error pop up and found a link on YT with the answer.  My disc files had the extensions .bin and .cue, After importing into Launchbox it defaulted to running the .cue file.  Launchbox needs to be configured to run the .bin file.  Right Click on the game, choose Edit Metadata/Media to open the game settings.  Then go to Launch --> Rom File and browse to your game directory and choose the file that ends in .bin.   And, that was that.  Fixed.

Link to comment
Share on other sites

On 9/1/2023 at 6:21 AM, YergeB1 said:

I just had this error pop up and found a link on YT with the answer.  My disc files had the extensions .bin and .cue, After importing into Launchbox it defaulted to running the .cue file.  Launchbox needs to be configured to run the .bin file.  Right Click on the game, choose Edit Metadata/Media to open the game settings.  Then go to Launch --> Rom File and browse to your game directory and choose the file that ends in .bin.   And, that was that.  Fixed.

Legend, this fixed my problem, thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...