Jump to content
LaunchBox Community Forums
Otterly Amazing

Launchbox 9.3 seems to be hanging my Intel NUC

Recommended Posts

I've been setting up my collection on my new hades canyon NUC (I love this damn thing!) with Retroarch and my favorite emulators. No real problems until I installed Launchbox. So far today I've had three crashes that I had to hard reset on my computer. This only seems to be occuring while using Launchbox. First two crashes occured while I was setting up all the options in launchbox. Third just happened while playing Snes9x to test out functionality. I installed all available updates through Intel's updater (BIOS, fixes, etc.). Retroarch is also at latest version. The only thing that I haven't done is get a Windows 10 license, so its in watermark mode. Of course this NUC is notorious for being the first collaboration between Intel and AMD so it is running a i7 CPU and Vega CPU on the same chip.

Specs: Hades canyon Intel NUC w/ Samsung EVO 500GB SSD, 16 GB Gskill 2400mhz ram, AMD Vega 4GB GPU

Edited by Otterly Amazing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...