Jump to content
LaunchBox Community Forums

[Solved] Steam Link, Big Box & Dolphin - Xbox 360 controller don't work


Recommended Posts

Hi Everyone !

I have a gamepad problem with the Dolphin emulator when I run a Gamecube game from Big Box on my Steam Link.
My gamepad work fine in Snes games or GBA games (retroarch), and very well in the Big Box Menu.
I did a search (google & on the forum) but I didn't find an answer that solves my problem.

My Setup:

  • Steam Link connected to my TV + Xbox 360 usb Wireless Receiver
  • Xbox 360 Wireless Controller
  • Latest Launchbox + Premium account for Big Box 

What i tried (in order):

  • Configure my X360 controller in big picture as a generic controller (no changes)
    (Manage shortcut (Big Box) > Controller configuration > Gamepad template)
  • Configure in Dolphin launched directly via steam shortcuts (Half Worked)
    (Dolphin detected my gamepad in Xinput and games worked, but it doesn't change anything if I try to run a game with Big Box)
  • Deactivated the steam overlay (in doubt - no changes)
  • Unchecked the 2 controller's options in Big Box (no changes)
    (Big Box > Options > Controller > uncheked controller activation & Use all controllers)
  • Used Retroarch to launch Gamecube games in Big Box (Worked but...)
    (Retroarch worked but with many graphic  & sound issues, and more hard to tweak unlike Dolphin)


So my only conclusion at this point is that the Steam Link send Xinput information, but there is a problem between Big Box and Dolphin. Retroarch is not impacted (it detects the controller because we see the notification at the bottom of the screen). 


Has someone managed with their Steam Link to set up an Xbox 360 controller to work with Big Box and Dolphin ? Or would someone have an idea of what to do to solve this problem?


Thank you :)


PS. sorry for my english, i'm a little bit rusty with this language.

Edited by Nicobliss
Link to comment
Share on other sites

Thanks @CDBlue your reply :)

Since my question yesterday I restart my pc, and now everything work perfectly without any other changes...
So for people who would have the same problem as me, this is how I configured my Steam, Big Box and Dolphin:

In Steam Link:

  • Big Box Shortcut > Manage Controller > Gamepad Template
  • Controller Option > Uncheck the 2 options (Overlay & Desktop)

In Big Box: 

  • Option > Controller > check both options (if they are not enabled natively)

In Dolphin:

  • Connect your controller(s) directly to the PC
  • Controller Settings > Port 1: choose "Standard Controller" > Configure button > Device: Choose Xinput/0/Gamepad > Map your buttons
  • In the same window, check the box "Always connected"
  • Do the same thing with all your gamepads and choose Xinput/2/Gamepad or Xinput/3/Gamepad or Xinput/4/Gamepad for each
  • Close Dolphin

       /!\ For each controller, you must associate the Xinput / 1to4 / in the drop-down list. If you combine Xinput / 1 / gamepad with two different controllers,
            for example, you can control 2 characters in a game with the same gamepad (the first one in the list). Not very practical!


And as @CDBlue said, check that Dolphin is not set to run as admin.


Now just to be sure, restart your computer ...  And normally everything should work properly!



Edited by Nicobliss
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...