Jump to content
LaunchBox Community Forums

Troubleshooting the default configuration


Exyloz
 Share

Recommended Posts

I have a game that works perfectly when I run it directly from DOSBox (NOT using LaunchBox). When I launch it with LaunchBox, it has a serious bug.

The first thing I tried was setting a custom DOSBox EXE path so that I'm running it with the same version of DOSBox. Then I tried changing various settings relating to memory, machine type and CPU core.

I'll list the bug details below in case someone already knows the fix for this particular game. But I'd like to know how to go about debugging LaunchBox's default DOSBos config. How can I compare it to the config used for a native DOSBox launch?

---

Bug details::

Game: Ultima Underworld 2

Tested on a new game, both from a fresh save at the start of the game and also directly from character creation.

When launched by LaunchBox, editing the map breaks the game. Specifically, after adding text to the map and leaving the map, the following problems occur:

1) Saving stops working. ("Save Game Failed")

2) Upon reopening the map, all text entries have disappeared, including the ones it starts with on a new game.

3) Upon changing the map level to 2 and then back to 1, all mapping has disappeared, even the mapping it starts with on a new game.

Again, this only happens when launched by LaunchBox, so it has to be due to one of the settings LaunchBox is using in it's default DOSBox config.

Link to comment
Share on other sites

Rather than delete my question, I'll answer it.

First, if you create a custom config file in LaunchBox, it will be populated with all the default settings. You can then navigate to that file wherever you created it and open it in a text editor. The order and comments will probably be very close to your native DOSBox default config file, making it easy to compare.

---

As for the bug, it has nothing to do with the config. It's apparently a DOSBox bug that makes no sense at all to me. If the files are on the C drive (in Windows) the error occurs.

C:\Users\xxxxxx\LaunchBox\Games\MS-DOS   (FAILS)

C:\MS-DOS   (FAILS)

C:\DOSBox   (FAILS)

D:\DOSBox   (WORKS)

E:\DOSBox   (WORKS)

I can't imagine how the location of the files in Windows could possibly affect a game running on an emulated file system. Maybe it's has something to do with the drive type rather than the drive letter. I really have no idea here.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...