Jump to content
LaunchBox Community Forums

Long Mame load time on BigBox for first game


Pinflip_
 Share

Recommended Posts

I notice others had issues with long times with mame launching but I have not noticed my issue in particular.

The issue that I have is that after start-up of my system, BigBox loads, and select a game to play it takes long time to load the first game.  I have no issues after this.  It does not matter what game I try and the issue does not persist after the first game launches.

This has been happening for me for both old and current versions of  LaunchBox and Mame.  Currently running LB 12.9 and Mame .240.  Does not happenn when I run mame outside of LB/BB

Edited by Pinflip_
Link to comment
Share on other sites

Interesting that you suggest to open Mame before launching BigBox. I have tried that with no success. 
one thing I neglected to add which was the issue is that my whole build is on an external hard drive (LB,Mame,…).
I decided to move LB and Mame over to internal storage of my pc and I don’t have the issue. I was monitoring the activity of the external hard drive and noticed when I launched the first game I was at the drives limit, hence the slow start. 

  • Thanks 1
Link to comment
Share on other sites

  • 4 months later...

This is an old post but I had the exact same issue. Pinflip_ last message helped me to figure out what was the problem so thank you for that. Here is my solution in case it helps someone else.

Just like Pinflip_, my build is on an external hard drive and my drive was under huge pressure when I loaded my first mame game through launchbox/bigbox. It could take up to 30 solid seconds before mame showing up. 

Antimalware Service Executable was the culprit. I had to add mame.exe as an exception into Windows defender (Fix3 in the link above).

https://www.easeus.com/partition-manager-software/antimalware-service-executable-high-disk-usage.html#3

MAME now starts almost instantly and I have a flawlessly experience with bigbox/mame. :)

 

 

 

Edited by Nanotik
  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
On 8/4/2022 at 2:14 PM, Nanotik said:

This is an old post but I had the exact same issue. Pinflip_ last message helped me to figure out what was the problem so thank you for that. Here is my solution in case it helps someone else...

After reading this I decided to try adding a Windows Defender exclusion for my mame.exe (even though it's on my internal/primary C drive) using the instructions here:
   https://support.microsoft.com/en-us/windows/add-an-exclusion-to-windows-security-811816c0-4dfd-af4a-47e4-c301afe13b26

Now when I launch dkong (Donkey Kong) from within BigBox it's:

  •     7.5 seconds faster on the first game launch (6.5 vs. 14 seconds)
  •     5.5 seconds faster on all subsequent game launches (2.7 vs 8.2 seconds)

This is running MAME 0.239 with BigBox 12.14 on an ancient/slow computer built in 2009 with Windows 10 Pro 21H2 (OS Build 19044.1865), 12 GB RAM and a Western Digital Caviar Green WD20EARS 2TB spinning drive.  I suspect those with non-ancient computers probably won't see as big of a speed increase.

The first launch is the first time you launch a game after booting Windows.  With or without a Defender exclusion the very first time you launch a game (after starting your computer) there's more of a delay.

Edited by InvaderJim
words are hard
Link to comment
Share on other sites

15 hours ago, InvaderJim said:

After reading this I decided to try adding a Windows Defender exclusion for my mame.exe (even though it's on my internal/primary C drive) using the instructions here:
   https://support.microsoft.com/en-us/windows/add-an-exclusion-to-windows-security-811816c0-4dfd-af4a-47e4-c301afe13b26

Now when I launch dkong (Donkey Kong) from within BigBox it's:

  •     7.5 seconds faster on the first game launch (6.5 vs. 14 seconds)
  •     5.5 seconds faster on all subsequent game launches (2.7 vs 8.2 seconds)

This is running MAME 0.239 with BigBox 12.14 on an ancient/slow computer built in 2009 with Windows 10 Pro 21H2 (OS Build 19044.1865), 12 GB RAM and a Western Digital Caviar Green WD20EARS 2TB spinning drive.  I suspect those with non-ancient computers probably won't see as big of a speed increase.

 

Great ! now my experience with mame is back as it once was ! Thanks !!!

I have applied the exclusion to my Kaspersky

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...