Jump to content
LaunchBox Community Forums

Mame launching problem with ini file checked !


Recommended Posts

first, please excuse my bad english, it's not my mother tongue.
Then my problem seams to happen a lot, but I couldn't find a fix anywher, so sorry if you think "another dumb noob". Well, I'll try my best to keep logical and be the more informative and specific.
The probleme is : MAMEUI (and MAME) 0.198 launching roms (from a 0.198 rom set), but launchbox fails to.
Launchbox ver is 5.9, premium. Windows is 10 1803, I recently did the April update and struggled to fix many problems, so I suspect something going on here.

MAMEUI64 is my default Arcade Emulateur and launch successfully through Launchbox.

I tried different things :

1) Separate roms from emultor :
So my emulator is here : F:\Jeux\Emulation\Emulateurs\Arcade\mameui64_198\mameui64.exe
My mame.ini file rom path is set to : rompath  "F:\Jeux\Emulation\Roms\Arcade\MAME 0.198 CHDs (merged);F:\Jeux\Emulation\Roms\Arcade\roms_split0198;F:\Jeux\Emulation\Emulateurs\Arcade\mameui64_198\roms"
BTW the mame roms folder is empty
I can launch a rom throught mameui64 (e.g: three stooges) but not through Launchbox (message error NOT FOUND, see picture)
The rom path in launchbox :  ..\..\Emulation\Roms\Arcade\roms_split0198\3stooges.zip

2) Then I tried to move a few working roms in the mame rom folder :
My mame.ini file is still the same
I moved my 3 stooges rom from the separate folder to F:\Jeux\Emulation\Emulateurs\Arcade\mameui64_198\roms
now the rom can be launched throught both LaunchBox and MameUI.
Great but, since I want to keep chds, roms and other stuff separated, the "everything in the rom mame folder" solution is a bad solution for me.
3) The I thought, ok, maybe I can use subfolders in the rom mame folder. So I put my 3 stooges rom in a rom mame subfolder mameui64_198\roms\roms_split_0198, but same problem as #1. (I added this subfolder to the ini mame file rompath)
4) Finally I tested to put my 3 stooges rom in a folder named rom_fav next to the rom mame folder (adding rom_fav to the ini rompath). Same problem

So the only working solution is not a good solution for me, and I never had this problems before my windows update.
Does it ring a bell ?
Thanks for helping, please let me know if you need more informations



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...