Jump to content
LaunchBox Community Forums

Launching MAME games through Launchbox is resetting controls


Jinxyface
 Share

Recommended Posts

Hello, I've recently started setting up MAME (.226), and everything works fine if I launch MAME by itself. Controller works and everything. I've set the games to launch through Launchbox (Launchbox pointed to C:\Users\<USER>\LaunchBox\Emulators\MAME -> mame64.exe). The games will organize and launch fine, but when launching through Launchbox, my controller doesn't work and the game will only work using the default MAME controls. I can then close LB, and re-launch the games directly through MAME and the controller works fine again.

 

Some extra info:

1) I only have one instance of MAME installed

 2) I've set my default.cfg to read only for MAME to not wipe controls on exit

3) I don't have RetroArch installed/am not using RetroArch MAME

4) I am using the most recent stable LB 11.8

 

Anyone got any ideas?

Edited by Jinxyface
Link to comment
Share on other sites

Hopefully someone with more insight on this will chime in as I'm just grasping at straws. ?

Ya, simply leaving dinput off after -keyboardprovider will basically tell MAME to load the keyboardprovider that's called rom_name [whatever the name of the rom is  (aka "File") you're trying to load].  image.png.1e13be944069f2e0cf235beec606d8eb.pngI have an Xbox controller as well and (thankfully) haven't ran into this.  (no offense)   So the full "-keyboardprovider dinput" should not be an issue. 

My last thought is: in LaunchBox, click Tools, Options... scroll down to Game Controllers and make sure Enable Game Controllers is checked.  By default it's not checked.

Link to comment
Share on other sites

I had this issue as well.  My assumption was that Mame was not given the permission to save the config file upon closing the program.

Here is what I did to fix it...

I found the mame64.exe in regular windows file explorer (NOT IN LAUNCHBOX)

RIGHT Click mame64.exe

select "Properties"

select "Compatibility" tab

Under Settings make sure "Run this program as an Administrator" is checked.

then Select "Apply"

click "OK" to exit the Properties dialogue.

 

Mame now saves my joystick configurations in Launchbox.

 

I hope this works for you.

Cheers

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...