Jump to content
LaunchBox Community Forums

2 naomi lightgun games only working 1 player


jimbone007
 Share

Recommended Posts

I'm back trying to get naomi lightgun games working with my gun4ir using demul launchbox and demulshooter. So far I have multiple running 2 player the only ones I cant get to work are house of the dead 2 and ninja assault. They work great 1 player but when I try to play two player the two guns only shoot as one. so where the "bullet" lands shows both colors but in one spot when using either gun. Anyone else have this problem or know the fix? Also I'm having a hard time hiding the mouse cursor in all the naomi/demul shooters.

Link to comment
Share on other sites

17 hours ago, jimbone007 said:

I'm back trying to get naomi lightgun games working with my gun4ir using demul launchbox and demulshooter. So far I have multiple running 2 player the only ones I cant get to work are house of the dead 2 and ninja assault. They work great 1 player but when I try to play two player the two guns only shoot as one. so where the "bullet" lands shows both colors but in one spot when using either gun. Anyone else have this problem or know the fix? Also I'm having a hard time hiding the mouse cursor in all the naomi/demul shooters.

I had the same issue and got tired of dealing with Retroarch so switched to the Flycast standalone emulator for 2 player games.  

When you say hide the cursor, are you talking about the system cursor or the in game crosshairs?

Link to comment
Share on other sites

I'm not using retroarch I'm using demul as the emulator and 2 player works with maze of kings, death crimson ox, and confidential mission just not hotd 2 and ninja assault for some reason. I read on another forum where the  creator of demulshooter told someone with the same issue that demulshooter needs to be run as admin because what was happening was that it wasn't opening the program like it should which is why it didn't work but i am running as admin. As far as the mouse I mean the system cursor. The lightguns act as a mouse so the system cursor shows. there is a option to hide mouse cursor in lb but it doesn't work maybe because I'm launching with a ahk 

Link to comment
Share on other sites

I just tried opening house of the dead 2 before demulshooter in the ahk script and that fixed it. 2 player works as it should for both hotd2 and ninja assault. I had to recalibrate player 2 for ninja assault also. now ninja assault is white in the sides of the screen instead of black though any idea why or how to fix that? 

Edited by jimbone007
Link to comment
Share on other sites

Demulshooter needs to run as admin. But the actual demul should *not* be running as admin. Demulshooter needs to run as admin so that it can hook into the emulator process.

Also, I have had massive mixed success running demulshooter before the emulator. Therefore, I always start demulshooter after the emulator process is up and established. The same with timing of running nomousy to hide the mouse cursor. Here is an example of my arcade demul launch AHK:

 

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir,\Light Gun Games\Dreamcast\demulgun
#SingleInstance force
 
; Sets sound 15 notches lower for this game, its louder than most.
SoundSet,-15
 
; Set my control panel leds
Run, \Light Gun Games\Tools\setleds\settwoplayergun.exe
 
; Run the emulator
Run,demul.exe -run=naomi -rom=deathcox
 
; Wait and run demulshooter after demul is running
Sleep, 15000
Run, \Light Gun Games\Demulshooter\DemulShooter.exe -target=demul07a -rom=deathcox
; Hide the mouse cursor
Run, \Light Gun Games\Tools\nomousy\nomousy.exe /hide
; Wait for demul to close
Process, WaitClose, demul.exe
 
; Clean up after demul closed.
Run, \Light Gun Games\tools\setleds\setfrontend.exe
Run, \Light Gun Games\Tools\nomousy\nomousy.exe
SoundSet,+15
; This runs as admin to make sure demulshooter is exited.
Run, \Light Gun Games\Demulshooter\killdemul.exe
ExitApp
 
;FOR EXITING THE GAME
ESC::      
    Process,Close,demul.exe
return
 

Note we Run demul not RunWait. Then we sleep for demul to be active and the game to start booting before we finally launch demulshooter and nomousy. This has been extremely reliable for me.

Without demulshooter hooking the process, you won't get raw gun input which means you won't get player 1 and player 2 individual controls.

Edited by markmon
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...