Jump to content
LaunchBox Community Forums

Xbox Bluetooth Controller & WinUAE issue

Recommended Posts

Morning fellow Arcadian's

As the title points out I currently have an issue with my Xbox Wireless Controller (Bluetooth) with connection to the emulator WinUAE (current version v3.4.0), when launching through Launchbox (current version as of 28/02/17).

I currently have Launchbox setup to launch all my emulators and games via Rocketlauncher (current version v1.0.1.10 with latest driver updates as of 28/02/17). Now all the other emulators I have installed and setup through Rocketlauncher work without a hitch with my Xbox Wireless Controller.

I have read up that WinUAE is susceptible to issues with the Xbox Wireless Controller via bluetooth and in order to get round this you need to put the following parameter '-norawhid' in at execution.  I have tried this on the standalone WinUAE (applied to the icon startup parameter field), and this works perfectly with the Xbox Wireless Controller.  However I cannot seem to pass the '-norawhid' within the Launchbox emulator setup area for Rocketlauncher.

Just to explain how I have setup Launchbox  with Rocketlauncher a bit more clearly. I have Rocketlauncher as my only emulator for all the associated systems/platforms that I use in Launchbox and within the 'Associated Platforms' field in Launchbox I pass the following command line to Rocketlauncher: -f "Z:\Launchbox\Launchbox,exe" -p RocketLauncherUI -s "Commodore Amiga" -r

This command then works in conjunction with the Rocketlauncher's setup for the platform (i.e.), 'Commodore Amiga' which I have left as default...due to the complexity of Rocketlauncher and my shameful small understanding of this beast!! Now I have tried placing the parameter '-norawhid' into this commandline, but it does not register on the excution of WinUAE via Rocketlauncher and as mentioned my understanding of Rocketlauncher is severely limit.  I cannot seem to understand how to enter additional parameters to the WinUAE (Commodore Amiga), platform in Rocketlauncher at all....aaaahhh!!!! :(

As I've mentioned above this setup works with no problems with all the other platforms setup with Launchbox/Rocketlauncher - so my question (which I can appreciate may be more a Rocketlauncher forum topic!), has anyone else had this issue of passing the '-norawhid' parameter in a similar scenario and succeeded or can anyone shed a light on my frustration due to my limited abilities here??

Many thanks in advance - Chris C.

Software used version recap:
Launchbox - v7.7
Rocketlauncher - v1.0.1.10 + Latest Drivers
WinUAE - v3.4.0


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...