Jump to content
LaunchBox Community Forums

MAME HLSL slider control of parameters


cvgamer
 Share

Recommended Posts

I'm trying to use HLSL under mame64ui .191

I followed the advice on this YouTube video:

https://www.youtube.com/watch?v=Q0vJrmXHydU

that tells you to delete existing ini files and start with one provided in the comments.

It seems to work except I can't get the HLSL slider controls to show up when I tab or tilde from within the game.

On the game properties from the main UI, if you go to Advanced->Select Effect I can choose an hlsl function (one only)

like shadow mask or scanlines, so I think it basically works, but how to easily change the parameters like in the video ?  
 

Link to comment
Share on other sites

The tilde key should bring up the slider at the bottom and then use your arrow keys to scroll through the different ones til you find the HLSL sliders. Keep in mind though changing those sliders will only remain while that game is loaded, it won't remember those settings after you close out the game. To make permanent changes you need to edit the raster.ini file in the \ini\presets\ folder

I'd suggest downloading my HLSL preset and seeing how they look, I think they look extremely good but of course personal preferences vary. Instructions are on the download page.

 

Link to comment
Share on other sites

I guess I was wrong in my initial post - the effects function in properties is some kind of png overlay on the screen - different from HLSL scanlines.

I tried the new raster file in ini presets and in the main mame.ini file which in .191 is in the main ini directory now, and a few other combinations.

What happens is the game screen does change. Without this HLSL stuff the actual game video looks like a "resized picture" with some blur. When I set

the HLSL parameters (video to d3d)  using these various ini files I get a solid hard pixellated image but I cannot adjust anything using the parameters

in the files . The adjustment sliders don't even show up when tilde or tabbing during the game.

So it does change but it won't seem to allow me to tweak those various parameters.

???

Info: am using an older but decent Radeon GFX card and DirectX 11.

 

 

Edited by cvgamer
Add info
Link to comment
Share on other sites

5 minutes ago, cvgamer said:

Without this HLSL stuff the actual game video looks like a "resized picture" with some blur.

This is most likely the bilinear filtering which is under:

# OSD ACCELERATED VIDEO OPTIONS
#
filter                    0

If you have a 1 in your mame.ini change it to 0, it should be off if using a shader.

8 minutes ago, cvgamer said:

When I set

the HLSL parameters (video to d3d)  using these various ini files I get a solid hard pixellated image

Did you enable HLSL in your mame.ini file ? Set hlsl_enable to 1

# DIRECT3D POST-PROCESSING OPTIONS
#
hlslpath                  hlsl
hlsl_enable               1

Link to comment
Share on other sites

Yes the filter is off - 0. So I guess that means the HLSL may not be recognized at all, its just the filter switch causing the change.

Yes hlsl is enabled. I've tried a lot of combinations of the YouTube ini and you're file and I have not yet gotten anything to work.

 

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...