Jump to content
LaunchBox Community Forums

New 2200g build, weird video, bad CPU?


Recommended Posts

Everything is running great on my original machine,building a new Ryzen 2200G mitx system. When I try to run Dreamcast or Naomi games I get weird video distortion/artifacts. I'm running Dreamcast games through ReicastOIT but have also tried Reicast, Redream and Demul. Naomi games are running in Demul. Dreamcast only renders in diagonal stripes, demul is covered in blinking pixel noise.

I've reinstalled video/chipset drivers and even did a fresh windows install. Has anyone seen this before? I'm totally at loss for what could be going wrong and I think I've got a bum CPU/APU?

Dreamcast 1: https://www.dropbox.com/s/cjwqi6xnyjshfse/retroarch 2018-10-05 08-31-14-29.mp4?dl=0

Dreamcast 2:https://www.dropbox.com/s/sla2t3k806s4udu/retroarch 2018-10-05 08-32-05-34.mp4?dl=0

Naomi: https://www.dropbox.com/s/71a68ttywdgxv68/demul 2018-10-05 08-34-11-98.mp4?dl=0

Naomi: https://www.dropbox.com/s/t94zjjw428otglv/demul 2018-10-05 08-34-33-06.mp4?dl=0

Edited by Numbskull
Link to comment
Share on other sites

Is this problem with only Dreamcast stuff ?

Have you tried other system emulators such as Dolphin, PPSSPP and PCSX2 ? Do those have any rendering issues at all ?

If you have these problems with other emulators then it could very well be a chip or driver issue. If not then I would just guess it's an issue with the emulator and your APUs OpenGL drivers. AMD video drivers can be problematic with OpenGL and is a known issue which is why I always recommend Nvidia when people ask which to use in an emulation build.

Try out other software and games to see if the issues are common between them or just restricted to Dreamcast.

Link to comment
Share on other sites

Thanks for your help. All the other emulators seem fine. I went with this AMD configuration based on ETAPrime's results with the same build. Always been and Intel/Nvidia user and I went out on a limb for a super compact build. I'll just keep my fingers crossed for a driver update. :(

Any other 2200G user's experiencing this? Mobo is an MSI B450i.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...